Problem new install rpi0w

Hi everyone.
I have a problem that I haven’t been able to solve for months now. It all started around June 2022, my ha went offline and the ‘cli’ console wasn’t working either. Only the emergency console. I tried various attempts but nothing … then I gave up because of little time.
I am now trying to fix the problem with a fresh install but every attempt fails. I tried to use the same hassos image used in 2021 to install my Ha on a rpi0w but nothing… I tried downloading a new image but nothing… Changed sdcard… Changed power supply, changed router… Nothing!
This happens:
Flash the sdcard, start my rpi and leave it for a couple of hours, then try to access from the web interface but still get the same error:
" INFO: Supervisor after closing "
Tried letting it charge for over 4 hours, still same error looping. The " cli " works but it waits for “supervisor” to start and then the message appears: Get http://supervisor/network/info: Dial TCP connect: no route ti host"
So I tried to reboot…
After reboot nothing works anymore… offline again (connected to the network but no response from the web interface " and emergency console again.
I’ve already tried to install everything 4 times and always the exact same result…
I tried to follow various solutions found on the forum but nothing works…
Does anyone have any suggestions?
If you need information, ask, I’m not very expert but if you tell me step by step what you need I can do it.
Thanks a lot to everyone.

You can’t install HA on RPI zero W by normal means anymore. People have done it through DietPi. Search the forum for it.

I was afraid this was the problem :pensive:
It worked for 2 years and now I don’t understand why I can’t use it anymore like I always have.???
So DietPi would be a light Debian… and then I install Ha… sort of like this?

You can install HA Container (native Docker) or Core (pip install) on that, just not HAOS (or Supervised).

However, it’s terribly under powered and lacking in RAM. It will not be a good experience, and you’re likely to run into issues when it runs out of RAM - which is likely to happen a lot.

Thanks a lot for the replies.
What makes me angry is that I used it until June of last year and it has always worked great. It stayed on for years without ever rebooting and I was installing haos.
Now I will try to install Ha container…

HA is constantly changing, while once 512 MB of RAM was enough those days are past. Do expect visits from the OOM killer.

I have a dev setup on a Pi0W.

From experience, do not install the container version. Install Core. Docker adds a lot of overhead and uses additional memory. And memory is an absolute premium on the Pi0W, so don’t waste it on that. You will want the little RAM you have to be entirely available to HA and not for container management. Also remove all built-in integrations you don’t use (things like auto discovery, etc).

It’s still a slow and suboptimal platform for HA.

I can understand that evolution is mandatory… but I don’t understand why if something works suddenly it shouldn’t work anymore when in the end I don’t care about having the latest version of Haos… Even if everything worked up to version 9. .
A bit like an old computer where you can install Windows 7 but not Windows 11… on that computer even in 10 years you will be able to install Windows, 7 and it will work!

You can grab an old version of HAOS and install it, nothing stopping you. Other than when you upgrade HA or install any add-ons you’ll likely run out of RAM.

Oh, and that the install is likely to take 12 to 24 hours.

I was installing the same version I started with more than a year ago… exactly 5.10… the problem is that the supervisor goes into a loop and doesn’t even complete the installation.
I would settle for the 5.10 I had before.
But it doesn’t work anymore and I don’t understand exactly why. I also tried 6.6 which is the latest that has been released for the rpi0w. Look at the photos, maybe you can think of a reason why it does this.

Unfortunately I don’t use HAOS, so my ability to troubleshoot based off of images is effectively zero.

@Spiro says it’s not possible anymore. But I don’t understand the reasons if I use an old version for working.

Check out this old thread.
Raspberry Pi 0 W

Yes, read it all before posting a new thread.
Now of course I’ll try to do so… Although it’s not the same as mounting a haos and I’ve already read that I could still have complications.