Raspberry Pi 0 W

Hi All,
I need your help , puzzled me for days . I had a Raspberry Pi 0 w with Home Assistant OS 4.12 to control 2 zig bee lights which flawlessly working for 2.5 years. Because of the power supply problem
Pi board and SD card got fried and broken.
So I am trying to have fresh install on my new Raspberry Pi 0 w with HASS OS 4.12, it is going to "preparing Home Installation " web page for 20 minutes , but never to go onboarding welcome configuration page .
At the end I can still ping the PI board , but nothing on web page http://ipaddressPi0:8123
Also I tried with different new Pi 0 w boards, SD cards as well , but no luck

I am aware it is not recommended hardware , just want to replace with same board and image, which was worked for 2.5 years

Do I miss any step here ? What I can remember suppose very straight forward : flash SD card , create CONFIG/network/my-network, leave Pi Board for 20-30 minutes.

Please advise and Thank you

Try using a different browser. I think I had problem with chrome. Onboarding just never showed up. I think I used EDGE. HASS OS 6.6 is the last that will work on Pi 0 w. Core-2021.9.7 is last to work.

I am using the Pi0W too indeed with hass OS 6.6. Updating up to 2202.6.7 went fine but after this version the web-interface does not work, port 8123 is not open anymore.
a.f.a.i.n. you cannot do a fresh install from the OS6.6 pi0w image because it always downloads the latest version so 2022.7.7 currently. It fails to start 1 task which avoids you to stop the core and upload a backup. I had a 2nd Pi0w running and copied the full SD card to re-install the backup of 2200607. This is ofcourse a temporary solution. Try to get my hands on a Pi0w2 but they aren’t available. Like this solution for my motorhome because if the small size and lower power consumption compared to a Pi3B

1 Like

If you can connect a keyboard and monitor to the Pi you could try

ha core update --version=2202.6.7

at the command line.

Nope, this does not work. It tells it finishes successfully really fast but does not doe a thing. If you say core stop it tells there is a pending task and therefore it will not stop. I suspect the Python update is causing this.

I have a similar behavior: installed a preconfigured image following this how-to:
On initial boot I get to the ‘preparing home assistant’ page under the URL http://ip:8123. Tried to access it with different browsers on different devices.
However, after a while this page is no more accessible, but the observer is.
On the HA CLI I constantly get messages:

@taste I am trying with popular OS 4.12 and it does not work either. As @christianbr mentioning below .
No luck with OS 4.19 ,5.13, and 6.6 . I can understand with latest image , but why this effecting on previous images OS , unless during install always need update to latest : eg Python

Just nope question: on general can I install Haas OS without internet connection at all ?

Worst comes to worst you could try what @taste did. Someone clone a working RPIzerow and clean out anything that belongs to them from the copy ,change password and you download the image from public google drive. If you can trust the image.

The problem is the onboarding script always downloads the latest core version. Without hacking into the DNS I would not know how to avoid that unless you could add a text file to indicate the version you want similar to getting the Wifi Settings

Not sure if it’s the HA OS or the supervisor having issues here, but the latest core 2022.7.7 is running fine on a Pi Zero W here (in a Python venv).



Hi @HeyImAlex , what version OS lite Raspberry PI do you use ?

There’s only one version of Raspberry Pi OS Lite available for the Pi0. So that one.

I am able to make it work, fresh install Hass OS on Pi 0 W with latest core 2022.7.7 with Raspi OS lite 2022-01-28 as explained https://www.home-assistant.io/installation/raspberrypi#install-home-assistant-core
Thank you all your help and sharing @taste @Spiro @HeyImAlex @christianbr


Great news. Could you reload your old backup on to it or do you have to start all again with your config?

Most likely go start over again. I am still digging if any back up ever made. 2 Zigbee lights only.

This sounds good, did not think of this for sure something to use until the rpi0W2 is available again (below $90, what is now asked for it)

By installing core only, cant have supervisor and add-ons . Top of my 2 Zig bee lights , I want to add status of input to monitor side gate / to GPIO of Pi.
I just know HA had been removed Integration of Raspberry GPIO from the core :face_with_raised_eyebrow:
Any work around for HA core installation , to get integration Raspberry GPIO now ?

how do you access the pi ?? by putty or anything else?

@tensopiseth by ssh Putty

hmm i still won’t be able to make it work… even through Putty.