Problem with installation on Raspberry PI4

Tags: #<Tag:0x00007fc42f9d64d0>

Hi,
I am trying to install Home Assistant on a Raspberry PI4 and it gets to the point where it says “Waiting for the Home Assistant CLI to be ready”; [WARN] Home Assistant CLI not starting! Jump into emergency console…
The instructions say:
4. Within a few minutes you will be able to reach Home Assistant on homeassistant.local:8123. If you are running an older Windows version or have a stricter network configuration, you might need to access Home Assistant at homeassistant:8123 or http://X.X.X.X:8123 (replace X.X.X.X with your Raspberry Pi’s IP address).
With the Home Assistant Operating System installed and accessible you can continue with onboarding.

I must be missing a step. I left it for 12 hours as suggested elsewhere but no change. I can see it in my router and it does have an IP address if that makes a difference.
Can someone please please please point me in the right direction?
I am a novice in Linux so please go easy on me…

Others also experience the same error CLI not starting on new install. Maybe try to do what those guys are doing there, some people got it fixed.

Hope it gets resolved soon :slight_smile:

Yes I saw that. That thread assumes that one has a lot of Linux knowledge I think.
The other thing is that I don’t see anything in that thread that someone has found a solution.
Hoping for a solution from someone in plain English for a Linux novice. I don’t want to try too many things just yet as I may messing it up even worse.
I am well and truly at the bottom of the food chain here.
I dont want to cry ‘poor me’ either, just looking for guidance.

Have you tried installing a previous release. That would be the easiest to do if you are not fluent in Linux…
So, get the latest 5.13 image: https://github.com/home-assistant/operating-system/releases/download/5.13/hassos_rpi4-64-5.13.img.xz

Apparently, something weird in this 6.1 release. Not sure what, I’m not using HAOS…

Thanks, I will try that.
Very much appreciate the help.

Before doing a new install with an older version, I thought I would try some of the things mentioned in the other thread re. time and date.
For a start, time and date was wrong so I fixed that but the time zone is wrong and I can’t change it. I try: timedatectl set-timezone Australia/Sydney
I get: Failed to set time zone: Failed to set time zone: Read-only file system

AHA!!! After rebooting, I now get a logo of sorts in the terminal window that says:
‘Home Assistant’
Welcome to the Home Assistant command line.
System information with IP address,etc…

OS version: Home Assistant OS 6.1
Home Assistant Core: landingpage
Home Assistant URL: http://homeassistant.local:8123
Observer URL: http://homeassistant.local:4357
ha >

EDIT:
Never mind, I managed to start the Onboarding. I will let everyone know how it turns out.

EDIT 2: I now have a Home Assistant dashboard working and I am guessing that I have some learning to do.
Thanks everyone.

How did you get past this error? Would you mind to write what you did so others can learn if they encounter the same error?

Many thanks and enjoy HA! :slight_smile:

All I did was to make sure that time and date was set right (I messed the time up a little the first time) and rebooted and it came up OK.
I never managed to change the time zone due to the Read-only but it seems that its not needed.
Once the Onboarding process starts, there is a field where the location is set anyway so I guess it gets the time zone from there.

1 Like