Problems connecting to GUI

Hi. This is my first post, I’m new to HA and also doing anything this technical as I’m not a coder or anything.

I bought a pi 3+ recently and managed to install HA on it (I tried just installing regular Pi OS before that to check the Pi worked ok and it seemed to be alright). The installation was done on a Mac using the official Pi installer and the Pi is currently on 5V power and connected with an ethernet cable to my router.

I can see the Pi’s IP address on my network and when I ping it, it returns immediatley with no loss, but weirdly, similarly to this post, I can’t access it in the browser. I’ve tried several ways of accessing it - http://homeassistant.local:8123 and also using the IP address of the Pi in the browser. I get the same kinds of errors as on the post mentioned above.

Can anyone please help me? I’ve even tried reinstalling home assistant on the Pi via the official Pi installer a second time but I’m still getting the same problem.

Thanks in advance.