Can't connect to homeassistant:8123

I have recently tried to access home assistant running on my Raspberry Pi 3B but I receive the following error in my browser:

This site can’t be reached
homeassistant ’s server IP address could not be found.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).
    DNS_PROBE_FINISHED_NXDOMAIN

The software is working, as I can see it continues to run the automatons I’ve set. I can’t seem to find it on my IP network and connecting via Ethernet makes no difference either. Is there any way to fix this? Or is my Pi broken?

What address are you trying to access?

How is your home assistant network set up? DuckDNS, Nabu Casa, just local or some other method?

Hey Tom, I’m trying to access home assistant via http://homeassistant:8123

The network is just my local network that I provided the raspberry pi access to when I set up the device some time ago.

1 Like

Try accessing it by the ip address.

e.g.

http://10.1.1.100:8123

You should have access now, following tom_l advice. For reference though, you were missing the .local from your url http://homeassistant.local:8123

http://homeassistant.local:8123 isnt working for me either, I should also add that i previously was able to access home assistant from the http://homeassistant:8123 address

I can’t seem to find the ip address on my router

Is the network cable plugged in to the pi?

Are there flashing LEDs on the pi?

Install Fing on your phone. It’s a great app to find devices on your network.

Still can’t find it even when using fing :confused:

It’s connected via wifi, which hasn’t been an issue until i tried to access it recently. The Pi’s red power light is on and the green light triggers sporadically like it usually does.

Connecting a server via wifi is not a good idea. It’ll work, but it’s not optimal.

Does your router have wifi clients list?

My bad, I didn’t realise that was an acceptable url. Seems strange you can’t find the ip with Fing. That suggests your Pi is on a different network to your phone. Might be worth connecting directly to the router with ethernet and then trying to find on your router again. If your router supports it, you could fix that ip and make a note of it for future reference. Might be worth considering the DuckDNS add-on as well, once you get it sorted :+1:

Not sure, I’ve just been checking the router activity via Fing and it shows every device but the Pi.

I tried connecting the Pi with an ethernet cable and it made no difference in being able to connect wirelessly.

Got a spare keyboard and monitor you can plug in?

Hit the enter key to interrupt the dmesg log. Sign in as “root”. There is no password. You will then be at a CLI where you can look at logs, restart safely, and even fix network settings.

So I plugged the pi directly into my router and was able to see it on the network and see its ip address. However, i still can’t connect to it. This makes me think the wireless capability of the pi might be broken?

Is there anything else you’d recommend before replacing the pi?

Using the attached keyboard and monitor you can set up the wifi using nmcil.

You can ignore all the SSH connection instructions and work directly from the CLI on the monitor.

Really though wifi is a poor connection method for a server and you should be using a cabled connection.

Unfortunately I don’t have a spare monitor or keyboard and ethernet isn’t really a permanent option. What’s most confusing is that it has been working perfectly for a number of months and has only recently stopped connecting. Could there be an issue with the router?

I’ve now tried another pi and i cant connect to that either, so that rules out the pi as the issue.

So I’m able to connect to the Pi briefly after rebooting it but then shortly after I can no longer connect. Does this narrow down the issue at all? I’m still confused as ever about this.

Hi, I’m facing the same problem, but i have a Pi 4B, did you find a solution?
If u did please mention it cuz i was searching for a solution for 2 days and couldn’t find anything.

Thank You