Problems settings up recorder and glances after restart (maybe because of hass.io supervisor 178?)

Hi,

HA cant setup recorder/history/logbook because of an error with the mariadb addon.
I reinstalled mariadb and I restored an 1 day old snapshot. But still problems. If I disable Mariadb it starts working again. Thats the log.

2019-08-16 20:30:58 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:01 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:04 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:07 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:08 WARNING (MainThread) [homeassistant.setup] Setup of recorder is taking over 10 seconds.
2019-08-16 20:31:10 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:13 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:16 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")
(Background on this error at: http://sqlalche.me/e/e3q8) (retrying in 3 seconds)
2019-08-16 20:31:19 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: (MySQLdb._exceptions.OperationalError) (2002, "Can't connect to MySQL server on 'core-mariadb' (115)")

Similar happend to the Glance component. The glance WebUI works as expected, but HA cant setup the component anymore.

Edit:
update hass.io supervisor to 179 did not fix the issue

Edit2:
Glances is still accessable via WebUI with ingress, but not direcly via IP and manuell port. So HA cant setup the component because thats not working.

Edit3:
Other addons (portainer) also not working with manuell port and local ip. Ingress is working fine. Something happend…

Edit4:
OK I downgraded the Supervisor to 173 and everything starts working for a short period (because the supervisor updates automatically to the lastest)
So all of this caused by the new Superversion Version starts with 174

Got that with supervisor 177. V178 seemed to solve it. Have V179 now but havn’t restarted anything after that.

I have supervisor 179. Still same issue

See this:

And

Same issue with mariadb. It appears to start occurring after I updated to the latest version of hass.io.

After the update to supervisor 181 set your DNS server. Or it will be trying to use 1.1.1.1 and 9.9.9.9 which may be blocked in your network if you use pi-hole or some other local DNS.

Supervisor 181 fixes the problems for me with addon and local IP+Port connection.
The MariaDB issue still exists.

For any reason, the hassio dns server is not set to 9.9.9.9. I set my dns server to pihole DNS. So hassio should choose 9.9.9.9 and 1.1.1.1.

Make sure your SSH addon is up to date and then issue these commands:

  • hassio dns options --servers dns://IP_ADDRESS
  • hassio dns restart

Where IP_ADDRESS is your Pi-hole ip address.

I found a fix that works for me.

I change the host name from “homeassistant” to “core-mariadb”.

“homeassistant” is what they have in https://www.home-assistant.io/addons/mariadb/
which worked before but not recently.

I am using a raspberry pi 3 with hass.io installed.

did not work for me. Can you please post your addon config and your configuration.yaml setting? Thanks a lot

{
  "databases": [
    "homeassistant"
  ],
  "logins": [
    {
      "username": "hass",
      "host": "core-mariadb",
      "password": "securePassword"
    }
  ],
  "rights": [
    {
      "username": "hass",
      "host": "core-mariadb",
      "database": "homeassistant",
      "grant": "ALL PRIVILEGES ON"
    }
  ]
}
recorder:
  db_url: mysql://hass:[email protected]/homeassistant?charset=utf8

I hope this helps.