Problems upgrading to .86.x?

Hello, I’m trying to upgrade from 85.1 to 86.2 and i’m having weird issues. Simple enough to upgrade right? Clicked upgrade in the tab. Then i watch in portainer and i can see the 85.1 container get deleted and the 86.2 get created. Give it about 10 minutes and then it reverts back to 85.1 container and kills the 86.2 one. I’m not even sure where to look at logs. The HA logs get erased after it reboots, I’ve tried to catch them and haven’t been able to. The portainer logs don’t really give me much. Any ideas on where i can look or what I can do? I read something somewhere that it could be memory, but i have 4GB on this Ubuntu 18.10 VM so I’m not sure if that would be true in this case.

I’m piling on your thread because my 85.1 to 86.1 failed and took a hard power cycle (hassio on rpi) to get it to respond. When it came back online, it was back to 85.1. At a loss as to what to do as well, other than ignore the update for now

Jump on. I had the same issue with going to 86.1 and also 86.2. I was hoping it was something that would get fixed in the next release, but I wasn’t so lucky.

I am having the same issue. on 85.1 update to 86.1 fails with message in log

WARNING (MainThread) [hassio.homeassistant] Don't wait anymore of Home Assistant startup!
CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!

Have tried several times including restarting host.

Same issue here as well from 0.85.1 -> 0.86.2

I have heard this before, but they didn’t talk about memory, they talked about diskspace. Do you have enough diskspace on your home assistant install? It could also be RAM related, but I don’t think so, I use 4GB on my setup as well with 6 virtual processors (though it is on a Ubuntu VM).

I have about 8GB space free (30%)…

I can throw some more disk space at it. That’s a good idea. I’ll post back if it changes anything.

I’d imagine it would be enough, though my own hass setup uses over 25GB of space (that is including the underlying Ubuntu install).

I have checked some other threads for you, and some say it is related to some breaking changes. In their particular case it was about OwnTracks, however that was a few releases ago. Did you thoroughly checked the breaking changes in this version? And in particular automations with a time trigger.

Another change is that entities can no longer end with an underscore (i.e. light.bathroom_) these entities are no longer allowed and will make your setup fail to start. If you had entities like this, remove the underscore in every page you had it set up (i.e. in automations, groups, customize, etc) Home Assistant automatically removed the underscore from the existing entities, but it won’t touch your config files so you will need to make sure these are correct.

Also check other breaking changes that might apply to your setup (for me it was just the underscores and one time trigger).

1 Like

I must have missed the underscore one! Nice catch. I don’t have any ending underscores but I do have some double underscores. I’m going to remove them and I bet you that will do it! I’ll post back in a few.

Tried all of those things. Actually removed all configuration.yaml entries other than the basic ones needed to run HA. Still will not update.

Seems to be the same for me. I’m scouring the breaking changes now to see if I missed anymore…

Mine fails too, 0.85.1 - 0.86.2 running in docker on NUC i3

So I commented out the following lines:

automation: !include automations.yaml

sensor: !include sensors.yaml

I also manually removed all of the “__” (double underscores) in both the core.entity_registry and fixed all of the corresponding entities in the lovelace cards. My upgrade went through!

Once i was up and stable on 86.2 I started adding my !include files back one by one. All of them are currently added in and I’m working perfectly fine. The only thing I can tell you is to look for entities starting or ending with an underscore or have a double underscore in it. That seemed to get me up and able to do the upgrade.

getting the same on my nuc i5 and ive even commented out automation and scripts

19-01-25 21:40:35 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.86.2
19-01-25 21:40:35 INFO (SyncWorker_16) [hassio.docker.interface] Update Docker 0.85.1 with homeassistant/intel-nuc-homeassistant:0.86.2
19-01-25 21:40:35 INFO (SyncWorker_16) [hassio.docker.interface] Pull image homeassistant/intel-nuc-homeassistant tag 0.86.2.
19-01-25 21:41:07 INFO (SyncWorker_16) [hassio.docker.interface] Tag image homeassistant/intel-nuc-homeassistant with version 0.86.2 as latest
19-01-25 21:41:07 INFO (SyncWorker_16) [hassio.docker.interface] Stop homeassistant/intel-nuc-homeassistant Docker application
19-01-25 21:41:38 INFO (SyncWorker_16) [hassio.docker.interface] Clean homeassistant/intel-nuc-homeassistant Docker application
19-01-25 21:41:38 INFO (SyncWorker_16) [hassio.docker.interface] Cleanup Docker images: [‘homeassistant/intel-nuc-homeassistant:0.85.1’]
19-01-25 21:41:39 INFO (SyncWorker_5) [hassio.docker.homeassistant] Start homeassistant homeassistant/intel-nuc-homeassistant with version 0.86.2
19-01-25 21:51:40 WARNING (MainThread) [hassio.homeassistant] Don’t wait anymore of Home Assistant startup!
19-01-25 21:51:40 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!
19-01-25 21:51:40 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.85.1
19-01-25 21:51:40 INFO (SyncWorker_1) [hassio.docker.interface] Update Docker 0.86.2 with homeassistant/intel-nuc-homeassistant:0.85.1
19-01-25 21:51:40 INFO (SyncWorker_1) [hassio.docker.interface] Pull image homeassistant/intel-nuc-homeassistant tag 0.85.1.

OK… this took forever to figure out but I finally got the update to take. As every one has been pointing out, it was the underscore issue that was killing me.

I hunted through all my config files, sensors.yaml, etc, and finally found two entities that had trailing underscores. They were from the systemmonitor sensor. For some reason the two disk space sensors had trailing underscores. So I fixed them and I’m thinking all is well… Try the update again but it still won’t update.

It turns out that at some point I had used the customization function to change an attribute on each of these. The customizations are stored in customize.yaml. I removed the trailing underscores from that file and like magic the update took.

What really helped finding this was watching the home-assistant.log file while the update is happening. When 86.2 was trying to start up I could see it throw the error for the entity with the underscore. If you wait until it rollsback to 85.1 it will overwrite the error messages in the log. You need to make sure you check the file after 86.2 tries to start but before the rollback happens. Once I had the name of the entity that was broken, I used the “find in files” function of the cloud 9 editor and it led me right to customize.yaml.

Hope that helps others in the same boat.

1 Like

Ah that’s good advice!
Also explains why you have been dragging your feet pushing the new dark-sky card :joy:
I had those system monitor things but they got me in 0.85…
How does your darksky card look with the defaults under 0.86.x?

The Temp was mis-aligned like yours was. I just updated the card on github with modified defaults for the temp top-margin… will post in the other thread shortly.

1 Like

component/hassio/__init__py(ERROR) is in the log.
How do i fix this?

Since 86.0 of Home Assistant the double underscores ‘__’ in entity names is not working anymore. Upgrading to that release is bringing to the following error (leaving the installed release unchanched):

19-01-24 20:27:12 INFO (SyncWorker_5) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.86.1
19-01-24 20:37:17 WARNING (MainThread) [hassio.homeassistant] Don’t wait anymore of Home Assistant startup!
19-01-24 20:37:17 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!

I looked for that kind of entities but on my files (entities and yaml) there is nothing, but found it in in:
the following double underscores:
“config_entry_id”: null,
“device_id”: “b51673ebc222482a9af12804ee6d36f0”,
“disabled_by”: null,
“entity_id”: “sensor.internetgatewaydevicev2__aimcenter_packets_sent” ,
“name”: null,
“platform”: “upnp”,
“unique_id”: “uuid:75802409-bccb-40e7-9f6c-C02506F0DD00_packets_sent”

aimcenter is my FritzBox 7490 Internet Router and in configuration.yaml was net monitor installed and working.

By the way, I did comment the net monitoring sensor of my FritzBox Router so that this sensor is no longer active. Anyhow the entries in the core.entity_registry is still there and the result is: no upgrade/remains on 85.1.

Has this to be changed on the Fritz Net Monitor Component? Or how and where can I edit this (as we are not supposed to change the storages)? Who names this ‘__aimcenter_packets_sent’ (with double underscores) which is an activity and not an entity? Does this block the upgrade?

Thanks a lot.