Problems with Apple TV 4K status in HA

Hello all,

I’m still fairly new here and like to experiment with HA.

But now I also run into a problem with apple tv 4k.

Installed beta version and integrated apple TV into HA.

But if the Apple TV is turned off for a while and I turn it back on, it always stays on STANDBY in HA and does not change to PLAYING or IDLE!!! No matter what I do it stays on STANDBY.

If I restart HA everything works normally again. Does anyone have an idea how I solve this?

Thank you for your response.

This is a known bug that I have not had time to fix, I’ll try to do that tomorrow or so. You need to reload the integration to make it work again.

OK thank you. I thought it was my ignorance. :smiley: :rofl: :rofl: :rofl:

It’s not :wink: Fix is here if you want to follow progress:

Thank you for your response, but I don’t understand all this yet, I’m not that far with HA yet.

Am I understanding correctly that the problem is now solved?

It will be resolved in the release coming out tonight. I will try to push the changes to the beta repo as well.

Thank you very much for your response. fine, I’ll wait until tomorrow and test it then.

Custom component is updated now as well.

Fantastic, it works great :rofl: :rofl: :ok_hand: :ok_hand:
thank you very much


I thought the problem was solved, but since last night I have the same problem again. Do you have an idea what I’m doing wrong?

Did you try restarting the Apple TV?

Thanks for your response

I turned it off but didn’t restart it.

Do you think that would help?

First of all thank you for your work, I am excited to see this as auto discovered item and can add it through configuration easily. I have setup a automation where it will turn my bedroom lights to a certain scene when we turn our apple tv on after 8 pm…It didnt fire the first night we used it (three nights ago) When I look into history I see Standby, Idle and Playing…My automation is set to fire the scene when the apple tv is turned on…I dont see that in the History though, did I do something wrong? Also is there a way to get certain apps names? it would be so cool to do something like when we play netflix have lights turn red, etc.

1 Like

Thanks for your response.

Been on vacation for a few days. But it doesn’t really work for me yet.
I restarted the apple tv and then it works, but if I turn it off for a few hours and turn it back on, it remains “STANDBY” again. What am I doing wrong? Can you help me with this problem? :innocent:

Hello, everyone, does anyone know if this problem has already been solved? Thank you for your response.

Experiencing the issue too. Reload does the trick to bring it back for some time. Any ideas on a resolution coming?
Thanks for the great work

Are you running the beta component from HACS? If you are, start by removing that.


Do you mean I need to uninstall Apple TV Beta?

Thanks for all the work.

Yes, it is very old.

Thanks for your response, which integration should I set up?