Push Notifications now available!

I’m using the app through Nabu Casa, and the new service doesn’t show after following instructions. Should this work through Nabu Casa as well?

Mine seems to work through nabu casa

1 Like

I did all the above and the service still does not appear. I am running HA 0.103.0.

Update: Uninstalled and reinstalled, Cleared data/cache. Works now.


Turns out I used the app for a while without enabling mobile app component. I never had “default_config:” in my configuration.yaml. after adding this, restart, logging out and in in the app and another restart, everything is there, also through Nabu Casa. Great new features! No need for gmaps integration anymore :slight_smile:


Ok, so the service is there, but calling it with

title: "title"
message: "message"

I do not get any notification.

I discovered, that the app has no notifications registered in Android 10.

Could this be the problem?

Wow cool, nice feature, allthough still waiting for image/url options… Looking forward to it

1 Like

This is awesome. Been waiting to move off my HTML5 notifications into native app. Any chance we’ll be able to name our device in the future so the service name can be “notify.mobile_app_myownname” instead of “*phonemodel#”?

So I found this line in my log:

components/mobile_app/notify.py not found

This would explain the lack of notifications :sunglasses:

Why would this component be missing. I’m on hassio 0.103.

Yeah, same request here… My wife and I have the same phone model, and this change makes it so that only one of us can get notifications

Turns out, my phone is registered four times under “devices”. This is propably the reason for the previous log entry. Only, there is no way of deleting these device registrations.

Sorry for spamming this thread.

After also deleting the multiple integrations, the devices are gone as well and I have a clean slate.
Then after linking the app to HA again the notifications work.

The notification icon is VERY tiny and not recognizable =-O

1 Like

yes you can, at least in my mobile I can do it. Go to the settings, notification and choose the HA app. There you can setup the sound you prefer

This is fixed in the latest commit

1 Like

Thanks! Strange… my wifes mobile has been discovered (two instances) in HA but my mobile doesn’t show up, have tried to add “mobile_app” manually in config but no difference. Maybe has to open new post for this.

Nothing to add, either change the name on the phone or under Devices in HA.

Also had double entities in the core.config_entities file. Worked after removing one of them.

A bug possibly?

Do actionable notifications work yet? If so, what is the syntax for creating actions?

1 Like

No not yet. Only title and message.

It’s there in the first post…