Python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you'll have pycryptodome 3.6.0 which is incompatible

When doing a pip3 install --upgrade homeassistant i get

python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you'll have pycryptodome 3.6.0 which is incompatible.

Till now, i’ve only did normal system updates. How do i solve this?

First of all, did you enable the HA virtual environment before doing the pip command?

Have you tried to install something else in the HA virtual environment?

Hi. Yes, i did you enable the HA virtual environment before doing the pip command. And i think i don’t have anything else installed in the HA venv.

Hi.

I can also confirm this, I get this error:

python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you’ll have pycryptodome 3.5.1 which is incompatible

I’ve enabled the HA virtual environment as usual, no extra installations attempted.

Regards.

PS: This is with an Archlinux install, I know it’s not Hassbian… but the error is related.

I’ve started seeing this too starting with 0.67 - no extras installed

edit: I forgot to note, I get the same message as @DNKROZ shows above.

I did have the same error during upgrade to 0.67.1 and also have checked from the general session at discord. They said it has no effect to HA. Just ignore the error.

1 Like

I did have the same error during upgrade to 0.67.1 and also have checked from the general session at discord. They said it has no effect to HA. Just ignore the error.

You still can upgrade and load HA normally.

How can i ‘still upgrade HA’? When i do a “pip3 install --upgrade homeassistant”, the error makes it so the upgrade stops:

(homeassistant) [email protected]:/home/pi $ pip3 install --upgrade homeassistant
Looking in indexes: https://pypi.python.org/simple, https://www.piwheels.org/simple
Requirement already up-to-date: homeassistant in /srv/homeassistant/lib/python3.5/site-packages (0.67.1)
Requirement not upgraded as not directly required: pytz>=2017.02 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (2018.4)
Requirement not upgraded as not directly required: attrs==17.4.0 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (17.4.0)
Requirement not upgraded as not directly required: jinja2>=2.10 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (2.10)
Requirement not upgraded as not directly required: requests==2.18.4 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (2.18.4)
Requirement not upgraded as not directly required: aiohttp==3.1.1 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (3.1.1)
Requirement not upgraded as not directly required: astral==1.6 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (1.6)
Requirement not upgraded as not directly required: voluptuous==0.11.1 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (0.11.1)
Requirement not upgraded as not directly required: pip>=8.0.3 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (10.0.0)
Requirement not upgraded as not directly required: async-timeout==2.0.1 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (2.0.1)
Requirement not upgraded as not directly required: pyyaml<4,>=3.11 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (3.12)
Requirement not upgraded as not directly required: certifi>=2017.4.17 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (2018.4.16)
Requirement not upgraded as not directly required: typing<4,>=3 in /srv/homeassistant/lib/python3.5/site-packages (from homeassistant) (3.6.4)
Requirement not upgraded as not directly required: MarkupSafe>=0.23 in /srv/homeassistant/lib/python3.5/site-packages (from jinja2>=2.10->homeassistant) (1.0)
Requirement not upgraded as not directly required: idna<2.7,>=2.5 in /srv/homeassistant/lib/python3.5/site-packages (from requests==2.18.4->homeassistant) (2.6)
Requirement not upgraded as not directly required: chardet<3.1.0,>=3.0.2 in /srv/homeassistant/lib/python3.5/site-packages (from requests==2.18.4->homeassistant) (3.0.4)
Requirement not upgraded as not directly required: urllib3<1.23,>=1.21.1 in /srv/homeassistant/lib/python3.5/site-packages (from requests==2.18.4->homeassistant) (1.22)
Requirement not upgraded as not directly required: idna-ssl>=1.0 in /srv/homeassistant/lib/python3.5/site-packages (from aiohttp==3.1.1->homeassistant) (1.0.1)
Requirement not upgraded as not directly required: multidict<5.0,>=4.0 in /srv/homeassistant/lib/python3.5/site-packages (from aiohttp==3.1.1->homeassistant) (4.2.0)
Requirement not upgraded as not directly required: yarl<2.0,>=1.0 in /srv/homeassistant/lib/python3.5/site-packages (from aiohttp==3.1.1->homeassistant) (1.1.1)
python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you'll have pycryptodome 3.6.0 which is incompatible.
(homeassistant) [email protected]:/home/pi $ 

How do i make it skip that error?

1 Like

what is your HA current installed version?

For hassbian to upgrade HA
https://www.home-assistant.io/docs/installation/hassbian/common-tasks/#update-home-assistant

command is
$ sudo systemctl stop [email protected]
$ sudo su -s /bin/bash homeassistant
$ source /srv/homeassistant/bin/activate
$ pip3 install --upgrade homeassistant
$ exit
$ sudo systemctl start [email protected]

That is exactly what i always do. And i shared the result of the pip3-step, where it stops at the error/warning-message. I would expect it to finish with a message no updates can be found. I’m currently on 0.67.1.

So you are already on the latest of HA 0.67.1

For the latest update of hassbian-config, here is the link and how to upgrade

Eh, sorry, n00b here, but, what do i need to do when on that URL? Download the 0.9 deb file? Unpack? Where? And what does that do for me?

If you do the fresh hassbian installation that means you already have latest home-assistant and hassbian-scripts.

You don’t need to upgrade hassbian-scripts.

O.k., we’ll see what happens when a new version (0.67.2/0.68) is released…

I forgot to include that while I saw this error, I was able to upgrade and launch HA without issue. I may rebuild my venv though to see if perhaps I mucked up somewhere. Not using Hassbian but rather OpenMediaVault with HA running in a Python3.6 venv.

exactly the same probleme , running on ubuntu systeme with pyton 3.6 venv.
since I upgraded HA on 67.1 version. got this error:
python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you’ll have pycryptodome 3.4.11 which is incompatible.

tested 68.0 same error !
only solution is to downgrade to 66.1 version running well

I did get the same error when trying to upgrade 0.67.1 and also has check from ha discord channel that this error has no effect to ha.

From you error the pycryptodome is lower than what need. So you can uninstall and install the latest version back. After you install the lastest version which I did on 0.67.1 then when HA update to 0.68 you still see the error that you have higher version of pycryptodome needed.

I follow from this https://github.com/home-assistant/home-assistant/issues/12675 / also don’t forget to read down the post from Mr.pvizeli

I follows this step
sudo systemctl stop [email protected]
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 uninstall pycryptodome
pip3 install pycryptodome
exit
sudo systemctl restart [email protected]

Workink now thanks

This is getting better and better:

netdisco 1.2.3 has requirement zeroconf==0.19.1, but you'll have zeroconf 0.20.0 which is incompatible.
python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you'll have pycryptodome 3.6.1 which is incompatible.
broadlink 0.9 has requirement pycryptodome==3.4.11, but you'll have pycryptodome 3.6.1 which is incompatible.

That means I need the old and the older version, but not the neweset what you suggested to install (used your codes)

So whats now?

I tried to use everything latest as long as everything still works fine. So pycryptodome is lastest. The uncompatible shows only during some upgrade but as long as my devices still works. I’m ok with such error. I have asked about this in discord channel and they said it is no effect ha.