Python3 high CPU Usage

Did it actually help?

ya, it did…but now i have to reconfigure the years of work that i had in. i first tried reinstalling, then restoring, but i had the same issue. Now i’m trying to configure everything i can in the UI first, then copying what i can out of my old config, automations, scripts etc.

i actually came across your post yesterday, and saw that you were thinking about it. that’s when i made up my mind…

I just had tried something new.
I removed the default_config: in my configuration.yaml.

Previously i tried already disabling all my components one by one, but wasnt able to narrow it down.

However, since removing default_config: my CPU Usage is MUCH lower.
HomeAssistant process is around 20% instead of 100%.
I do suspect the ssdp: but i will try to activate one by one all of the components in the default_config: and see where this leads me.


Found it… its the zeroconf:

When i add this one back to my config, it immediately uses a lot of CPU power.
Without it everything is fine. Now to find out why.


In my case I removed Z-wave configuration from configuration.yaml and added as a component and I have been running Home Assistant for 3 days without any issues.

that seems to solve it for me too! Running on docker inside an Ubuntu Server on ESXI.

Should have been fixed by 110.4 update. However, i also found that if I add my System to more than one VLAN HomeAssistant will use a lot more CPU Power. Zeroconf on or off.

I was still having this issue on 110.4. Do you mean you’re having the issue if you add the container to multiple networks? Or the actual host machine?

Yes if my host machine is in multiple networks, homeassistant goes crazy with CPU usage. I tried it several times, and as soon as I add an aditional VLAN the CPU usage goes up substantially.

This problem can be caused by any misbehaving integration so posting a py-spy is the best way to help narrow it down.

If its a zeroconf issue, hopefully it should be sorted out in which should be in 0.111 next week

Can you get an strace -f -p <pid> -s 4096 and look for mdns traffic?

Hi all,
i’m currently having the same issue: HA runs ok for about 13 hour and then become unresponsive and very very slow.
Htop shows 100+ usage on python3 home assistant.

Tried to disable all the plugins and integrations without success. Default_config is not present in my config.yaml

I runned a py-spy and this is the result:

Can anyone help me to read the data on the image?

I’m running hassio in docker on a ubuntu server machine hosted in a vmware esxi server.
I’m using hassio in a VLAN IOT but i’m passing the IOT VLAN as untegged one to the ubuntu VM, so only one LAN.


1 Like

Can you run another py-spy with a duration of 360 seconds?

Also please open an issue report with aiohomekit about the zeroconf call here

Hi, thanks for the reply.
Here the profile for 360 seconds. Note that now the home assistan is working, after i disabled some homekit in the configuration yaml. cpu usage still very high

exatly what is the problem?

Thank you for posting the 360 second recording. I’m working on a PR to fix it here

Sorry for the question but you found the problem? How I solve it? What is exactly my issue?

The issue seen on the recording you posted should be resolved in 0.113

I’m having the same issue with, after 12 hours (with 0.113.2) now after 1 hour with (0.113.3) Any help?

Please post a py-spy.

Also if you have the spotcast custom integration installs, be sure to upgrade.