QNAP entities not showing

I have the following in my configuration.yaml file (no errors showing):


  • platform: qnap
    host: 192.xxx.x.x
    port: 8080
    ssl: false
    verify_ssl: false
    username: xxxxxx
    password: xxxxxx
    • status
    • cpu_usage
    • memory_percent_used
    • network_tx
    • volume_percentage_used

I cannot find any qnap sensors as entities. I have followed the instructions in QNAP - Home Assistant (home-assistant.io)

Home Assistant 2023.3.4
Supervisor 2023.03.1
Operating System 9.5
Frontend 20230309.0 - latest

What am I missing?

Thank you in advance.

It’s impossible to tell from your posted message if there’s a format error of some sort. When adding yaml code to a message, use of a code block is important. It helps us, help you.

Based on what I see, I’d drop these three lines

    port: 8080
    ssl: false
    verify_ssl: false

Reload your configuration file then check for the QNAP attributes.

Sorry about that, not really sure how to do the code block. I will try this:

  - platform: qnap
    host: 192.x.x.x
    # port: 8080
    # ssl: false
    # verify_ssl: false
    username: xxxxx
    password: xxxxx
      - status
      - cpu_usage
      - memory_percent_used
      - network_tx
      - volume_percentage_used

I tried blocking those you mentioned above out, no entities showing.
Looking for guidance…

The code looks okay… although I’d remove, not comment out, the lines mentioned previously.

Have you checked the QNAP logs to see if any errors are listed? Does the username on the QNAP have admin access?

I just removed those lines altogether and restarted HA. Still no entities showing.

I also checked the logs on the QNAP, the only entries are the times I accessed it via the web page.
The username has full admin access.

Just to clarify; all I have done is added the lines to configuration.yaml. Nothing else.
Could it be that something need to be installed or something? I am a noob.

I don’t think so! There is always a learning curve with anything. Seems like your at the begin of the curve on this one. I place myself somewhere in the middle. I know just enough to be dangerous!

I’m not sure what to suggest from here. Would you post a copy of your configuration.yaml file so that I may have a look through it. With exception of user names and passwords, don’t block out information that may be pertinent.

Have you modified any other yaml files? If so, which and how.

Just for certainty - can you verify the IP address of the QNAP matches your code?

One last thing - is your QNAP on the same IP segment as Home Assistant?

Thank you for doing this, very much appreciated.
Here is my configuration.yaml:

  - platform: google_translate
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    service_name: google_say
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
  - name: Home
    latitude: -33.xxxxxxxx
    longitude: 150.xxxxxx
    radius: 100
    icon: mdi:castle
  client_id: 7A71F5A07126003B78A9D235EABC19A3BFB9848262C8694E6A7CEE72857D3EE9
  client_secret: 41C856BC412BCAEC535355D212BBBE29F31B7FC1E8529BEB0BEA3950C2CF5C5F
  # name_template: $Bosch $dishwasher $bosch_dishwasher
  language: en
  sensor_value_translation: local
  - platform: qnap
    username: xxxxxxxxx
    password: xxxxxxxxx
      - status
      - cpu_usage
      - memory_percent_used
      - network_tx
      - volume_percentage_used
  - platform: command_line
    name: Raspberry CPU Temperature
    command: cat /sys/class/thermal/thermal_zone0/temp
    unit_of_measurement: "°C"
    value_template: "{{ value | multiply(0.001) | round(2) }}"

Also modified automations.yaml and scripts.yaml because of course, automations. I could post those as well but I have looked through those and I cannot see anything that even remotely would affect the QNAP integration.
IP address is verified and definitely correct and it is on the same segment as HA (everything is on the same segment at my place).
I am not even getting any error messages in any log files.

Again, thanks for helping.

Is there any chance the IP of your HA instance has been blocked by the QNAP NAS?

I don’t believe so. I couldn’t see anything in the QNAP logs and they usually do show blocked login attempts.
It does my head in.

I have it working! What I did on a whim, I added the port:

  - platform: qnap

Don't know why or how but it now works.


Update to this, this is just for information.
I have 2 QNAPs, one TS451 and one TS221.
The TS451 will not show any of the temperature sensors. It is on firmware 5.0.1. The CPU, memory, volume used and status works.
With the TS221 everything works. On firmware 4.3.3.

I totally rewrote the QNAP integration and moved to ConfigFlow… waiting to be accepted, if you want in the meantime, I posted a repo for HACS

I’d love to get your feedback with the various firmware versions.

I would like to try it. But where can I find it? I could not find it in HACS.
If it is only in GitHub, how do I install it in HA?

UPDATE; I have installed it and it is working for both the TS221 and TS451.

For the TS451 with firmware 5.0.1, I now have a couple of extra sensors. The ones marked NEW didn’t exist before.
CPU usage
Network link 1
Network link 2
Health (NEW)
Memory usage
Network 1 Up
Network 2 Up
System Temperature (NEW)
Volume Used

It would be great to have the drive temperatures for TS451 if possible.

TS221 with firmware 4.3.3:
CPU usage
Network link
Health (NEW)
Memory usage
Temperature Drive 1
Temperature Drive 2
Volume Used

Thank you for doing this, much appreciated.