Qolsys HACS Qolsysgw Configuration help

Hello all,

I’m diving a little deeper into HA, and started to go down the rabbit hole at home.

I have a qolsys panel 4, and learned I might be able to see sensor status via an HACS integration called Qolsysgw.

I’ve tried to follow the directions outline by the Qolsysgw documentation here:

But it makes several references to things I am unfamiliar with and while I’ve done my best I don’t think I’ve got this integration working quiet right.

From the documentation I need to setup an MQTT broker, so I installed mosquitto. Under MQTT, I’ve noted the username and password for the broker under the MQTT settings → reconfigure MQTT button.

Next I installed appdaemon. Using the SSH add on. I found the apps.yaml file and modified it with the settings listed in the Qolsysqw document.

  module: gateway
  class: QolsysGateway
  panel_host: <192.168.X.X>
  panel_token: <XXXXXXXX>
  mqtt_namespace: mqtt

I think found the appdaemon.yaml for Appdaemon. I added the following for MQTT:

  type: mqtt
  namespace: mqtt
  client_host: '192.168.X.X' <-IP for the HA server with MQTT not the Qolsys Panel)
  client_user: 'XXXXXXX' <- found under the MQTT configuration
  client_password: 'XXXXXXX' <- found under the MQTT configuration

Now when I reload Appdaemon, I see the following in the logs:

2024-04-13 05:11:47.736911 INFO AppDaemon: App initialization complete
2024-04-13 05:11:47.736453 WARNING AppDaemon: No app description found for: /config/apps/hello.py - ignoring
2024-04-13 05:11:47.735257 INFO AppDaemon: Adding /config/apps to module import path
2024-04-13 05:11:47.732068 INFO AppDaemon: Scheduler running in realtime

Leads me to believe that the settings in appdaemon.yaml are correct.

At this point I’m hitting a brick wall, I don’t know what to do next. I’ve never used MQTT before, but I am under the impression that if Appdaemon is launching the qolsysgw integration correctly then any sensor found on my qolsys panel should be sent to MQTT. Then under the HA.-> device and services, I should see new discovered entities from MQTT.

I don’t see any errors in the Appdaemon logs, so I assume Qolsysgw is launching correctly. However, I don’t see any new MQTT entities. Additionally the Qolsys panel automatically reboots after 15 mins if it doesn’t receive a remote connection. My panel does this, so I assume its not being connected to by the Qolsysgw integration.

Can anyone point me in the right direction here?

Did you install the qolsysgw package for AppDaemon from HACS?

The AppDaemon logs don’t show the module starting. So it’s either not installed or installed in the wrong location.

1 Like

Yes. I installed HACS, then installed Qolsysgw.

Under the AppDaemon → State page, I see the following under the Apps tab.

I should also note that under the MQTT log tab, I can see that the Appdaemon is connecting to the MQTT broker.

[21:47:18] INFO: Starting AppDaemon...
s6-rc: info: service legacy-services successfully started
2024-04-13 06:47:19.699895 INFO AppDaemon: AppDaemon Version 4.4.2 starting
2024-04-13 06:47:19.700000 INFO AppDaemon: Python version is 3.11.6
2024-04-13 06:47:19.700045 INFO AppDaemon: Configuration read from: /config/appdaemon.yaml
2024-04-13 06:47:19.700097 INFO AppDaemon: Added log: AppDaemon
2024-04-13 06:47:19.700164 INFO AppDaemon: Added log: Error
2024-04-13 06:47:19.700212 INFO AppDaemon: Added log: Access
2024-04-13 06:47:19.700272 INFO AppDaemon: Added log: Diag
2024-04-13 06:47:19.756791 INFO AppDaemon: Loading Plugin HASS using class HassPlugin from module hassplugin
2024-04-13 06:47:19.813310 INFO HASS: HASS Plugin Initializing
2024-04-13 06:47:19.813379 WARNING HASS: ha_url not found in HASS configuration - module not initialized
2024-04-13 06:47:19.813422 INFO HASS: HASS Plugin initialization complete
2024-04-13 06:47:19.813506 INFO AppDaemon: Loading Plugin MQTT using class MqttPlugin from module mqttplugin
2024-04-13 06:47:19.834039 INFO MQTT: MQTT Plugin Initializing
2024-04-13 06:47:19.834110 INFO MQTT: Using 'mqtt-client/status' as Will Topic
2024-04-13 06:47:19.834152 INFO MQTT: Using 'mqtt-client/status' as Birth Topic
2024-04-13 06:47:19.834198 INFO MQTT: Using appdaemon_mqtt_client as Client ID
2024-04-13 06:47:19.834334 INFO AppDaemon: Initializing HTTP
2024-04-13 06:47:19.834428 INFO AppDaemon: Using 'ws' for event stream
2024-04-13 06:47:19.835391 INFO AppDaemon: Starting API
2024-04-13 06:47:19.836174 INFO AppDaemon: Starting Admin Interface
2024-04-13 06:47:19.836262 INFO AppDaemon: Starting Dashboards
2024-04-13 06:47:19.841158 INFO HASS: Connected to Home Assistant 2024.4.3
2024-04-13 06:47:19.843157 INFO MQTT: Connected to Broker at URL 192.168.X.X:1883
2024-04-13 06:47:19.846107 INFO AppDaemon: Got initial state from namespace mqtt
2024-04-13 06:47:19.846203 INFO MQTT: MQTT Plugin initialization complete
2024-04-13 06:47:19.846729 INFO AppDaemon: App 'qolsys_panel' added
2024-04-13 06:47:19.846990 INFO AppDaemon: Found 1 active apps
2024-04-13 06:47:19.847056 INFO AppDaemon: Found 0 inactive apps
2024-04-13 06:47:19.847112 INFO AppDaemon: Found 0 global libraries
2024-04-13 06:47:19.847172 INFO AppDaemon: Starting Apps with 1 workers and 1 pins
2024-04-13 06:47:19.847479 INFO AppDaemon: Running on port 5050
2024-04-13 06:47:19.854853 INFO HASS: Evaluating startup conditions
2024-04-13 06:47:19.857125 INFO HASS: Startup condition met: hass state=RUNNING
2024-04-13 06:47:19.857217 INFO HASS: All startup conditions met
2024-04-13 06:47:19.859909 INFO AppDaemon: Got initial state from namespace default
2024-04-13 06:47:20.024524 INFO AppDaemon: New client Admin Client connected
2024-04-13 06:47:21.850045 INFO AppDaemon: Scheduler running in realtime
2024-04-13 06:47:21.852354 INFO AppDaemon: Adding /config/apps to module import path
2024-04-13 06:47:21.853030 WARNING AppDaemon: No app description found for: /config/apps/hello.py - ignoring
2024-04-13 06:47:21.853284 INFO AppDaemon: App initialization complete

After reading through here:

I realized that the QolsysGW integration was being installed by HACS somewhere else.

Whereas Appdaemon is installed:

I did a recursive CP from:
cp -r /config/appdeamon/apps/qolsysgw to /addon_configs/XXXXXXX_appdaemon/apps

Now everything is working fine.

I find it weird that the dev recommends installing via HACS when HACS itself is creating this problem. But maybe the way I have HA installed is different, and causing weird issues.

Anways everything works now. Yay!

That was the problem I linked to above.


Derp. Friday night, and sick. The niteqil was flowing.

1 Like