Qubino RGBW as 4-channel switch

Tags: #<Tag:0x00007f739a9676b0>

I saw a post on this topic some time ago but can’t seem to find it now. There is a way to make the Qubino RGBW dimmer work as 4 individual DC switches. Here’s how I managed to get it to work.

When the Qubino RGBW controller is included in the z-wave network, it’s added in its default color dimmer mode. To convert it to a 4-channel DC switch, you have to change a parameter. The problem then is that the z-wave configuration doesn’t change to reflect this. So you have to change the z-wave configuration.

Add the controller
Add the Qubino RGBW controller in the usual z-wave way. Note the node id.

Change the parameter
I wrote a script to do this, but then found out it’s easier to use the z-wave ui.

  1. Go to configuration, select z-wave configuration
  2. In the Nodes pulldown, find the node for the Qubino RGBW controller
  3. In Node Config Options, select parameter 14. For Config Value select 2. Click SET CONFIG PARAMETER.

Remove the node
This is the easiest way to get all the changes into the config file. Use the z-wave configuration to remove the Qubino RGBW node.

Modify z-wave configuration
Although you removed the node, it is still in your configuration file. That means that, if you re-add it, it will have the old collor-dimmer configuration and not the 4-channel configuration. So you have to edit the z-wave configuration file to remove the node for the Qubino RGBW controller.

  1. Edit the configuration file. My configuration file is /home/homeassistant/.homeassistant/zwcfg_0xe696b7a9.xml.
  2. Delete the Qubino RGBW node. Everything starting <Node id=“xx”… where xx is the node id. The next few lines should look like this
                <Manufacturer id="159" name="Unknown: id=0159">
                        <Product type="1" id="54" name="Unknown: type=0001, id=0054">
                                <MetaData />
                        </Product>

Be sure you delete it all the way to the corresponding tag before the next <Node tag.
3. Save the configuration file
4. If it’s there, delete the corresponding <Node tag from the cache file (mine is called ozwcache_0xe696b7a9.xml). It shouldn’t have cached the definition yet, but it’s possible.

Restart the server
Restart the server, then add the controller again. This should add the complete 4-channel controller configuration to the z-wave configuration file. You can check the z-wave configuration file again, or you can go to the z-wave configuration page and check the list of parameters. There should be more and different parameters than before. In particular, you should see reference to multichannel and 4 different channels.

Thank you for this guide!

In case someone runs into the same problems as me:

For me, parameter 14 is not in the list for the device, I only have parameter 1-4. Solution was to make the parameter change using zwave.set_config_parameter.

Also, when I tried editing the xml-config to remove the node and then restart and add again, this didn’t work. I had to send the parameter change, remove the node through the zwave-UI in HA, and then just add it back again immediately. No editing of the xml-file. After this it showed up as a 4-channel dimmer.

Thanks for the update! With the changes to HA z-wave support since I did this the first time, I’m not surprised that the process has changed. I will be doing it again very soon, so I really appreciate that you posted. Also, glad to see an alternative to editing the XML - that was the tricky part!