Questions for NUC Users

I have switched form a raspberry pi to an intel NUC running Ubuntu and Home Assistant in a docker. Overall the NUC has been great. It has been stable and Home Assistant restarts are super fast.
Checking that the configuration.yaml file is valid using “Check Config” is pretty much instant. Very nice.

I have a few issues that I can’t seem to figure out. This is probably due to my inexperience with Ubuntu and Linux in general. I have the NUC hard-wired with an ethernet cable to my router.

  1. If I reset the NUC or the power goes out temporarily, the NUC wll restart. When this happens Home Assistant does not start up properly. I believe this is caused by the ethernet port on the NUC being off by default. I have messed around a bunch and tried looking it up, but I am at a loss.

  2. I have an aeotec z-stick for a zwave controller. I have had the USB port change on me as well. (ttyACM0 vs ttyACM1).

  3. I also want to setup some kind of remote access to the NUC for debugging and just playing around when I want to. Maybe something like VNC. I have logged in with VNC before, but it seems to have the same restart issue as #1 above. When the NUC restarts, I no longer have VNC access.

I am hoping some of the other NUC users have some experience they can share.

Thanks,
Jeremy

For item #1, be certain to check your BIOS settings before the computer boots. It’s not entirely likely, but you MIGHT have a setting that disabled the LAN/Ethernet port by default.

For item #3, VNC is one option, but so is Remote Desktop Protocol, RDP.

Edit: sorry didn’t realize you weren’t already using something… I use RealVNC… the mobile app is super helpful in a pinch if something stops working I can just use that to get right in and see what’s going on.

https://www.realvnc.com/en/connect/download/vnc/linux/

For vnc to start on boot I believe I used this… it was awhile ago though…


systemctl enable vncserver-x11-serviced.service

Here is some more info on that
https://www.realvnc.com/en/connect/docs/man/vncserver-x11-serviced.html

And for #1 are you sure it’s “trying” to start HA… maybe your service isn’t set correctly ? Check your home assistant log after a restart and see if it even tried to start.

1 Like

Mine uses ethernet as well and it’s not off by default in mine… Never heard of an ethernet port being disabled on boot on anything. My Hass.io on Debian/Docker starts perfectly

For remote access to my home network I use either teamviewer as a specific machine access app to log in to my PC and from there I can get to anything else I need as if I am sitting in front of that machine.

Or for more general use I use a VPN.

I had been using a VPN that came provided by my ASUS router but I’m in the process of switching my home network equipment over to unifi stuff. So I just set up a brand new OpenVPN Server on my NUC running in docker. So now I also have general access to my entire network including my HA instance as if I was connected to my home wifi/ethernet network.

As far as my ethernet on the NUC it starts right up on boot.

How did you install HA in Docker?

Is it Hassio or a regular HA image?

If you aren’t using hassio then what restart policy did you use when you set up the HA container? If you didn’t set one then the container won’t automatically start on a reboot. Or for any other reason. You will always have to start it up yourself manually.

As far as the USB stick changing port. you have to set HA to use the USB port by-id or set a udev rule to make the port persistent thru restarts. I’ve used both and I personally like the udev rule method better. Which is the method I currently use.

i have nuc with proxmox installed. after that I have Ubuntu server with docketed Hass. everything works fine, goes up after power outage. you should check bios ( if nuc restart to previous state) and if using proxmox - autostart on VM. later you should use docker with restart unless stopped.
I also have aotec - I created udev rule to set static name of the dongle and pass it through.

It is certainly not standard for a NUC to have ethernet off on boot. As someone said it might be a bios setting I suppose.

The only thing I can think of is that maybe if your DHCP server is not up when the NUC boots, it may not get an ethernet IP address, and if HA starts in that state, things will go wrong. Or HA is starting before the DHCP server hands out an address.

1 Like

For #2 see this post and specify the dev path by-id instead:

1 Like

VNC by default requires you to be logged in in order to access the session. If you make some configuration changes, you can either:
A. Have your user auto logged in and start the VNC service
or
B. Get a working VNC at the login screen

Personally, a desktop on a server is pointless. The best thing you can do is learn how to use a command line, as it doesn’t inhibit the use of the system in any way.

BTW, on my NUC, I have never had to “start the ethernet” and I have never had it rename my ZWave stick.

I have ESXI 6.7 with ha running on an ubuntu vm for the last four months. No problems so far. I use console through the web ui as remote desktop.

My two cents… and this is most likely just repeating what is already said:

  1. Ethernet should be available on boot - check BIOS for sure, if you don’t find anything there, possibly server logs to see if there is an error - BTW if you want to post your Motherboard details someone here might be nice enough to Google the manual if you can’t find anything that would disable it there.

  2. Answered by others - I don’t use zwave, so I’ll keep quiet :slight_smile:

  3. My server is running ubuntu headless - my router has a WireGuard VPN setup and my phone/laptop have the VPN client (WireGuard on Android and TunSafe on Windows I believe). I can access the server anytime/anywhere as long as I can get to the internet. I like this approach as I think I am being safer (but I could be wrong) since I am not forwarding any ports from the router - also I can setup the VPN to have as little or as much access as I’d like. In other words, I can also access my camera’s, and other devices if necessary - as long as the firewall is setup for it.

Cheers!
DeadEnd

HI everyone. Thanks for the responses. I think #1 and #2 may have the same root cause, the lack of an ethernet connection at startup. This is what I am seeing:

Note the message that says “Connection failed” at the top of the screen. PCI Ethernet is Off.

This is what the settings menu looks like. It said “Connecting” under Prolific Technology Ethernet before I took the snapshot.

After turning PCI Ethernet On, I have an internet connection right away.

Once I have a network connection I can open Portainer. I can see all the home assistant containers are running except Duck DNS is stopped. I restarted the Duck DNS, hassio supervisor and home assistant containers and everything is up and running. It’s like it is trying to use the Prolific Technology Ethernet (whatever that is) instead of PCI Ethernet. I can’t figure out how to change it.

I did change the power on option to “Last State”, but it didn’t help. It was on something like “Turn On” before. Originally the NUC wouldn’t even turn on after a power outage.

Ethernet being disabled on boot sounds rather like this problem.

I did change the power on option to “Last State”, but it didn’t help. It was on something like “Turn On” before. Originally the NUC wouldn’t even turn on after a power outage

I’d strongly suggest avoiding this setting if you have regular power outages without a UPS in place. I had a linux server fried some years ago when the local power company repeatedly bounced the supply without warning.

Why don’t you try Proxmox? Here are two great Youtube tutorials by DrZzs:

and

This seemed really promising. I spent a few hours messing with it and didn’t have any luck.

Eventually I disconnected the NUC from my KVM. (https://smile.amazon.com/gp/product/B011NLY5J6/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1)

Once I disconnected the NUC from the KVM the startup related network issues went away. Once I can get some kind of remote access setup, I’ll have no use for the KVM anymore, so I think I’m on the right track.

Yes, the USB devices get enumerated by the order in which they connect… so this can happen. You should use the “permanent” device in: /dev/serial/by-id/ that will not change across reboots.

Made a bit more progress today. I now have VNC working without any manual intervention after resets. I hit a stumbling block due to the NUC not having a monitor plugged in (headless), but I just used a secondary monitor input on my desktop monitor. Not the best solution, but it seems to be working for me.

I went with Real VNC and I have downloaded the mobile app which seems like it could come in handy.

I’m not sure why you are having so many issues with your NUC. I bought a NUC, installed Ubuntu Server on it, then hassio and about 6 other home server-y things. Other than the few min it took to install ubuntu, I have literally never plugged in a keyboard or monitor. Been running for 2 years now.

Furthermore, why are VNCing to it? Everything can be done through ssh, which is built in, and active by default.

2 Likes

Just three small issues. Other than that it was relatively pain free. While all of this may be familiar and therefore simple to you, it has been quite the learning process for me with this being my first Linux install. You could really have a good laugh if you knew how many hours it took me to figure out how to get it to see the addition SSD that I installed…

Now that the reset/power on ethernet issue has been resolved/avoided I really shouldn’t need to interact with the NUC at all. I can access Portainer from my Windows machine to restart things with Home Assistant if needed.

I used Putty in the past to connect to the raspberry pi on occasion when things went wrong. I have been unable to get SSH to work, I get an “access denied” message. Just spent some time trying to enable SSH and access it from windows with Putty and I’m not having any luck. Kind of ironic that I’m using the unnecessary VNC to login to try to get SSH working.

Which addon are you using? How do you have it configured?