Quick documentation for Hassbian

Documentation is lacking currently and I’ve hadn’t had the time to fix that.
Here’s some of the most common answers to your question.

###Location of HA on Hassbian
HA on Hassbian is installed in a Venv at /srv/homeassistant.
Configuration is located at /home/homeassistant/.homeassistant

###To update Ha on Hassbian
Log in as the pi account

sudo systemctl stop [email protected]	
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 install --upgrade homeassistant
sudo systemctl start [email protected]	

###To start/stop/restart Ha on Hassbian
Log in as the pi account

sudo systemctl stop [email protected]	

Replace stop with start/restart to get the required functionality.

###Check your configuration on Hassbian
Log in as the pi account

sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
hass --script check_config

Hi Landrash

Thanks for putting this together. I am not able to get the start/stop/restart commands to work.

here is what I get.
pi@raspberrypi:/etc/init.d $ sudo systemctl stop home-assistant.service
Failed to stop home-assistant.service: Unit home-assistant.service not loaded.
pi@raspberrypi:/etc/init.d $

should the service be listed with sudo service --status-all?


My mistake, updating accordingly.
Service name is [email protected]

Thanks again.

I have setup some aliases so I don’t have to remember the command :slight_smile:

#homeassistant Start, Stop, and Restart
alias harestart=‘sudo systemctl restart [email protected]
alias hastop=‘sudo systemctl stop [email protected]
alias hastart=‘sudo systemctl start [email protected]


1 Like

Anybody know the password for the homeassistant user? I want to add open-zwave as a folder in /srv/ which is owned by the aforementioned user.

1 Like

The homeassistant user is a system account without a set password.
Use su to get a shell as the homeassistant user if needed. Following command will open a shell as the homeassistant user. Run this as the pi user.

sudo su -s /bin/bash homeassistant

if anybody else is using the hassbian image and is installing openzwave, to allow the homeassistant user to execute commands as sudo, put this in your /etc/sudoers file

homeassistant ALL=(ALL) NOPASSWD:ALL

The homeassistant should not have sudo privliges and installation of OpenZwave can be done perfectly fine with the pi account.

To further my explanation. The homeassistant account is limited by design to run Home Assistant with minimal privileges. We don’t want to put more badly designed IoT devices on the net than necessary.


What’s the correct instruction page for installing openzwave PROPERLY once you have a brand new Hassbian load? I tried to follow the main zwave instruction and then realized that maybe I needed to follow the one on the Virtual Env setup page (at the bottom). I had to modify those instructions a little because they used the ‘Hass’ folder naming convention instead of ‘HomeAssistant’. I’m still getting ‘failed to initialize’ errors; " You are missing required dependency Python Open Z-Wave". Any help on this? Thanks much.


How to set up connection in WinSCP to be able to edit and save configuration.yaml.
I am able to view and open configuration using pi user but I receive Permission denied error when trying to save.

i’m able to install openzwave properly, but getting it to talk to HA with the right permissions is where i’m having problems. I’ve set up openzwave twice before using both the all-in-one installer and from scratch. here’s what i have so far:

sudo apt-get install cython3 libudev-dev python3-sphinx python3-setuptools git

enter homeassistant user and update virtualenv to the right version of cython. NOTE: in the hassbian image pip3 points to the system pip3 and not to the virtualenv pip, so if you use pip3 the build steps won’t work
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip install --upgrade cython

create the directory
cd /srv
sudo mkdir python-openzwave
sudo chown pi:pi python-openzwave
grab the project from git
git clone https://github.com/OpenZWave/python-openzwave.git

from here you should be able to follow the steps in the getting started z-wave page to get openzwave built.


I am having problems installing OpenZwave in the hassbian image. same @siukwai

Likewise as of a couple days ago; kept getting the banner on front-end mentioning configuration if I remember correctly. My problem would come in when I would add the zwave: to the config file; no syntax was accepted, producing the same banner error.

HASSbian is awesome, it fixed all my issues I had with the previous Home Assistant installation attempts and just works.Thanks for the great work on that project. I however acquired an couple of Z Wave relays and an Aeotec Z-Stick (Gen 5) to use on my Pi. I followed Ben’s awesome video on setting this up only to find that the installation instructions does not work on HASSbian due to file structure diffs etc. Is there any information on how to get this stick to work on a HASSbian installation or do I have to revert to the all-in-one installer? Any chance of including OpenZwave support in HASSbian in future? Thanks again to the developers for such an awesome opensource project!


Hi, what is the default root password? not for pi but for root? I want to connect with WIN SCP as opposed to ssh, and when i connect using pi, I cannot see any files under the home assistant version. When I used another version on a syno box, using root I could…

Root account is disabled for login.

For what it is worth: sudo ./hassbian-scripts/install_openzwave.sh was the script I run in the Hassbian 0.38.4 image, and found out afterwards it was working fine!
After the install, which takes a long time, so sit back and relax, I used:

  • cd /srv/homeassistant/src/open-zwave-control-panel/
  • ./ozwcp -p 8888
  • Open a web browser to http://your_pi_ip:8888
    Specify your zwave controller, for example /dev/ttyACM0 and hit initialize

Hope this helps for you as well.

1 Like

You should’t need sudo for the second command :slight_smile:

thanks! took sudo out of 2nd command.

1 Like