Random "Google Assistant unable to reach Home Assistant Cloud by Nabu Casa"

Over the last week and a half or so when we ask Google Assistant to perform Home Assistant tasks it randomly fails. When it fails it says “I’m having trouble reaching the Home Assistant cloud by Nabu Casa”. I thought perhaps there was some sort of network connectivity issue, but while it happens I can still reach the internet from devices on my network, and more importantly I can trigger webhooks.

Is anyone else experiencing this behavior with Google Home? Any suggestions for how to fix this?

Update:
I just found the following in my logs:
Logger: homeassistant.components.cloud.google_config

Error reporting state - message_discarded: Message discarded because max messages reachced

—System—
docker: true
docker_version:19.03.12-ce
hassio: true
supervisor: 235
version: 0.114.4

I have also been having similar issues. Sometimes I get a ‘unable to contact HA cloud by Nabu Casa’ or whatever, other times it will say there was an error ‘turning off light blah’ yet still turns off the light…

In my log I have a variety of errors:

Logger: hass_nabucasa.iot
Source: /usr/local/lib/python3.8/site-packages/hass_nabucasa/iot_base.py:212
First occurred: August 29, 2020, 4:27:43 PM (208 occurrences)
Last logged: 8:42:02 AM

  • Unable to connect: 503, message=‘Invalid response status’, url=URL(‘wss://cloud.nabucasa.com/websocket’)
  • Unable to connect: 502, message=‘Invalid response status’, url=URL(‘wss://cloud.nabucasa.com/websocket’)
  • Unable to connect: 504, message=‘Invalid response status’, url=URL(‘wss://cloud.nabucasa.com/websocket’)

Logger: hass_nabucasa.iot
Source: /usr/local/lib/python3.8/site-packages/hass_nabucasa/iot_base.py:149
First occurred: August 30, 2020, 12:00:47 AM (23 occurrences)
Last logged: 5:33:11 AM

Cannot connect because unable to refresh token: Too many requests

Lots of 502, 503 and 504 errors relating to Nabu Casa

1 Like

Just found the same error in my logs.

Logger: hass_nabucasa.iot
Source: /usr/local/lib/python3.8/site-packages/hass_nabucasa/iot_base.py:212
First occurred: 11:31:07 PM (10 occurrences)
Last logged: 11:37:21 PM

* Unable to connect: 502, message='Invalid response status', url=URL('wss://cloud.nabucasa.com/websocket')
* Unable to connect: 503, message='Invalid response status', url=URL('wss://cloud.nabucasa.com/websocket')
* Unable to connect: 504, message='Invalid response status', url=URL('wss://cloud.nabucasa.com/websocket')

Yes, it’s been reported in the #cloud channel on the HA Discord server. They’re still looking in to it apparently, no indications of what the problem is (though it’s been noted that traffic has doubled recently) or when resolution can be expected.

The same problem has been reported impacting Alexa, so it’s not a Google specific issue either, but looks to be something with the NC service.

3 Likes

Is it maybe caused by the new Google system, seems since a few days we have now the live state in the Google home app

Reply from Nabu Casa Support:

"We are experiencing a load issue and are looking into the source of the problem.

In the meantime we have released a new version of cloud to help deal with the increased load"

1 Like