Raspbee + RaspberryPi 4

I’ve been trying to get Raspbee working on my raspberry pi 4 for the past 2 days now, scouring every possible forum and search result from google, but to no avail.

Below is my setup:

The following docker-compose.yaml files are used:

version: '3'
    container_name: home-assistant
    image: homeassistant/raspberrypi4-homeassistant:0.97.2
      - 8123:8123
      - /home/pi/homeassistant:/config
      - /etc/localtime:/etc/localtime:ro
      - TZ=Netherlands/Amsterdam
    restart: always


version: "3"
    container_name: pihole
    image: pihole/pihole:latest
      - "53:53/tcp"
      - "53:53/udp"
      - "67:67/udp"
      - "8080:80/tcp"
      - "8443:443/tcp"
      TZ: 'Netherlands/Amsterdam'
      WEBPASSWORD: 'CYfUhcwZN4mJgJtt2n!HX%Q!Q*x%24*'
    # Volumes store your data between container upgrades
       - './etc-pihole/:/etc/pihole/'
       - './etc-dnsmasq.d/:/etc/dnsmasq.d/'
      - NET_ADMIN
    restart: always


version: "3"
    image: marthoc/deconz
    container_name: deconz
    network_mode: host
    restart: always
      - ~/.local/share/dresden-elektronik/deCONZ:/root/.local/share/dresden-elektronik/deCONZ
      - /etc/localtime:/etc/localtime:ro
      - /dev/ttyAMA0
      - DECONZ_DEVICE=/dev/ttyAMA0
      - DECONZ_WEB_PORT=80
      - DECONZ_WS_PORT=443
      - DEBUG_INFO=1
      - DEBUG_APS=0
      - DEBUG_ZCL=0
      - DEBUG_ZDP=0
      - DEBUG_OTAU=0

I’ve also modified the /boot/config.txt . with the following at the end of the file (has a blank line at the end):


and configured user access rights of the serial interface (raspi-config) as specified here https://phoscon.de/en/raspbee/install#docker

I can access the Phoscon-GW (via the raspberry ip) and have also reset the password.
On the Settings > Gateway page the version number is 2.05.66 / 16/06/2019 but firmware states not connected. As a note in Settings > Gateway > Advanced I cannot change the ZigBee channel, currently states 0 (if I try to change this I get a never ending spinning clog), and Network id is unknown.

The logs from my deconz container show the following:

[marthoc/deconz] Starting deCONZ...
[marthoc/deconz] Current deCONZ version: 2.05.66
[marthoc/deconz] Web UI port: 80
[marthoc/deconz] Websockets port: 443
[marthoc/deconz] VNC Disabled
libpng warning: iCCP: known incorrect sRGB profile
This plugin does not support propagateSizeHints()
This plugin does not support propagateSizeHints()
15:23:58:564 HTTP Server listen on address, port: 80, root: /usr/share/deCONZ/webapp/
15:23:58:577 CTRL. 3.16.215:23:58:639 dev /dev/ttyAMA0
15:23:58:639 COM: /dev/ttyAMA0 / serialno:
15:23:58:639 COM: --dev: /dev/ttyAMA0 (RaspBee)
15:23:58:639 ZCLDB init file /root/.local/share/dresden-elektronik/deCONZ/zcldb.txt
15:23:58:749 parent process /bin/sh
15:23:58:750 gw run mode: docker
15:23:58:750 GW sd-card image version file does not exist: /root/.local/share/dresden-elektronik/deCONZ/gw-version
15:23:58:750 sd-card cid: <xxxxxxxxxxxxxx redacted xxxxxxxxxxxxxx>
15:23:58:751 DB sqlite version 3.16.2
15:23:58:753 DB PRAGMA page_count: 30
15:23:58:753 DB PRAGMA page_size: 4096
15:23:58:753 DB PRAGMA freelist_count: 0
15:23:58:753 DB file size 122880 bytes, free pages 0
15:23:58:753 DB PRAGMA user_version: 6
15:23:58:753 DB cleanup
15:23:58:754 DB create temporary views
15:23:58:763 don't close database yet, keep open for 900 seconds
15:23:58:764 started websocket server at port 443
15:23:58:767 discovery updated announce interval to 10 minutes
15:23:58:769 found node plugin: libde_rest_plugin.so - REST API Plugin
15:23:58:772 found node plugin: libde_signal_plugin.so - Signal Monitor Plugin
15:23:58:782 found node plugin: libstd_otau_plugin.so - STD OTAU Plugin
15:23:58:812 dev /dev/ttyAMA0
15:23:58:812 COM: /dev/ttyAMA0 / serialno:
15:23:58:812 COM: --dev: /dev/ttyAMA0 (RaspBee)
15:23:58:985 Error: invalid command
15:23:59:323 device state timeout ignored in state 2
15:23:59:996 Error: invalid command
15:24:00:274 device state timeout ignored in state 2
15:24:00:907 Error: invalid command
15:24:01:225 device state timeout ignored in state 2
15:24:01:917 Error: invalid command
15:24:02:221 device state timeout ignored in state 2
15:24:02:928 Error: invalid command
15:24:03:220 device state timeout ignored in state 2
15:24:03:839 Error: invalid command
15:24:04:100 dev /dev/ttyAMA0
15:24:04:221 device state timeout (handled)
15:24:04:314 Announced to internet
15:24:04:314 discovery server date: Sun, 18 Aug 2019 13:24:04 GMT
15:24:04:314 	 local time seems to be ok
15:24:04:314 discovery found version 2.04.35 for update channel stable
15:24:04:720 wait reconnect 15 seconds
15:24:04:721 void zmMaster::handleStateIdle(zmMaster::MasterEvent) not connected goto OFF state
15:24:04:721 device state timeout ignored in state 1
15:24:05:720 wait reconnect 14 seconds
15:24:06:720 wait reconnect 13 seconds
15:24:07:720 wait reconnect 12 seconds
15:24:08:720 wait reconnect 11 seconds
15:24:09:720 wait reconnect 10 seconds
15:24:10:322 scan skip host .226
15:24:10:721 wait reconnect 9 seconds
15:24:11:720 wait reconnect 8 seconds
15:24:12:721 wait reconnect 7 seconds
15:24:13:720 wait reconnect 6 seconds
15:24:14:298 dev /dev/ttyAMA0
15:24:14:721 wait reconnect 5 seconds
15:24:15:721 wait reconnect 4 seconds
15:24:16:721 wait reconnect 3 seconds
15:24:17:721 wait reconnect 2 seconds
15:24:18:720 wait reconnect 1 seconds
15:24:18:796 dev /dev/ttyAMA0
15:24:18:796 COM: /dev/ttyAMA0 / serialno:
15:24:18:796 COM: --dev: /dev/ttyAMA0 (RaspBee)
15:24:18:951 Error: invalid command
15:24:19:283 device state timeout ignored in state 2
15:24:19:961 Error: invalid command
15:24:20:234 device state timeout ignored in state 2
15:24:20:872 Error: invalid command
15:24:21:220 device state timeout ignored in state 2
15:24:21:883 Error: invalid command
15:24:22:220 device state timeout ignored in state 2
15:24:22:893 Error: invalid command
15:24:23:220 device state timeout ignored in state 2
15:24:23:904 Error: invalid command
15:24:24:220 device state timeout (handled)
15:24:24:295 dev /dev/ttyAMA0
15:24:24:721 wait reconnect 15 seconds
15:24:24:721 void zmMaster::handleStateIdle(zmMaster::MasterEvent) not connected goto OFF state
15:24:24:721 device state timeout ignored in state 1
15:24:25:721 wait reconnect 14 seconds
15:24:26:720 wait reconnect 13 seconds
15:24:27:720 wait reconnect 12 seconds
15:24:28:720 wait reconnect 11 seconds
15:24:29:721 wait reconnect 10 seconds
15:24:30:720 wait reconnect 9 seconds
15:24:31:720 wait reconnect 8 seconds
15:24:32:721 wait reconnect 7 seconds
15:24:33:720 wait reconnect 6 seconds
15:24:34:284 dev /dev/ttyAMA0
15:24:34:721 wait reconnect 5 seconds
15:24:35:721 wait reconnect 4 seconds
15:24:36:720 wait reconnect 3 seconds
15:24:37:721 wait reconnect 2 seconds
15:24:38:720 wait reconnect 1 seconds

I tried to connect a Philips Hue motion sensor but this fails to connect (expected with the logs above). I’m not sure what I’m missing but any help with trying to figure why I cannot get the Raspbee to work out would be greatly appreciated (hoping it’s not cause I’m running on teh Raspberry Pi 4). If I’ve missed out any info which could help with figuring this out more than happy to provide more.

Thanks for any help in advance.

I do believe you have to disable bluetooth, not sure how it is done on a pi4 but on a pi3:

In the config.txt file:


This might solve your problem.

I too have this issue - same clean config on a Pi3 works ok, but on the Pi4 nothing will ever pair or get past the waiting to join screen. Firmware connects and otherwise it appears to be working.

Same here. Raspbee not working on RPi4: neither in Raspbian or Hass.io.

I checked the serial symlinks, and serial0 points to the right ttyAMA0
Deconz (in both Raspian and Hass.io) can see Raspee, show Firmware but fails topair with any devices. Help?

Have you checked with the vendor of Raspbee if Raspi 4 is supported?

I guess they have to do some modifications to deCONZ.

I did and they referenced me to a test image they have which worked, but it doesn’t work in theHA environment so I guess this points to an issue with the HA Deconz add-on?

for now I’ve istalled my Zigbee into a dedicated pi / ha that runs only this. My main system then talks to that.


it is finaly working for me on hass.io with pi4. Need to set the device to /dev/ttyS0 instead of * /dev/ttyAMA0
Hope this helps.



What lines did you add in config.txt .

Hello @januszjm

I just got this working. My setup is:

device: /dev/ttyAMA0
vnc_password: *replace*with*your*pw*

Config.txt setup like:


At first it dit not work. But then I added the extra blank line in config.txt and it all woks just perfect.

Thanks Olivier… It works for me now!
Resume if you have:

  • RaspBee use device: /dev/ttyS0

  • ConBee use device: /dev/ttyAMA0