Raspberry Pi 3 - Hassio reboot loop

I’ve installed the Pi 3 disc image using the Etcher app & then plugged my Pi into my TV in the hope that after 20 minutes or so I’ve got a functional Home Assistant. However what seems to happen is I’m in a reboot loop, I’ll see the HA splash screen, then the screen will go black or the display will go off completely, then repeat.

I’ve had a look on the disc for log files, and I’ve tried to setup a wifi specific connection config but I’m not really able to get anything happening.

I’m going to download the HASSbian image & try to do things that way, but had hoped it’d just be easy first time, so is there anything I can try while the image downloads (slow internet here!)

HASS.IO doesn’t have any interface on the device itself. Is the pi actually rebooting or is it just reconnecting to the display every so often?

Reboots like that, if it’s really rebooting, would suggest a problem with the power supply. Are you using a power supply (not a mobile phone charger) that’s rated for a minimum of 2.4A?

It’s been running XBMC for ages without any issues, but good point. It’s connected to an older model of this;

I think that should cover the power required.

Yeah I wondered that but had it connected to HDMI incase there was a progress bar or at least some sign that it was working.

Judging by the LEDs it’s a reboot. For lack of better terminology, I’ll call the two LEDs an activity light & a power light. It gets to a green or green flashing activity light, then stops & the power light drops for a split second, then two red, the red activity light might blink, maybe goes orange before green again. It’s that kind of cycle which made me think it was trying to boot, hitting a problem then rebooting.

Hi all,
Did anybody find a solution for the reboot loop issue ???
I got the same problem on my RaspberryPi 3 B+.
First, I also suspected the power supply but I can not detect a voltage drop. Moreover, the Raspberry Pi without problems when I use any other SD card and a different image.
Thanks for your help

I just found with my oscilloscope that in fact there is a small voltage drop down to even 3.6 Volt.
Even after soldering a capacitor of 680 uF close to the USB power socket of th Raspberry, the drop was still there.
However, here is the good news:
I tried to reboot the Raspi without the connected LAN cable and the voltage was absolutely stable. Seems like I got some disturbance from my Ethernet Switch .
Anyway, system is launching now and I was planning to use WLAN in the first place.
Does anybody know if the LAN behavior is normal or how to solve that ?
Thanks a lot

I need to apologize !!!
The reboot was in fact caused by the power supply.
After I replaced it by a more powerful one (5V 2A instead of 5V 1A), there was no more reboot.

Power (if Pi) At least 2.5A

From the docs, and see the official guidance. You’re still underpowering that device.

I also experienced this issue on RPi 3. I found that home-assistant.log was 8GB in size, which filled up the hassio-data volume on the 16GB SD card installed. The system couldn’t write any more data. I used a Ubuntu Live CD to mount the volume and delete the home-assistant.log file as root. Afterwards, I was able to boot hassio successfully.