Raspberry Pi 4 on PoE-HAT: Getting hot and fan of PoE-HAT is never running

Tags: #<Tag:0x00007f32669e5378>

Hi2Uall,

I have a running hass.io on my new Raspberry Pi 4 with PoE-HAT. The RPi is getting hot and the PoE-HAT ventilator is never running.

I tested with Raspbian Buster and the ventilator is working as expected, so I guess the Hass.io is responsible for the flaw.

System:
Raspberry Pi 4 Model B - 4GB
Hass.io System: HassOS 3.5, Deployment staging (64b)
Hass.io supervisor: 189 (Home Assistant 0.99.3)

Anyone got an idea how to solve this?

Updated to HassOS 3

System:
Raspberry Pi 4 Model B - 4GB
Hass.io System: HassOS 3.7, Deployment production (64b)
Hass.io supervisor: 192 (Home Assistant 0.103.0)

arch	aarch64
dev	false
docker	true
hassio	true
os_name	Linux
python_version	3.7.5
timezone	Europe/Amsterdam
version	0.103.0
virtualenv	false

Problem is still there! Please help!

Maybe can I turn the ventilator on manually, by the use of Node-Red or someway else?

Hello. Just commenting so I get updates to this. I too am new and using a RPi4 with a POE hat. However, the fan on mine will cycle on and off as needed. Probably about once a minute for about 15 seconds is what it’s doing now. I had to remove the heat sink from my USB and WiFi chips to get the POE hat to install properly. That makes me nervous but according to the places I’ve googled, the heat sinks aren’t really needed. I am concerned because my USB ports are warm and I’d like to make sure the host OS is using up to date firmware which utilizes energy and thermal management updates. I’d also like to look into controlling the fan as well as it seems to cycle from off to full speed. I’d rather it just run all the time at a lower speed personally. My RPi is not using WiFi or anything else, just the ethernet. Here’s my info:

System Health
arch armv7l
dev false
docker true
hassio true
os_name Linux
python_version 3.7.6
timezone America/New_York
version 0.106.2
virtualenv false
Frontend version 20200220.5

Thanks for reporting @amcferrin90.
Does this mean your fan is activated (although it is not optimal)?

Did you use Home Assistant 64b version or the 32b?

I believe it was the 64b version to match the processor.

My fan is working though. I found in another post how to edit the config.txt file and add thresholds for when the fan was to turn on low and high. I used 57 & 63 degrees celsius as thresholds. The fan runs less frequently. I did make sure that the host OS and hassio were updated.

Alan

1 Like

Do have a link to that post?

Sorry for the delay on the response. Slipped my mind! This is the post I found about it:

I changed mine to 57 and 60 celsius though. I read that one of the chips has a rating max of 70 while other chips were another 20 degrees above that.

Alan

1 Like

Put your SD card into a windows machine and add this to the bottom of the config.txt file in the boot partition

dtparam=poe_fan_temp0=55000,poe_fan_temp0_hyst=5000
dtparam=poe_fan_temp1=65000,poe_fan_temp1_hyst=2000
1 Like

Thanks guys, I will give it a try this weekend.

I have exactly the same problem. Adding fan params in config.txt does nothing. The Raspi 4 is getting pretty toasty in sunny South Africa… :slight_smile:

1 Like

Welcome @KarlZA to the forum!

I will try to setup, a new Home Assistant on a RasPi 4, tomorrow. I will report back any issues or setup options.

1 - Linux command to mount bootpartition (fat16):
sudo mount -t vfat /dev/sdX1 MOUNTMAP
X = sdcard boot partition, for example /dev/sdc1
MOUNTMAP = map to mount the boot partition to, for example /mnt/temp

2 - Parameters added to the config.txt (used for testing):

## poe_fan_temp
##    temp0 is lower speed fan, temp1 is high fan speed.
##    Current setting is fan turns on at 50C, turns off when it comes back down to 45C.
##    If the temperature reaches 55C it will go full blast until it drops back down to 50C. 
dtparam=poe_fan_temp0=50000,poe_fan_temp0_hyst=5000
dtparam=poe_fan_temp1=55000,poe_fan_temp1_hyst=5000

3 - Unmount (in Linux: sudo umount /dev/sdX1)

4 - Insert SDCard in RasPi4 and connect to PoE switch. The RasPi should boot.

5 - Find the RasPi Ip-address and connect with: http://IP_ADDRESS:8123

6 - Finished the install (could take 20 min) and login with new username/password. Enable Advanced mode in the user settings.

7 - Install File editor add-on and start it.

8 - In File editor add to configuration.yaml:

sensor:
 # https://www.home-assistant.io/components/sensor.command_line/#cpu-temperature
  - platform: command_line
    name: CPU Temperature
    command: "cat /sys/class/thermal/thermal_zone0/temp"
    # If errors occur, remove degree symbol below
    unit_of_measurement: "°C"
    value_template: '{{ value | multiply(0.001) | round(1) }}'

and validate the configuration.

9 - Restart the Home Assistant (server).

10 - A temperature-cpu-monitor-badge is added to check the current cpu temperature.

11 - image HELP!! The fan is still not doing anything at all :cry:

Config:
RasPi 4 (4GiB) with Raspberry Pi - PoE-HAT (2018), fan is working with Raspbian Buster.
Home Assistant version: Raspberry Pi 4 Model B 64bit
HA System:

Hostname 	homeassistant
System 	HassOS 3.12 (64b version)
Deployment 	production
arch 	aarch64
dev 	false
docker 	true
hassio 	true
os_name 	Linux
python_version 	3.7.6
timezone 	Europe/Amsterdam
version 	0.106.5
virtualenv 	false

So what I’m doing wrong??
How can I check if error’s are there (by checking using the SSH & Web Terminal add-on, for example, and Linux commands)?

EDIT: I can see the actual temperature when using:

cat /sys/class/thermal/cooling_device0/temp

Where can I find the trip-points (low/high/hyst)?

Other links I found, which maybe useful:

@Domoticon Any luck? I upgraded to the latest hass.io release, still the same. Cannot get the fan to spin up at all.

Same here, I added the lines above to the config.txt file on the Pi and reduced the trip temperature and the fan will not spin, all I get is the kick when it first powers up.

Pi4 2GB, Official PoE Hat and 64 Bit HASS.IO version 107.5. Any ideas would be appreciated.

@KarlZA, @G8YTZ also got no progress. I also don’t know where to go from here. :cry:

1 Like

FYI, it seems to be a 64bit version problem. Reported by mvoort1337 on Github:
https://github.com/home-assistant/operating-system/issues/518#issuecomment-610796199

1 Like

I checked the above and can confirm the reported using Home Assistant 0.108.3 HassOS 3.12.

RasPi 4 (4GB) - 64b - Fan not working at all
RasPi 4 (4GB) - 32b - Fan is working > +/- 46 °C

image

Before 12:50h 64b version active, after 13:45h 32b version active.
No additional config used for fan, only temperature sensor config to monitor CPU temperature.

sensor:
 # https://www.home-assistant.io/components/sensor.command_line/#cpu-temperature
  - platform: command_line
    name: CPU Temperature
    command: "cat /sys/class/thermal/thermal_zone0/temp"
    # If errors occur, remove degree symbol below
    unit_of_measurement: "°C"
    value_template: '{{ value | multiply(0.001) | round(1) }}'
1 Like

The Poe HAT fan seems to be working on 64-bit since HassOS 4.12!

Reported by Alchiadus on github:

image
Confirmed!!