Raspberry Pi Bluetooth

Good evening all,

I am trying to get my HA install on a Raspberry Pi to recognize an Inkbird IBS-TH2 (temperature only) sensor. It seems that others have it working, but when I go to add the Inkbird integration, I get a message that says “No devices found on the network.”

So, I tried to install the Bluetooth integration because I do not see it listed anywhere in the integrations, and I get a message that says “No unconfigured Bluetooth adapters found.”

So, either the Raspberry Pi on-board bluetooth adapter cannot be found, and thus cannot be configured or it is configured and just not working for some reason.

Can someone please help, I really want to get this sensor integrated ASAP.

Thanks in advnace.

First, to help you, we need you to help us understand your hardware and software

The Bluetooth integration should offer to install itself automatically with HASSOS >~8 on a RPi >=3.

Settings → Devices & Services → Bluetooth should show the integration, with likely one device (hc0 - the adapter itself). After that, it’s pretty much automatic - mine picked up neighbours AirTags, but that’s about it.

Bluetooth Low Energy support is pretty new so HASS updates are important, and as devices are often battery-powered, radio range can be a problem. Try fresh batteries next to the RPI perhaps?

If this helps, :heart: this post!

1 Like

Thanks for the help. I figured it might be something with the install itself so I just created a new instance and started over. I did not have that much in HA anyway and really and truly wanted to start over in the first place. This just gave me a reason. Everything appears to be working correctly with the fresh install.

I also have this exact problem.
Running RPI4 with HASS OS Image installed
Tried to add Switchbot integration and got the “No unconfigured Bluetooth adapters found.”
Tried to add Bluetooth Integration and got “No unconfigured Bluetooth adapters found.”
I found the “bluetoothctl” command which I put into TTY. Using the Show command I can see that the bluetooth is Pairable YES but Discoverable NO

Thanks in advance!

Did you get this figured out? I’m having the same issue.

Im having the same issue. Solutions?

I had the exact some issue until someone on Discord pointed out that I may have previously Ignored my Bluetooth Integration. So I went to Integrations, looked at Ignored devices and it was indeed the case! As soon as I re-enabled it, all the Switchbot curtains showed up even without having to manually trigger a search.

1 Like

Dear Bluetooth Experts,

would appreciate your kind support.
Running an Pi3 32, tried to activate Bluetooth integration but “no addapter found and no addapter hided” was show.

Hints welcome, thank you in advance.

PS: Installed via Hass.io, updated to latest version of core and OS

Same problem for me, latest hassio version, BLE used to work but somehow cannot enable bluetooth with internal BT anymore since some time. Pi4. Used to use HACS ble integration for some time. Somewhere I must oversee something …

fml, the fix for me was enabling bluetooth via /boot/config.txt. Somehow it was disabled in that file.

I’m also facing this issue right now (HassOS, RPi4B)… I did have Bluetooth disabled initially via dtoverlays in the config.txt on the SD Card:


Because I needed the UART before. But I don’t need that anymore, so I commented those out. The only things in config.txt are these now:

# HassOS - don't change it!


I still get the error “No unconfigured Bluetooth adapters found. There are 0 ignored adapters.”. And yes, it’s not ignored…

Is there something else I need to do to bring it back?

From what I read, BT is broken because the latest OS updates has some changes in it. It’s currently being worked on but it has been ongoing for a while… so who knows when it will be fixed?

1 Like

oh… ok :confused: Thx for the update, so it’s at least not on me :smiley:

And OS v12 has been released, and it looks like I no longer have Bluetooth errors.

Give it a update and try again.

Already did, sadly still the same: No unconfigured Bluetooth adapters found. There are 0 ignored adapters.

Boo. The wait continues…

My home assistant has been crashing due to BlueTooth I disabled it to figure it out. I have a Home Assisant Yellow with a Rasberry Pi4. I first noticed a bunch of errors in the logs for AirThings. It would run fine for a few days then crash. THe home assistant would need to be unplugged then plugged back in to be able to log into it.

I just deleted the BlueTooth device (the hcio device) and it had a second one created along with it that looked like an IP address. I then went to the BlueTooth page on then click the “Add Intergration” button (Link to Integrations: add integration – My Home Assistant)I had to update my home url but afterwards it ran a set-up wizard. I then rebooted (not restart) that seemed to work. I still need to wait a few days to verify it does not crash and set up Airthings devices.

It’s worth a try.

Thanks a lot for this info…I had the same situation and this hint helped a lot!

Going to the underlying system and running the command below solved it for me:

apt install bluetooth bluez -y

Chiming in here to say a clean install also worked for me!