Raspberry pi camera on Hassio

When I add the raspberry pi camera to my Hassio on a pi 3/zero I receive raspistill: not found although I verified that the camera is correctly connected under Rasbian. Is there a way to trouble-shoot this, or is raspistill just not included in the Hassio build?

I get the same error.
[homeassistant.components.camera.rpi_camera] 'raspistill' was not found
I’m guessing raspistill isn’t installed as part of Hassio

Created an issue:

thanks. I’ll be watching this issue. Was hoping to hook up the camera and use it to do motion detection

I have this config in camera.yaml, and have not issues with the native RPi camera.

- platform: generic
  still_image_url: http://192.168.1.111:5004/cam.jpg
  username: your_username
  password: your_password

Hi Kanga
Looks like you are accessing another Pi. This thread is on Pi camera mounted on Hassio
Cheers

did anyone find a solution to this problem?

This issue is still open, so the current solution is don’t use Hassio

Just migrated to Hass.io … Raspberry pi camera doesn’t works :(. Anyone is working on a fix for that ?

I am having this same issue…no idea how to debug either, because SSH brings me to what appears to be a pseudo-“virtual” environment inside hass.io … not the actual environment in which such devices as the RPi camera might show up…

Is this a solution to a different problem or the one referenced in this thread?

Problem:

Solution:

Hello,

Anyone had a solution to get a RasPi camera running on the same Pi which is running hass.io?
EDIT: just searched on github: there is an issue open: https://github.com/home-assistant/hassio/issues/184
But only lots of discussions, nothing i would see a constant solution on the default image/software… maybe it is lower prio. Feeling sad not able to use my RasPi cam on my hass-io host…

/ Ralf

1 Like

Is this being worked on? Just bought the Pi Camera Module v2 after finding out about the rpi_camera component and now can’t get it to work. In the log after a restart:
‘raspistill’ was not found
17:10 components/rpi_camera/camera.py (ERROR)

That’s a Hassio issue

I found this “Known issues and limitations”
Local USB or Pi cameras are currently not supported yet. This is caused by a limitation of Hass.io. A request for a change has been made to make this possible in the future. motionEye(OS) allows you to use a second instance (e.g., a Pi Zero W) for those kinds of purposes.

That was found here:

1 Like

I just received mi Pi camera v2 and then, while trying to figure out why it didn’t work, found all the various threads about not working in Hassio.

Does anyone know is this is going to get supported any time soon. Really disappointed about this

@bowesmana cameras and docker is a challenge, and this issue has been noted for a while now. I recommend you use Hasspbian

Yeah, that seems to be the recommendation, but the learning curve has been steep enough already and I’m not so keen on having to redo everything - as has been expressed already, I just want a gui and and simple way to do stuff. I’m a developer, so I get the challenges, but that’s my day job :slight_smile:

@robmarkcole as I have two Pis, would it be simple just to put the camera on the other Pi and stream it into Hassio from there?

Yes that’s what the motioneye addon supports

1 Like