Raspberry pi zero 2 w

I’ve created a feature request for supporting this board: Support Raspberry Pi Zero 2 W
@agners I count on your vote :slight_smile:


So I did some tests on my brand new Pi Zero 2 W. It’s a very nice upgrade over the old Pi Zero W, but there are some serious drawbacks compared to a Pi3 or Pi4. Which obviously makes sense, considering the size difference. It’s still very impressive how they managed to put that much on a small single sided board.


  • Much better performance than the Pi Zero 1, but still lower than the Pi3 (same CPU, but lower clock speed).
  • Wifi is around 60% faster than the one of the Pi Zero 1 (but it’s still very slow, see below)
  • Inexpensive
  • Small


  • Wifi is very slow and drops very quickly with distance to the AP. I put the Pi Zero 2 into the same location and orientation than the Pi Zero 1, around 3m from the AP with a wooden floor inbetween. On the Pi Zero 1 I get around 30 Mbps, the Pi Zero 2 does 47 Mbps. Nice speedup, but in the end that’s still barely 6 MB/s. This makes everything involving the network really slow and laggy.

  • 512MB RAM is not much. Especially if you run overlayfs, so to make the SD card readonly and keep all logs in ram (which btw is super easy to do on the newer Raspberry Pi OS versions and makes SD card failures a thing of the past), then you’ll hit the limits pretty easily.

  • The thing heats up quite a bit under load. I stress tested it a little. After around 6 minutes the CPU was over 70°C and I stopped the test. A heatsink would be very much advised if you run some more heavy stuff on it.

All in all a very nice board. But as far as I see it, it isn’t really usable for a serious HA install, mainly due to the slow wifi and the limited memory. It may cope well with a very stripped down HA. But I’d suggest installing it as a bare bones venv to reduce memory use then.

The board has a lot of other great uses of course. For me it works great as a wifi connected USB mass storage device for media delivery (basically it presents itself as a USB drive, but maps all data to the NAS). Like the Pi Zero 1, it has OTG support on the USB port, something the Pi3 doesn’t have.


I’m new to home assistant, but I say everything works fine using zero 2w. I have about 10 tuya covers and lights that control using localtuya (from hacs). The raspberry don’t get hot. I have about 15 automations. I hope they make a image.


Hey! Which image did you use to flash Home Assistent OS on the Pi Zero 2W?

Ich had problems while adding Add-ons. I used the Image for the Pi 3 64bit…

1 Like

ok i thing i’ve got it running supervised on 2 zero, and docker, and prtainer, following this video : HomeAssistant Supervised on Docker - YouTube
now i must delete everything and try to make it again, because i cant figure it out how it happened.

64bit with 512 Mb ram ? Not advisable. Better use the 32bit image.

Not sure how to check sw version. the lack of hardware is pushing in to this. i do not have possibility to pay over 100 euros for raspi 4 that is the only one available on market.
so for testing and playing 2 zero.

I managed to successfully install Home Assistant OS on my Zero W2 using this link: Raspberry Pi - Home Assistant and selecting the Pi 3 32bit URL with balenaEtcher on a 32G SD card. It has by default supervisor installed. I managed to get HACS integrated and added some custom repositories, all worked well and I could not notice a difference in performance to HA I have running on a Pi3B.


Can you plz tell the steps to install manually and how to increase swap file.

Also how do I configure wifi before the first boot?

I use RPi3 image for docker and it work’s fine but not superspeed. It’s better to use HassOS instead of docker - did you maybe test this two options?

I install rp3 image on rpi zero 2w.

  1. I am not able to configure wifi.
  2. How to increase swap file?

How did you get it to work docker.

Since the rpi zero 2 are available again for a good a price, i gave it a try with HA.
First i tried the latest Zero 2 Image Index of /11.0.dev20230720
No output, does not start.
Than i tried the Rpi3 64 Image, that starts up to the IP Adress Message, and the Preparing … HTML Site.
But thats it, there are repeating Errors

Nxt i’ll try the Rpi 32bit Image

Wifi Config
Create directory in root of the SD , config\network
create a file here wifi-network


# Make sure to use a SSID of a 2.4GHz network




no luck, the Rpi 3 Images makes the similar/same Errors.

No i’m Back to Rasberry Pi Imager, and the Rpi3 Image OS10.3 (RPi3)
Started w/o any problems, takes some time to start onboarding website.
But Crashes next screen after entering User Password …

Ok enough 4 today :slight_smile:

Ah I am not alone out there with struggeling installing HASS on a Zero 2W. Here are my problems…

thx, i’ll try the DietPi Way :slight_smile:
tried also OpenHab, absolut no problem to install and run on a Pi Zero2

@bepp on ‘your’ thread i wrote my disappointment cause it is only the ha core so useless 4me. maybe i find a way to install HACS?

I had been running HA on a pi4b for several years, but I had to swap out machines so I could use it for another purpose. This led to me using a pi0-2w with HomeBridge for several months, as I couldn’t get my docker compose I had previously used (HA, mqtt, and zigbee2mqtt) to run reliably.

It was all good and well, but I really missed the Adaptive Lighting plugin I had used. So, I ordered a Radxa Zero. I spent the past couple of days trying to get it working, but I couldn’t find an image that ran well and enabled the serial port properly (I use a RaspbeeII).

So today, I did some more work with the Pi0-2w and am delighted to report it’s running really well. I stopped using mosquito for mqtt and z2m, and switched to ZHA, which oddly seems to be a little less resource intensive.

Make It So

I started with the minimal-64bit rpi image on an sd card.


sudo apt update; sudo apt upgrade -y

Increase Swap and install ZRAM

sudo dphys-swapfile swapoff
sudo nano /etc/dphys-swapfile

edit to make swap larger I did about 500 mb which I think is overkill

sudo dphys-swapfile setup
sudo dphys-swapfile swapon

git clone https://github.com/foundObjects/zram-swap
cd zram-swap/
sudo ./install.sh
cd ..

Install Docker

curl -sSL https://get.docker.com | sh
sudo usermod -aG docker $USER

Setup HA

mkdir ha
cd ha
nano docker-compose.yml

edit with the following contents:

version: ‘3’

container_name: homeassistant
image: homeassistant/home-assistant:stable
- ./:/config
- /etc/localtime:/etc/localtime:ro
restart: unless-stopped
network_mode: host
- /dev/ttyS0:/dev/ttyS0

Setup Serial

sudo raspi-config

then interfaces > serial > enable serial, disable console

Reboot and :rocket:

sudo reboot
cd ha
docker compose up -d

Install HACS

docker exec -it homeassistant bash
wget -O - https://get.hacs.xyz | bash -


docker compose restart 

At that point I was able to login in in the browser and set everything up. ZHA was able to grab my RaspbeeII and find all the lights. I then installed Adaptive Lighting via HACS and everything is chugging along right as rain.

I’m in a small apartment and I don’t have a ton of devices (≈45 devices). I would still like to be able to use the Radxa since it’s quite a bit faster, but I don’t know how many more days I can spend trying to get the serial working.

I am not currently running a mqtt server, but I’ll need one if I want to connect my blinds–they run Tasmota. Planning on using the Deno project opifex which I used in my interim setup and it was very lightweight. Once it starts up, the pi sits pretty much at idle, so not too worried about adding it in.

I’m actually really happy with the pi0-2w. WiFi latency doesn’t seem to be an issue, I swear the lights turn on before I’ve taken my finger off the button in the Apple Home app. And it’s nice to be able to utilize a piece of hardware I’m finding fewer and fewer uses for. That said, I probably will docker compose stop before I run system updates.

I also really like that I can plug it directly into the usb c port on the back of my router and there’s no cables running everywhere. Super clean setup. The whole thing is occupying 4.7G, so it would fit on the 16G eMMC in the Radxa… Next time in adventure land, I guess…