Raspberry Pi4 - Up & Running

Hi All

Just a quick note to let you know I have got Home Assistant Running on the Raspberry Pi4(2gb) with Buster & Python 3.7.3 running in a virtual environment.

So far no issues will need to test further.
mosquito next

If you want details of what i did let me know, it’s you basic Pyton 3.7.3 upgrade and venv install.



Are you using an SD card for storage or an SSD?

Apparently the throughput to an SD card is improved in the RPI 4. Throughput to an SSD is greatly improved due to the availability of USB 3 ports.

SD at the moment but I am looking at SSD for the future

It’s a fairly straightforward install in a venv as you’ve indicated. I’ve held back on the Pi 4 until the 4gb becomes available again.

Instead I installed Buster on the Pi3b+ just to test the OS and early indications are good.

The big indicator in performance will be the availability to boot from SSD on the new USB3 facility and of course a whopping 4gb of RAM v the 1gb on the Raspberry Pi3b+

Who knows with all that extra memory could we be looking at some form of RAM disk operation using tmpfs for HASS at some stage in the future.

Curious how much faster reboots are now.

Rebooting the pi faster but nothing amazing, restarting home assistant much faster, will do some final time comparisons when the systems are identical. Response time on the web interface is noticeably faster.

2gb seams more than adequate for a home assistant installation, I don’t believe the would be much to gain with the 4gb. I never hit memory problems with the 1gb pi3.

1 Like

I also went with the 2GB version, should be more than enough for Buster+HASSIO and a few other things.

I imagine the 4Gb version would interest people who wish to run multiple docker containers:

  • Home Assistant
  • mosquitto
  • MariaDB
  • grafana
  • influxdb
  • portainer
  • traefik
  • nodered
  • etc …


Hit a bump the appears to be a issue with z-wave, it looks like Buster is missing the drivers for my aeotec z stick, I haven’t discounted a mistake by me but looks like an issue.

Also Buster has Python 3.7.3 as standard so you don t need to update before installation.

Mosquito and RfxTrx work ok.

How did you get it to work?

Z-wave i have not, you can apparently get that to work by using a usb hub but I have not tried that yet.

the main install of home assistant in via the alternative install in a virtual environment instructions below


Thanks. I got it working but the hass.io section is missing and it is not running as a service. How do I get the hass.io tabe so I can add some add-ons and how do i get it to start automatically in the background?

You only get the hass.io section if you install hass os which you have not done. You have to install each individually or add via the Integrations in configuration


Not necessarily. Hassio is a docker supervisor. So if you had docker working on the pi 4 you could install Hassio.

I’ll wait until the Hassio option is available before installing on my pi 4 when it turns up

Edit: looks like you can get docker going with a little bit of work - https://forums.docker.com/t/release-for-raspberry-pi-4-raspbian-buster/77120

There is still no install available for docker on raspbian buster
So the work-around is to revert to stretch for the docker install…

Not quite right… you can install Hass.io as a generic linux install on Debian or Ubuntu… HassOS is just a distro that comes with some images of hass.io

Yeah, it’s a work around to get it going. Here is the github issue anyway, judging from the comments people are having some success with it - https://github.com/docker/for-linux/issues/709

I have no doubt that will work… The official Buster Docker release will be the same as stretch probably…

I followed this thread: https://docs.docker.com/install/linux/docker-ce/debian/
Works with docker on RPI4 and Hass.IO RPI3 container.

Running Home Assistant in a virtual environment on a Raspberry Pi4 (2G) with RfxTrx433XL and booting on external SSD (Kingston 120 GB) … Just working fine (no problem during the installation). Very good response time… I am also running MRTG and Nagios on the same box to monitor my network. With HA, Nagios, MRTG and Apache running, I am using around 300 MB of memory out of the 2GB. CPU is around 12% in average and CPU temperature is around 75°C (pretty high) but no cooler at all (Pi4 is in a case)… I ordered one cooler (static) to see the effect on the temperature… I installed the version Raspian Buster with Desktop…

1 Like