RaspberryPI 3b SSD USB boot

Hi, is there something new about booting directly from usb ssd on RPI3? After a 20+ installations i’m sure it doesn’t happens. Rasprian boots perfectly, but HASSOS dont- ver. 3.13. I just want to use HASSIO with HASSOS, easy and working great on SD. Do someone had success with this, or we must wait more time for development of this miracle? Just info- Transcend ESD240 portable SSD is the device working here with Raspbian. Thanks in advance.

Hi,

Is the USB host boot mode activated on your Pi?
https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md
I guess yes as you managed to put Raspbian, but maybe for some reason bit could have been reset.

How did you flash Home Assistant? Etcher?

I’m personally booting HassOS (currently 3.13) from USB on Raspberry Pi 3B+, works great. I never put any SDCard in this Pi.
It’s not an SSD though, but one of those tiny USB flash drives: Sandisk CZ43.
No need to set this mode on 3B+.
Maybe you could also try with a flash drive to see if the problem is with the Pi or with the SSD (or how it’s installed)?

Eric

I’m not sure, you do talk about the same thing. :slight_smile: As far as I know, under HassOS, the boot from SSD is not supported. This is only supported by installing Raspian and afterwards install HA as supervised (so HA is “running” your OS, but it’s not HassOS) or you install Rasbpian and afterwards Docker with Hass.IO.

Tbh I’m a little surprised HassOS is working for you @ericpignet , not installed as supervised. Are you sure, you didn’t install Rasbpian and afterwards the supervised installation? :slight_smile:

To sum it up, a plain HassOS will not run from SSD on a Pi3. You need to install Rasbpian and afterwards the installation method you want. I for one choose the Docker installation method. It is clean, easy to handle and is running nicely. And it is Hass.IO in the end, with all the added benefit of addOns and so on. :slight_smile:

EDIT: I found the thread, where I read about problems with Pi3 and SSD. Check it out:

Hi,
I have the same installation. I took the hasio image, put that on sdd and it was find for months. Now I started to see problems. Exactly after latest system update…

Any advice what to do with such installation?

Hi Patrick,
I confirm HassOS works for me from USB, using the official Home Assistant image, and I’m pretty sure I never installed Raspbian on this flash drive. However it’s a Raspberry Pi 3B+.
Eric

Mine is 3b+ too. Now thinking how to migrate my setup to “proper” installation… any ideas how to move all the config? Backup and restore on new install or migrate existing installation as a whole?

I have currently upgraded from RPi 3b+ to a NUC(using Ubuntu/Docker) but can confirm it is possible to run HassOS booting from SSD without any SD cards on RPi 3b+.

This is how I did it:
From MS Windows:

  • Rightclick Windows logo in bottom corner and click “Windows Powershell”

  • Type: “Diskpart”

  • Type: “List disk”

  • Type “Select disk x” (x is the number of the disk to be partitioned)

  • Type “clean”

  • Type “List disk”

  • Type “Create partition primary”

  • Type “Select partition 1”

  • Type “Active”

  • Type “Format FS=NTFS quick”

  • Type “Assign letter=w”

  • Download last HassOS and burn it to the SSD disk using f.ex.Balena Etcher

  • Put the disk in RPi and boot up.

1 Like

More or less thats what I was doing. I know it works as I have this on my desk now :slight_smile: It seems though that its not “proper” way. Dunno about the docker much but is it possible to have mu current installation running on a docker on a raspbian? Sounds like inception :wink:

Thanks for the reply, that’s good to know! I read in a few threads, it woudln’t work, so I used the Docker install from the beginning. But I’ll definitely give it a try, as it would be the version I want. :slight_smile:

This is how I installed using Docker:

  • Made a backup of my previous installation.

  • Installed Ubuntu and docker following this thread. Should work on raspbian aswell.

  • Installed Home Assistant Supervised Link

  • Restored my previous backups from GUI.

Works like a charm :partying_face:

1 Like

I followed this tutorial https://www.youtube.com/watch?v=uuGz9d_tTzc
I have a RPi 3 (not +) and a Samsung SSD plugged in with USB 3.1 (doesn’t need to be that level of USB). I burnt the HassOS image onto the SSD with Balena Etcher but unzipped the image before burning, even though Etcher can handle zipped files. It shows you how to enable boot from USB in the tutorial. This worked for me and I haven’t needed to use an SD card with the boot file. Not all SSD Caddy’s work, from reading other threads. There’s a list of recommended hardware, if you search the forum. Good luck :+1:

Hi guys, now i have all things done and working with HASSIO- HASSOS 3.13. To be clear RPi3B v.1.2 not B+ with Transcend 120G ESD240C SSD. Now boots from SSD without SD card inserted and working stable for 2 days. There was a 2 problems - this small portable ssd is power hungry- 0.9A, and slow to start. The solution is setting a bit on RPI for more time to wait for SSD to be ready and Y cable for external power. There is no need to resize partitions on ssd after Etcher, HASSIO done this by itself. Just write image to SSD, set boot from usb and wait bits, start RPi and wait. After ~15 min waiting install samba put back your snapshot and start restore. I have no luck with USB hub with own power supply, the RPi dont boot from it. The SSD must be connected directly.
I found this great thread on Raspberry’s forums regarding SSD booting- look at 3rd post.
https://www.raspberrypi.org/forums/viewtopic.php?t=225812

1 Like