USB Boot on Raspberry Pi 3

Anyone had any luck booting hass.io from a USB drive on a Raspberry Pi 3?

I’ve just tried, and was greeted with a blank screen. Power LED On, Green light blinking on and off continuously.

Have burnt the same image to a MicroSD and it worked without issue

Did you enable the USB boot mode already?

I have it running off a SSD with SD card with boot files on, never had an issue since with corruptione etc. I followed a guide that was straight forward using minitool partition software, I will try and find the PDF and upload later today.

I also been running a RPI 3 on a ssd with usb2sata converter and no sd card. It has been working for 6 months now. I had some trouble when I did a warm reboot (power of and start worked but not the reboot). But I hade to set some delay flag. I used the guide on raspberry pi site. Then I manually installed Home Assistant.
No issues yet.

Yes. Default image seems to boot to at least the Home Assistant logo. However, the Hass GUI will never actually open. Works fine when I boot the same image from an SD card

I can get home assistant to work that way. Was wondering about the actual Hass.io image

I think this can be done using docker but the instructions are not clear enough for a novice.

The Raspberry website mentions:

Starting with the 2017-04-10 release of Raspbian you can install a working Rasbian system to a USB mass storage device by copying the operating system image directly onto your USB device, in the same way that you would for an SD card. To perform this step, follow the instructions here, remembering to select the drive that corresponds to your USB mass storage device.

I doubt if ResinOS is capable of booting a Raspberry Pi3 from a USB device out of the box just like Raspbian.

To quote from the resinos docs, I’d say it might be possible.

resin local flash command helps to easily and safely flash the resinOS system image on an SD card or USB drive.

But I have no resinos experince yet.

Thanks everyone. I might just wait until it’s supported on the hass.io image. I tried moving my current home assistant image over and was successful getting it to boot. However, homebridge just never would work after the move. Home Assistant worked fine. Thought I’d start over with hass.io when I move everything over

Did you ever find that guide?

ill find it and put it up in the next few hours
cheers

And what was wrong with HB? I can’t see why particular one add-on was not working. It’s not using any hardware capabilities so it’s even more strange. Do you remember by any chance what errors did you get?

I ended up getting the original image to work today. HB just simply wouldn’t work before. Service started fine and there weren’t any odd errors. But all devices showed no response in the Home app. Reimaged to a different USB drive today and I got it working. Still interested in a hass.io image in the future though.

@pvizeli Hi, I see on resin-os gitter chat that you have been working on the development of this hass.io image.
Thanks for this; I just started on hass.io and was wondering if the options or settings involved in the creation of the image file itself have any influence on the possibility to boot from USB drive (or SSD via USB)? My RPI3 somehow likes to eat SD cards after a couple of reboots.
:wink:

A Hassbian image or raspian/aio can boot fine from USB on my RPI3, but the hass.io resin-os image fails. Tried several USB drives, no luck. It just stalls during boot, even the boot logo is not shown.
The same image flashed to a SD card boots fine.

I have installed the image on SD card and have completed the hass.io installation and the Home Assitant page shows up.
After installing some add-ons, I made a image file of the SD card and flashed that to my USB drive but still no luck.

According to the github repository it should already be available in the firmware, see: https://github.com/resin-os/resinos/issues/283.

Could you take a look into this for making this available in a coming update of the image?
Thanks!
:wink:

2 Likes

Same problem here. Can boot raspbian img from usb, but Hass.io just hangs…
It would be so great if anybody could sort this out, as I’ve found that I just sleep better knowing than my pi’s are running usb sticks :slight_smile:

2 Likes

Same - I have just gone through the same heartache, then found this thread.

After my second microsd failure I decided to use a usb case with a SSD drive to boot my Pi off and run HA. I etchered raspbian on there after enabling USB booting just to confirm booting from USB was working. No problems.

After etching hass.io onto the same drive, after power on I get no console. The Pi flickers a few lights and then calms down.

Would love to see this working.

1 Like

+1 Me too… burning down SD cards like there is no tomorrow…

Hi all!

I can boot hass.io from usb.
I made some changes in cmdline.txt and config.txt files.
There are two of each!
One couple on the resion-boot partition, and another on resin-rootA partition in resin-boot directory

I changed the “root” option in cmdline.txt

root=/dev/sda2

and I added the usb boot line to config.txt, at the end

program_usb_boot_mode=1

One another thing:
I enabled ssh access to resin os, explained here:

3 Likes