Ratgdo sensors working but not the buttons to open/close door or toggle the light

I’ve got two DIY ratgo boards that seem to be fully functioning except the buttons to open/close the door and the light.

  • Both are exhibiting the same issue.
  • Home Assistant accurately shows the state of the door (open/closed/percentage, etc), the motor sensor, the obstruction sensor.
  • Everything updates when using the wall button or remotes.
  • Nothing happens when using the software buttons (both Home Assistant and the webui).
  • This is the ESPHome variant.
  • This is a DIY version of the ratgo (via https://www.youtube.com/watch?v=5yV5V7prG6c)
  • Does it matter that the .yaml file and the name/prefix don’t match? I can’t imagine that’s it, but I just noticed it while copying the yaml here.
  • Could it be due to learning the code as mentioned here?
  • I have re-wired 3 times.
  • Soldering looks solid to me.

At this point, I’m stumped.

Below is logs from the webui as well as my YAML file, to compare results.

Thank you to Aaron for helping this far, and thanks in advance to anyone else who helps.


Clicking in webui:

11:29:43 [D] [cover:076] ‘Door’ - Setting
11:29:43 [D] [cover:084] Position: 100%
11:29:43 [D] [number:012] ‘Rolling code counter’: Sending state 173.000000
11:29:47 [D] [esp8266.preferences:238] Saving preferences to flash…
11:30:15 [D] [ratgdo:210] Status: door=CLOSED light=OFF lock=UNLOCK

(it’s the same when clicking in Home Assistant)

Snippet from logs when clicking via door remote (which works as expected):

11:33:42 [D] [ratgdo:210] Status: door=OPENING light=ON lock=UNLOCKED
11:33:42 [D] [cover:170] ‘Door’ - Publishing:
11:33:42 [D] [cover:173] Position: 0%
11:33:42 [D] [cover:186] Current Operation: OPENING
11:33:42 [D] [cover:170] ‘Door’ - Publishing:
11:33:42 [D] [cover:173] Position: 5%
11:33:42 [D] [cover:186] Current Operation: OPENING
11:33:43 [D] [cover:170] ‘Door’ - Publishing:
11:33:43 [D] [cover:173] Position: 9%


  id_prefix: garage_door_dave_esp
  friendly_name: "garage_door_dave_esp"
  uart_tx_pin: D1
  uart_rx_pin: D2
  input_obst_pin: D7
  status_door_pin: D0
  status_obstruction_pin: D8
  dry_contact_open_pin: D5
  dry_contact_close_pin: D6
  dry_contact_light_pin: D3


  name: ${id_prefix}
  friendly_name: ${friendly_name}
  name_add_mac_suffix: true
    name: ratgdo.esphome
    version: "2.0"

  board: d1_mini_lite
  restore_from_flash: true

  package_import_url: github://ratgdo/esphome-ratgdo/v2board_esp8266_d1_mini_lite.yaml@main

    url: https://github.com/ratgdo/esphome-ratgdo
    files: [base.yaml]
    refresh: 1s

# Sync time with Home Assistant.
  - platform: homeassistant
    id: homeassistant_time

# api:
#   id: api_server

      key: redacted



  ssid: !secret wifi_ssid
  password: !secret wifi_password


you ever figure this out?

I have not. Still trying to narrow it down. Are you having a similar issue?

Further updates:

I tried the sync button solution via, with no luck.

I tried swapping out the api to match the default ratgo yaml, also no luck.


      key: xxxx


  id: api_server

The hardware I’m using is using pin D1 instead of D4 for the uart_tx_pin however, I don’t know enough about IO pins to know if this is a problem.

I was having similar behavior, such as:
Status was accurately reporting
Light control was working
Hardware and original GDO remote buttons were working
Software (HA) buttons were not operating the garage door
I seemed to regularly lose connection - the whole RatGDO page hit by IP address didn’t always load

What I did that fixed it…

  1. Swapped out power supply. I originally used an old cell phone charger and replaced it with the charger I got from an rPi kit. That solved that the RatGDO ui wasn’t always fully loading. The stats on that original charger claimed the same output as my rPi supply - it obviously had enough power to report status and control the lights, but it wasn’t consistent/complete.

  2. Wire connections into the GDO weren’t reliable. The cheap GDO spring clips weren’t holding twisted wire connections or giving a good connection to them both, in both my white and red connectors. For the white wires (GDO wall button plus ratGDO connection) I ferule crimped them together and that worked. For the red wires (GDO wall button, ratGDO +… don’t remember, but there were 3 wires) they wouldn’t fit into the crimped ferule connector I had, and then also fit into the spring connector securely - so I ended up using a 4-wire wago type connector. Each of my 3 wires went into the connector, then ran the 4th connector back to the GDO, eliminating twisted wire connections.

Has worked reliably for a week since.


I don’t have any issues with the ui loading, so I guess my power is sufficient.

However, I will try re-wiring again with your tips. Thus far I have been twisting only (with different wires).

Thanks for the input.

Update: I’m fairly certain it’s not wiring related.

I went and picked up some solid 18g wire and some wago connectors. Previously I was using stranded wire and twisting them together. Anyway, I wired it all up and still the same result.

I know the wiring is working because the door still works via remote/button/etc, which is now going through the wago connectors before getting to the opener. Additionally (as before), everything in Home Assistant is accurate (status, sensors, etc). Just the buttons to open/close/toggle the door and or light do nothing.

For posterity, my model numbers are:

  • Chamberlain Wd832Kev
  • Chamberlain B750

A thought; when opening/closing your door, what do the ratgdo logs say (before it starts publishing percentage).

When using the remote (and the door properly opens) it says:

Status: door=OPENING light=ON lock=UNLOCKED

When pushing the button in the GUI (and the door does not open) it says:

'Door' - Setting

I would think they should be the same no?

Beyond that, I’m stuck. Not sure where to go from here. Any other suggestions would be much appreciated.

I had some similar behaviors too, with the up and down buttons in the Home Assistant and esphome interfaces not having any effect on the garage door despite messages in the esphome logs that action was underway. What I did find was that the toggle button and stop buttons did cause the garage door to raise and lower, both in esphome and Home Assistant. Not sure why these work and the up and down buttons do not. Currently wondering whether it is GDO-specfic. I am using a Chamberlain EVO-100 GDO.

Unfortunately, my toggle button does nothing.

Was looking around for info on where to find the logs you asked about today (first day I noticed the reply, sorry) and found this link which may interest you:


That lead me to wondering where the newer firmware is… GitHub - ratgdo/mqtt-ratgdo: ratgdo via mqtt

Hope it helps

That’s interesting. I think I’m running v2 at the moment. I’m going to pull one down and flash it as soon as I get some spare time.

Thanks for the share. Sounds promising.

Any luck with this? I am having the same problem. I can see the blue light on the RATGDO flash when I toggle in HA but the garage door does nothing.

I haven’t had a chance to re-flash, so no updates yet. Hopefully this weekend.

Also, I could be wrong, but I don’t believe my lights flash when I push buttons, so we may have different issues. Just throwing that out there.

I ended up re-flashing using the ESPHOME setup and so far so good. Also has more sensors which is nice.

I’m already on ESPHome, so we definitely had different issues.

@barroomhero barroomhero - Any luck with resolving this as I am going through the same thing and I have the device V2.0 as you

I have not. I got frustrated, then lazy about it.

I need to do it. My next step is easy; I just want to re-flash the newer firmware on the device. I’m hoping that helps but after that I’m out of ideas.

I also have this issue.

here is my Custom:Button card. I do want to make a few changes but is works.

type: custom:button-card
entity: cover.ratgdov25i_f393ba_door
name: Garage Door
show_icon: true
show_name: true
show_state: true
  action: toggle
  - value: open
    icon: mdi:garage-open
    color: rgb(255,0,0)
  - value: close
    icon: mdi:garage

I was having this problem (March 2024) with my Ratgdo v2.53i (e.g. esphome-ratgdo/static/ratgdo_v2.5xi.jpg at e3eacef44d6008aeb8a342a2fbb8e75d9cf6c98c · ratgdo/esphome-ratgdo · GitHub) with the a newly installed Liftmaster garage door opener, and dug around and eventually determined the default auto-adopt YAML presented by HA/ESPHome is incorrect, because it’s for a v2 board, not a v25.

The problematic auto adopt ratgdov25i.yaml segment is:

  ratgdo.esphome: github://ratgdo/esphome-ratgdo/v2board_esp8266_d1_mini.yaml@main

notice the “v2board”, and if you look at the corresponding pic, this is not the device i have: esphome-ratgdo/static/v2board_esp8266_d1_mini.png at e3eacef44d6008aeb8a342a2fbb8e75d9cf6c98c · ratgdo/esphome-ratgdo · GitHub

So I changed the line to:

  ratgdo.esphome: github://ratgdo/esphome-ratgdo/v25board_esp8266_d1_mini.yaml@main

and now all door functions work flawlessly!

After digging through a bunch of the github configs (github com/ratgdo/esphome-ratgdo/tree/main/static), I noticed the key difference in settings between the v2 and v25 for esp8266_d1_mini:

uart_tx_pin: D4


uart_tx_pin: D1

Hope this can be helpful to others. Not sure why HA didn’t auto-detect the correct board, because the rat garage guy doesn’t even sell that old v2 board anymore.


p.s. sorry for the mangled links, this forum would only allow me to include 2 because this is a nuub account.