Home Assistant Community

Recovering a Snapshot?

#1

I had to reflash my micro SD card, I have added Samba and put my snapshot in the backup folder but I can’t figure out how to get the snapshot tab to display my snapshot to restore from (no more refresh button)

0 Likes

#2

Perhaps restart home assistant?
Or perhaps you can load it from the panel? (Developer Tools>Services and call the hassio.restore_full service)

See here too Hassio 0.61 Snapshot Service

0 Likes

#3

I ran into this issue as well. Restarting my Raspberry Pi made it show up. I hope this helps someone in the future!

4 Likes

#4

from ssh you can run
hassio sn reload
and it will update the snapshot list.
I think there’s a reload now in the front end as well.

3 Likes

#5

@DavidFW1960, @dale3h, I can confirm a restart of the host (Rpi etc) is needed. Restart of hassio from webui or supervisor restart does not do the trick.

1 Like

#6

I don’t know what you are doing but I can reload snapshots without restarting the host just fine.

0 Likes

#7

I dont know what you are doing, but I can’t :slight_smile:

1 Like

#8

I’ve done it twice over the last few days.

0 Likes

#9

You and me both mate. Definitely doesn’t work on my hassio.

0 Likes

#10

I had same issue. There’s a small refresh button in the right upper corner on the snapshot page. That worked for me

7 Likes

#11

Same here!

0 Likes

#12

@Try2Fly you are right, the refresh button forces to system to reload the snapshots. I have done it with a rpi3 and the new hassio

1 Like

#13

Thanks much! I was totally overlooking that refresh button.

0 Likes

#14

Try2Fly - Thank you! I was beating my head against this too, not seeing that button!

0 Likes

#15

Hey guys, hope you don’t mind me asking. Woke up this morning to find several of my configuration files have become unreadable.

I’m trying to restore my most recent snapshot. I can see it and hit ‘restore selected’ but it doesn’t seem to be doing anything.

What should I see to know it is restoring?

0 Likes

#16

The hassio sn reload didn’t work for me, but the little refresh button in the corner did work. Thanks.

0 Likes

#17

Hi David, replying to you because I notice you are very active here.

I have been using hassio for 4-5 months, decided to do a new install because of many errors in log file about corrupt .py files, etc…

I copied the .tar file to another location. I have the new install up and running, installed samba from the add on interface. When I try to alter username and password (i can change the interface w/o issue) I can not save and get this message:
not a valid value for dictionary value @ data[‘options’]. Got {‘workgroup’: ‘WORKGROUP’, ‘username’: ‘hassio’, ‘password’: None, ‘interface’: ‘eth0’, ‘allow_hosts’: [‘10.0.0.0/8’, ‘172.16.0.0/12’, ‘192.168.0.0/16’]}

also, when I try to upload the .tar file into the backup folder through the configurator, it does not upload, so even if I refresh the view it does not show any restore options.

I have restarted and rebooted a few times.

What am I missing? Am I supposed to use putty?

0 Likes

#18

When an addon config turns red, you have a formatting error so check for that. Look for missing quotes, commas, etc. Also, you need to have a password.

0 Likes

#19

thank you, the quotes on password were missing as the default value off null does not show it requires quotations like the other fields do!

Okay, I still can not upload the tar file via the configurator, how do I get a windwos share like I had before I used the nuclear option?

0 Likes

#20

I use the ip address of home assistant within file explorer. \\192.168.1.240, for example. Then I add \config or whatever to quick access. Don’t bother messing with host names or the network browser.

0 Likes