Redmond ready for sky support


Would it be possible to add support for controlling Redmond readyforsky items?

Here is their website:
Here is what I found about its protocol:

I have a kettle and can support with testing or something else.

Here is an article about Redmont readyforsky kettle protocol on russian language:

I just wanted to point out to non-russian speakers that there is also a custom component available for Redmond SkyKettle G200S (also works with G210S and other kettles with similar software).

1 Like

I’ve tested the component. Works great on RPi with Debian, but it doesn’t work with on hassio because gatttool is deprecated and not installed.
The component needs to be rewritten to use python Bluetooth interface.
I guess using btlewrap like:

Sorry, I may be misunderstanding, but there is a separate which definitely works with hassio.

The hassio version differs in few rows and uses pexpect and gatttool.
Maybe I miscongured rpi, but I didn’t make it work.
0. I have Raspberry Pi 3 B

  1. I configured it with official manual
  2. Installed the custom module using
  3. Received error in logs on missing gatttool

I tried to ssh and install gatttool with bluez-deprecated, but it didn’t see hci device to scan for ble devices.
So I could test it only on Official Debian Stretch Lite for RPi.

I am trying to use a new version of the component.
Here is the link:

I putted, manifest.json, files inside the “custom_components/R4S_G200S” directory.

Then I added the following configuration:

  - platform: R4S_G200S
    device: 'hci0'

Finally I received the following error after validating the configuration: “Platform not found: water_heater.R4S_G200S”

I use Home Assistant 0.96.5

May anyone suggest me what I am doing wrong or what should I check?

Update: Seems like the issue was solved by restarting the home assistant.

А точнее конфигурацию можете написать а то у меня ругается
Error loading /config/configuration.yaml: while scanning a simple key
in “/config/configuration.yaml”, line 120, column 5
could not find expected ‘:’
in “/config/configuration.yaml”, line 120, column 9
может что то не подключил ?

в подключении чайника к HA я полный чайник а точной и доскональной документации для чайников я чет толком найти не могу

У меня вышло настроить подключение. Правда под мой чайник компонент не очень подходит, видать API поменялось с версией чайника но включать/выключать чайник я могу.

Вышло так:

  - platform: R4S_G200S
    device: 'hci0' # hardware bluetooth device
    mac: 'kettle_mac_address_here' # your kettle mac
    key: 'bbbbbbbbbbbbbbbb' # 8 byte password
    scan_interval: 90

У вас судя по всему в конфигурации ошибка, наверное отсутствует “:” в нужном месте.

Все равно не получается но спасибо за помощь

@sani Hello, which model of kettle do you use? is it G200S or a newer one?

Hello, I use RK-G213S.
Seems like it is newer than G200S.

Its work fine for me
But theare one moment with key
I download bash file from here

And connect with bash script
And then add key from bash to config

which key u get from bash?

  - platform: R4S_G200S
    device: 'hci0'
    mac: 'FC:D9:F3:A6:FA:97'
    key: 'b54c75b1b40c88ef'
    scan_interval: 90

Из вот этой статьи
Вот этот скрипт им коннект сначала делаю
а после того как чайник его принимает то начинает работать и в хомасистанте

Да, спасибо! Получилось авторизоваться на чайнике. Но управляться не хочет. У меня модель чайника M216S (

Жаль. А на моем RK-G201S работает полностью все. Видимо изменили протокол. Пропиретарные протоколы - ЗЛО!

С 216 версией есть информация? смог залететь?

Дайте ссылку на компонент, пожалуйста. Выше ссылки не работают уже…