Rehash/Updates? Controlling EcoSmart Lights with HA and the Lutron Aurora

Hello everyone!

I’m having issues with zha smart lights, an Aurora Lutron Dimmer, and HA.


  • Home Assistant 2021.11.5 (Raspberry Pi 4B)

  • Nortek HUSBZB-1 Zigbee & Z-Wave Plus USB Stick

  • EcoSmart BR30 Smart Lights

  • Lutron Aurora

In our living room, I have 5 EcoSmart lights on track lighting. I have them paired to my HA system via a Nortek dongle (using zha). I’ve been able to change brightness and color temp with no problem via my phone or tablet using my HA dashboard.

However, I wanted to add a smart hardware dimmer so a mobile device would not be needed to control the brightness.

I picked up a Lutron Aurora smart dimmer, but I’ve hit a roadblock as the lights are paired with HA, not the dimmer. If I instead pair the lights with the dimmer, I then lose the ability to control them via HA. I’m caught in a loop!

I assume the best course of action is to keep the lights paired with HA, and then pair the dimmer with HA, and have HA orchestrate the control of the lights via the dimmer.


I’ve tried several approaches (Node-Red via @kmclaughlin , Event Sensor integration, Automation via the HA GUI or editing the automations.yaml file, and none seem to work.

FWIW, I have a very similar situation in another room, and it works fine (I just don’t recall what I did). This includes the Aurora dimmer and Phillips Hue recessed lighting. I can use either the Aurora dimmer or HA to control the lights. I seem to recall I paired the lights with the dimmer and with HA, which seems counterintuitive…unless Hue lights have the ability to be controlled via multiple zha masters.


I’m in a similar situation where I have the same Nortek HUSBZB-1 stick and am not able to use the Lutron Aurora buttons. I have a Philips Hue bridge where they pair perfectly with it, but the buttons can only control lights that are connected to the Hue bridge.

I read a forum post saying that the HUSBZB simply doesn’t work with the Aurora buttons. I’ve connected the buttons to the stick once and was able to turn on/off the lights, but could not control brightness reliably. I bought a cheap Itead Sonoff Zigbee 3.0 USB stick hoping that would fix the problem, but I haven’t been successful yet. I’m hopeful though!

I’ve also updated the Zigbee firmware on the HUSBZB stick but that didn’t fix the issue either.

I hope you can find a solution that doesn’t require buying a new Zigbee stick.

@dwinnn I think this post sums up the issue:

Same situation here - Nortek HUSBZB-1 with Lutron Aurora rotary dimmers - rotation registers (sometimes) and button clicks register extremely rarely (i.e. maybe 1 in 50 clicks?). I believe the only solution is a different stick - I’ve read that the Conbee2 is a good alternative although I already have a zzh! from Electrolama onorder so I’m gonna see if that does the trick first.

@dwinnn @nixtaoz

I picked up a Conbee II, and it does indeed fix this problem, but I find the Conbee II to not work as reliably with other devices as the Nortek.

After I discovered the not-as-reliable Conbee II, decided just to go with a newer Sonoff Zigbee 3.0 stick. Cheaper and more horsepower. I’m awaiting that to arrive (they ship from China, I believe). Once that’s arrived, I’ll return the Conbee II (thanks to Amazon’s generous return window). I’m hoping the Sonoff Zigbee 3.0 solves all ills.

I used the Sonoff Zigbee 3.0 stick to pair the Lutron Aurora button but still had the same issues, however I only tested with some blueprints. I never fully understood how the buttons worked and what events are registered to trigger an automation. I eventually gave up and bought some Philips Hue lights on sale and connected the Aurora buttons to my Hue bridge. I hope you have better luck!

1 Like

@dwinn to clarify, you couldn’t pair the lights and the Aurora to the Sonoff and have them controlled via zha? Or, could you pair them successfully, just not have HA respond properly to Aurora button pushes and turns to control the lights?

The Aurora button technically paired to the Sonoff using ZHA, but all I saw was a battery sensor. This was the same when I paired with the Nortek HUSBZSB. I looked at Zigbee logs to see if any events were coming from the Aurora buttons but didn’t see anything.

1 Like

Post testing here for others who may find this thread:

Adding a Sonoff Zigbee 3.0 Plus dongle to my HA system as a replacement for my Conbee II works with the Aurora Lutron, just as the Conbee II did (but Nortek stick did not.)

Be sure to use this blueprint after pairing to the Sonoff vs zha.

…and yes, all devices had to be re-added manually…and don’t forget to unpair any Hue lights before starting your manual re-pairing…ya gotta unpair them via HA (or with their dimmer remote) before you can re-pair them with a new zha stick.

1 Like