ZHA - Lutron Aurora Dimmer Blueprint

Tags: #<Tag:0x00007fc40c0710e8> #<Tag:0x00007fc40c070e18> #<Tag:0x00007fc40c0708f0>

This blueprint supports the Lutron Aurora dimmer (model: Z3-1BRL) through the ZHA integration.

Open your Home Assistant instance and show the blueprint import dialog with a specific blueprint pre-filled.

Description:

Control lights with a Lutron Aurora Dimmer Switch.

Pressing in the dimmer button will toggle between turning lights on
to full brightness, and turning the lights off.
Rotating the dimmer will increase and decrease the light brightness.

Adjust the sensitivity in the automation setup if updates from the dimmer are being sent too quickly

blueprint:
  name: ZHA - Lutron Aurora Dimmer v1.3
  description: 'Control lights with a Lutron Aurora Dimmer
    Pressing in the dimmer button will toggle between turning lights on
    to full brightness, and turning the lights off.
    Rotating the dimmer will increase and decrease the light brightness.
    
    Adjust the sensitivity if updates from the dimmer are being sent too quickly
    '
  domain: automation
  input:
    remote:
      name: Lutron Aurora Dimmer Switch
      description: Lutron Aurora Z3-1BRL
      selector:
        device:
          integration: zha
          manufacturer: Lutron
          model: Z3-1BRL
          entity:
            domain: sensor
            device_class: battery
    light:
      name: Light(s)
      description: The light(s) to control
      selector:
        target:
          entity:
            domain: light
    sensitivity:
      name: Sensitivity
      description: Reducing sensitivity will reduce rate of changes being sent to lights
      default: 3
      selector:
        number:
          min: 1
          max: 3
          mode: slider
          step: 1
  source_url: https://community.home-assistant.io/t/zha-lutron-aurora-dimmer-blueprint/292421
mode: restart
max_exceeded: silent
trigger:
  - platform: event
    event_type: zha_event
    event_data:
      device_id: !input "remote"
action:
  - variables:
      sensitivity_input: !input "sensitivity"
      selected_light: !input "light"
      sensitivity: >
        {% if sensitivity_input == "3" %}
          1
        {% elif sensitivity_input == "2" %}
          5
        {% else %}
          15
        {% endif %}  
      prior_brightness: "{{ brightness | default }}"
      command: "{{ trigger.event.data.command }}"
      brightness: "{{ (trigger.event.data.args[0]|int) / (sensitivity|int) * (sensitivity|int) }}"
  - choose:
      - conditions:
          - "{{ command == 'move_to_level_with_on_off' }}"
          - "{{ brightness != prior_brightness }}"
        sequence:
          - service: light.turn_on
            target: "{{ selected_light }}"
            data:
              brightness: "{{ brightness }}"
1 Like

Thank you … works great :+1:

Replaced my simple automation for this with your BP because…well…blueprints are prettier.
Thanks for sharing.

Fyi, this is not what I’m seeing (and not what I expect to see based on how this dimmer works). The on/off toggle goes between off [0] and full brightness [255].

Thanks for catching that. I’ll clean the description up…

1 Like

Since upgrading to 2021.4 I’m getting the following.

image

Your thoughts?

There are some new warnings added in the latest release. This is one of them.
I’ve updated the blueprint to clean up those warnings. If you are still seeing anything in the logs after updating to the latest blueprint, let me know.

Hello, I’m new to Home Assistant and when I create an automation using this blueprint it says there are no matching devices. I have a ton of Lutron Aurora buttons on my home assistant so they should be there. Am I doing something wrong?

Are they on ZHA or via hue?

They are connected to my Hue hub

Won’t work then. Zha and deconz are separate from hue. All run on signee protocol so you can connect his things to these other hubs. But only one at a time. So it ain’t work for you unless you do other stuff

Hi @matthewkessler96. As @jeeftor noted this blueprint works for Aurora Dimmers that are connected into a ZHA zigbee network integration, rather than a Hue integration.
To my knowledge integrating Hue dimmers (especially the Aurora) into HA automations can be a bit challenging as the Hue integration doesn’t appear to expose enough information in entities or events to be useful for many automations. You may be able to find some folks on this site that have had some success. I’ve looked previously, but wasn’t able to find much.

Thanks for the reply. I only just started using Home Assistant a few weeks ago so I’m very new to all this. Are you saying that if I added a Zigbee module to my Raspberry Pi that’s I’m using as my Home Assistant Hub I could connect to the Auroras directly and expose more functionality?

That is exactly what @bjpetit and @jeeftor are saying :slight_smile:

Zigbee is a protocol and then there are sub protocols within such as ZLL (Zigbee Light Link) which is what hue runs - which is (in theory) Zigbee 3.0 compatible (I believe).

There are various bridges out there that support various flavors of Zigbee: Ikea, Hue, Aquare etc. - as well as dropping in a Zigbee stick into the pi and then running your own server such as ZHA.

Then to get more complex I think you can run “emulated-hue” or “diy-hue”? on the server to make it so some of the hue apps think the devices are “hue” compatible.

I haven’t gone down that route yet.

This is like genius! Thanks! I’d purchased a Hampton Bay ceiling light that is supposed to integrate with a Wink hub, so I crossed my fingers and hoped that it would work with my Philips Hue hub but that hasn’t worked out. But, it integrated easily with ZHA. I’d never added an Aurora switch into HA, before, which would have been difficult as I’ve also never created an automation using a JSON event result. With your blueprint, I didn’t have to bother with a single line of coding.

1 Like

Only partially working for me. Spinning the dial changes the brightness but pressing the button will not turn them on, can only turn on with the dial. Pressing the button to turn them off only works if you first spin the brightness all the way down.

Hmmm. I’d be interested in seeing what events are coming through when you push the button on the dimmer. If you’d like to see the events that this blueprint is looking for, you can run through the following steps in home assistant…

  1. Go to Developer Tools → Events
  2. Set ‘Event to subscribe to’ to zha_event
  3. Click ‘Start Listening’

This will display events coming in through the zha integration. When you click the button on the dimmer you should see an event that looks something like this…

Event 53 fired 7:17 AM:
{
    "event_type": "zha_event",
    "data": {
        "device_ieee": "xxxxxxx",
        "unique_id": "xxxxxxx",
        "device_id": "xxxxxxx",
        "endpoint_id": 1,
        "cluster_id": 8,
        "command": "move_to_level_with_on_off",
        "args": [
            0,
            7
        ]
    },
    "origin": "LOCAL",
    "time_fired": "2021-06-24T12:17:35.790651+00:00",
    "context": {
        "id": "xxxxxxx",
        "parent_id": null,
        "user_id": null
    }
}

Depending on what other devices you have in your Zigbee network, you may see some other events too. But you can look at the device_id/unique_id values, which should be the same for all of the events that come from your dimmer.
The key fields in this event are the command, which should be “move_to_level_with_on_off” and the first number in the args list. When you push the button you should see that first args entry toggle between 0 and 255 with each push. When you spin the dial that number will increase and decrease, with the range between 0 and 255.

Off the top of my head, either an event isn’t making it through when you push the button, or one of the event values that comes through when the button is pushed is unexpected.

If you want to dig in a bit, take a look at the zha events and let me know what you see and we can try and determine where things are misbehaving.

Thanks, this is the first and only zigbee device on my network. It appears that clicks are not being sent as events only when I scroll the wheel. Maybe 1 in 100 press I get the event button. Perhaps the device is defective?

Edit: I just paired a second lutron aurora and have the same issue. I only get wheel events.

Edit2: if the are are [2,2] if I press the button then I will get the args [0,2] otherwise it seems the button never fires a vent.

Are you using a Nortek HUSBZB-1 USB stick for ZHA? I wonder if you are seeing this. It’s been around for a bit. But I’m not sure that its been fixed.

1 Like

Well I can confirm that I have the same behavior, and am using that device. Of course… lol I’ve been using one Aurora paired directly with some bulbs, but I just tried your blueprint so I could include some wifi bulbs. Sooooo close…