[Release] Inception alarm/access control panel by Innerrange

logo
This is an addon that integrates the Innerange Inception System with home assistant. There exists a project already that does this for users of HA core, this addon is for users of HA OS (Supervised).

This addon is a fork from matthew-larner/inception-mqtt that used a separate docker container to run the service. This service is the same as above (assuming fork does not diverge too much due to updates on original project), wrapped as an addon that allows users of Home Assistant OS (supervised) to run the service.

To Install:

Go to Supervisor -> Add-on Store -> 3 dots at top right -> repositories
Enter https://github.com/samturner3/homeassistant-addons and click add.
Screen Shot 2021-03-24 at 12.34.39 pm

You will find a new card under Sam's Home Assistant Addons. Click it.
Screen Shot 2021-03-24 at 12.34.55 pm

Click install

Go to configuration tab

Enter in required controller details. See readme for details.

Start addon and monitor logs by clicking Log tab at the top.
Ensure there are no errors. You know it is working once you see your controller entities being listed.

You should now have working addon!

Important tips:

  • This addon requires you have setup and running an mqtt broker within HA.
  • If you cannot see all devices ensure the user you logged on with has the appropriate permissions in the inception web interface.

This is my first addon, let me know how you go :slight_smile:

I went to give this a crack tonight and when I started it. I got this error.


[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[17:46:13] ERROR: Got unexpected response from the API: Service not enabled
[17:46:14] INFO: Starting service.
> [email protected] start /usr/src/app
> if-env NODE_ENV=local && npm run start:dev || npm run start:prod
> [email protected] start:prod /usr/src/app
> node ./dist/index.js
Invalid URL: mqtt://:@:NaN
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] start:prod: `node ./dist/index.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] start:prod script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2021-03-28T07_16_15_277Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] start: `if-env NODE_ENV=local && npm run start:dev || npm run start:prod`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2021-03-28T07_16_15_309Z-debug.log
[cmd] /run.sh exited 1
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

from the API: Service not enabled.

Not :100: sure what service this refers to, but ensure you have a mqtt broker setup on home assistant and ensure the username’s user on the inception API permission is enabled. Check readme for details.

I’m all good there have a mosquito broker and have it as an integration. I think this line in the log is key
Invalid URL: mqtt://:@:NaN
It reads to me like it is not picking up the MQTT server configuration.

API is all good in inception. Was using Matt Larner’s setup before I thought I would give this integration a go.

Ok next version I’ll give option to select mqtt broker manually in case someone is not using the internal HA one. Hope this would help a few people.

In that version I’ll also intergrate changes from original project.