Remote access and port forwarding

after two days of trying a lot of probabilities, finally i have remote access from cellular network, and that’s the problem, because that is the only access i have from the application on my phones, if i change to wifi i lose connction or i have to browse the “httpS://my.ip.address:8123” on pc only to get access.
this is my router configuration after port forwarging.

Best regards.

What home assistant installation method did you use, e.g. hassio?

What are you using to generate your SSL certificates?

Are you really using a (static?) public IP address or have you used a dynamic DNS service like DuckDNS?

hey Tom,

i am using Hassio on a raspberrypi 3 b+ ,
for IP address i am using duckdns, encrypt ssl is integrated…

Does your router support hairpinning (NAT loopback)?

What error do you see in the PC browser when you try to access via your local network?

Also you can delete the 443-443 port forward rule. Not needed unless you are using it for something else.

this is what i get when connected by wifi, (connection lost, reconnecting…)
and for 443-443 port forward, if i delete it i lose all access on the application.

Are you using https://my_duckDNS_address:8123 ?

Are you using a reverse proxy?

no proxy only https://my_duckdns_address:8123

If you are using

Then you should not need to forward 443.

Something odd going on here. No idea what.

I do suggest you check this:

I used home assistant at work and remote access did not work from local wi fi (hassio, duckdns). Nat loopback was exactly the point and my friend helped to manage that from router settings. So, in this case you are probably right too.

it workdt once in the morning without touching to any Nat Loopback parameters, after a reboot to make sure that everything is ok i lost access so i installed a recent hassio and that’s the problem.

Can you tyr this:

no on the pc’s browser i don’t have probleme, it is in phone’s application as i shown you.

I meant trying to access HA from your PC using the duckdns address not the ip address.

Ok. Let me get this straight.

Cellular network:
mobile phone access to == ok

Local network
PC access to == ???
PC access to https://ip_address:8123 == ok
mobile phone access to https://ip_address:8123 == ok
mobile phone access to == fail

If that “???” is “fail” then this is almost certainly a NAT loopback problem with your router.

Cellular network:
mobile phone access to == ok

Local network
PC access to == fail
PC access to https://ip_address:8123 == ok
mobile phone access to https://ip_address:8123 == fail
mobile phone access to == fail

Yep, NAT loopback problem with your router.

Also your wireless router security settings aren’t allowing access between clients on the network.

any solution please, because it is little bit weird sometimes it works when i desactivate and reactivate the port forwarding for 443 but after a reboot i lost it.

What’s your router make and model?

If you cant really touch the router I suggest you start running split dns. install adguard home, pi-hole or dnsmasq.

Personally I prefer the adguardhome and it will also provide you with adblock and tracking.
With this you can add your HA as dns on your local network and tell to always use https://ip_address:8123

1 Like

sorry to be late i was bloqued because i am new so i am limited on posts; i have netis DL4323D.

i am trying and i’ll give you the feedback, it would be a great idea if i do not have to touch to the router.

can you tell me please what to put here, (forwards domain and server).

  "defaults": ["", ""],
  "forwards": [
    {"domain": "????", "server": "????"}
  "hosts": [
    {"host": "", "ip": ""}