Remove Space between entities card

Hi there,
This card should list me some system stats. At the End of the card, there are also some conditions, to show the status of my 3 NAS only when they´re turned on, and it looks like this:

Why is there so much space between the entry “HA Database Size” and the Diskstation-sensors and how can I reduce them to aliign correct to the other entries?

Here is the code:

  - color: 'rgb(223, 255, 255)'
    color_type: label-card
    name: system stats
        - height: 15px
      action: navigate
      navigation_path: /lovelace/7
    type: 'custom:button-card'
  - cards:
      - entities:
          - entity: sensor.speedtest_download
          - sensor.speedtest_upload
          - binary_sensor.fritzbox_connectivity
          - entity: sensor.fb7590uptime
            icon: 'mdi:clock'
            name: Fritzbox 7590
          - entity: sensor.ha_uptime
            name: Hassio
          - entity: sensor.nucuptime
            icon: 'mdi:clock'
            name: NUC
          - entity: sensor.omvuptime
            icon: 'mdi:clock'
            name: OpenMediaVault
          - entity: sensor.db_size
            icon: 'mdi:database'
            name: HA Database Size
        show_header_toggle: false
        title: null
        type: entities
    type: vertical-stack
  - cards:
      - card:
            - entity: sensor.ds3status
              icon: 'mdi:database'
              name: Diskstation3
          type: entities
          - entity: switch.diskstation3
            state: 'on'
        type: conditional
      - card:
            - entity: sensor.ds2status
              name: Diskstation2
          type: entities
          - entity: switch.diskstation2
            state: 'on'
        type: conditional
      - card:
            - entity: sensor.ds1status
              name: Diskstation1
          type: entities
          - entity: switch.diskstation1
            state: 'on'
        type: conditional
    type: vertical-stack
type: vertical-stack

At least I can see why: I´m using the Amoled theme, so I couldn´t see that every entity from the Diskstations is in one card.
Any hint on how I can put them into the enttities card with the condition if they are on or off?

Gotta use a different card type. auto-entities or the monster card. Both are custom cards.

Why not just use an entities card and put them all in there ?

cause he has conditionals on them. He wants to maintain conditional visibility and have them in 1 card.

EDIT: Probably could do these conditionals inside an entities card but you’d need to use the under the hood names hui-xxx

So entity_filter ??? I think you helped me with that one once :crazy_face:

oh yeah, that would work, forgot about that card

Thanks for the tip with the entity_filter. Works well.

With such a dark theme, how do you get on with the unused entities page ?

I don’t see anything in unused entities even with the default theme on 0.101.3.

And I do have unused entities.

Never used the page before, but looks okay?

something must be wrong on your system. Mine pretty much says all my entities are unused because I’m using all custom cards. Seeing your setup in the past, I would assume you would have the same ‘problem’.

I must admit that ‘interface’ is kind of a poor cousin to the automations for me so they have a much lower priority.
I’ll probably invest more time when I’ve made everything else ‘feature rich enough’ :crazy_face: (so read a LOOOOOOONG time ! )

But I normally run with JuanTech’s Grey - Orange Theme and when I’m looking for entities I have to switch to Light - Orange.
It’s probably a fault in one of the text colour elements, but don’t know how to find what and where and the correct value.
This is what my unused entities looks like normally, about as much use as a chocolate teapot !

Petro, yep. I even mentioned that here: 0.101: Airly, Apprise, Sinch, Solar-Log, Microsoft Teams

@Mutt There is a theme setting you have to add. I can’t remember it though. Will have a look for you tomorrow. Bedtime now.

Thank you kind sir !
Sleep Tight

Hmm, i’m still on 0.101.0b. Maybe i’ll update to 0.101.3 tonight and see if I have the same issue.

@Mutt pretty sure this is it:

card-background-color: "var(--paper-card-background-color)"

@petro It has to be something wrong with my system as others on the latest version don’t have the issue.

Thanks for trying but …
I made a copy of the line before trying … but the result was the same

  ### Cards ###
  ####paper-card-background-color: "#23232E"
  paper-card-background-color: "#494B58"
  paper-listbox-background-color: var(--primary-background-color)

It did require a restart but ALL my normal cards went the ‘background’ grey (so it did change stuff - just not the entities background (or the UE text - either is good for me))

Not sure why the card background is applicable to unused items as my standard cards are dark (see below) and the UE is near White (but then again “I know Nothing !” :rofl: )


card-background-color: "var(--paper-card-background-color)"

Not paper-card...

It worked for me and everyone else:

1 Like