Remove States from Alarm

I would like for the overlay alarm card to only show the home, away and disarmed state. I have no use for night, vacation and custom.

  - platform: manual
    name: Home Alarm
    trigger_time: 300 #how long does the alarm sound
      trigger_time: 0 #set to 0 so it never triggers when disamed
      arming_time: 1 #set to 0 so it goes to state armed_home right away when enabled
      delay_time: 0 #set to 0 so it will trigger an alarm as soon as something happens
      arming_time: 1 #set to 60 so we have 60 seconds to leave the house before the alarm will go to away mode when enabled
      delay_time: 20 #set to 30 as this gives us 30 seconds to disable alarm when returning
1 Like

Edit the dashboard card and in-tick the modes you don’t want.

This only works for the lovelace card and not the overlay.

If I press the cog wheel on the overlay I get:

This entity ('alarm_control_panel.home_alarm') does not have a unique ID, therefore its settings cannot be managed from the UI. See the documentation for more detail.

So basically I’m trying to figure out how I can define the available states via yaml.

It should change the pop-up card too. It does for me. Try clearing your browser cache.

That’s not where you change it.

For some reason it does not work for me. Checking the states are reflected in the lovelace card but not overlay. Tried reloading from completely reset browser as well as incognito mode. I find it odd there is no way to specify the states you want in yaml.

Additionally I’m showing the overlay when pressing a chip card where there is no way to specify the states. Hence why I was looking for a way to specify the states overall for the alarm via yaml.

Screenshot 2023-05-18 at 09.28.11

I’m using Alarmo rather than the manual alarm control panel. Maybe that’s the difference.

You might like to try it. It is a lot easier to set up than the manual alarm panel.

That is the difference for sure. Will give Alarmo a go.

I want to add something to thist topic because using Alarmo is a possibility, but not the solution at the problem I had.
I didn’t find any guide to do this, so I will write here.

I wanted to remove some option from my manual alarm.
So initially I had the manual alarm configuration:

  - platform: manual
    name: Allarme

with some automations when the alarm was set to away_vacation

To limit the number of option I have now created a template alarm:

  - platform: manual
    name: Allarme

  - platform: template
        name: Allarme corretto
        unique_id: allarme_corretto
        value_template: "{{ states('alarm_control_panel.allarme') }}"
        code_arm_required: false
          service: alarm_control_panel.alarm_arm_vacation
            entity_id: alarm_control_panel.allarme
          service: alarm_control_panel.alarm_disarm
            entity_id: alarm_control_panel.allarme
            code: !secret alarm_code

here you can see the original alarm, thenyou add the template panel with name, ID and the manual alarm panel you want to control.

as you can see I added only arm_vacation and disarm, so now on the frontend I see only those

Hope this help!