Reolink NVR stream: or snapshots.. Please I need help seeing them on hassio

The NVR IP ADRESS is 192.168.0.34
And the cameras are 172.16.0.25:9000

I tried following the string page and got nothing and then I have been trying to use the FTP from the NVR into hassio FTP but I cannot figure out the correct directory.
Digiblur has a youtube video connecting his reolink cameras but he didn’t have the NVR and I would like to continue using my nvr and atleast send snapshots when motion is detected
Any ideas would help… Thanks

I tried that with no luck and I don’t know if it is because the reolink camera doesn’t have a local ip address, only the NVR

Does anyone know of an API or script to connect Reolink’s NVR to HA?

I had exactly the same issue but after a little bit of tinkering I found out how to get them to appear in HA through a Reolink NVR, as googling return no results.

I eventually got it working with the following:

camera:    
    -   platform: generic
        name: <name>
        still_image_url: "http://<ip_address_of_NVR>/cgi-bin/api.cgi?cmd=Snap&amp;channel=0&amp;rs=<random_string_of_characters_and_numbers>&amp;user=<username>&amp;password=<password>"
        stream_source: "rtsp://<username>:<password>@<ip_address_of_NVR>:554/h264Preview_<camera_number>_sub"

All the above should be self explainatory but the <camera_number> starts at 01 and works up.

You can then add picture glance cards with the following:

camera_image: camera.<name>
camera_view: live
entities: []
title: <friendly_camera_name>
type: picture-glance

I hope this helps you and any others who stubble upon this thread.

7 Likes

So glad I stumbled across this. I clicked order on the Reolink NVR and then I couldn’t find anything online about how I can get access to the camera MJPEG (still images) and I started to regret my decision until I found this post. I assume your’s is still going fine? I am personally wanting to put the still image URL into my Sharptools.io dashboard.

Hi Jason,

Mine is still going fantastically well, I haven’t had any drop outs or failures after a month of solid use.

As it is just using URL’s, I think they can be used in sharptools looking through their documentation but can’t be 100% certain as that’s all I know about it.

Glad you found the information helpful as I couldn’t find anything on the internet either.

1 Like

Thanks mate. I believe it will work too because I am already using MJPEG images in Sharptools.io when connecting directly to the camera but I was just worried about the NVR being in the way but I noticed your URL was slightly different to the one I current use which is below:

http://MYIPADDRESS:80/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=MYRANDOMSTRINGOFCHARACTERS&user=MYUSER&password=MYPASSWORD

So my Reolink NVR arrived and it turns out both our links work :slight_smile: and I have mine working in the Sharptools.io dashboard with 2 second image snapshots. Excellent.

Hi guys. Just wanted to drop in and say Thanks to roadkill for this post. I was struggling to integrate my cameras and nothing seemed to work because of the Reolink NVR setup.

It took me a few hours, but I finally got it to work. Roadkill’s instructions were very important, but my system still didn’t work. I putzed with it for a while, and kept getting an error that my NVR’s web client didn’t like the cgi script. It said that cgi access was unavailable.

I finally flashed new firmware to my NVR and cameras (I hadn’t done this since they were installed) and that fixed my connectivity issues. So, if anyone else is struggling, make sure your Reolink firmware is current and then try again.

1 Like

well done
thank you

do you have any idea if like to detect motion from each cam in HA

thanks

@roadkill247 is your’s still working fine? I found my link still works for a moment until it refreshes but then it breaks in Sharptools.io. I can however refresh over and over in the browser and it’s working perfectly. Any ideas?

The autorefresh in SharpTools.io appends a unique string to the URL on each refresh as a cache busting technique. (Eg. To make sure you actually get a new image each time)

For example:

&st_uuid=ffc4dece-08ea-46f3-a1e8-1c5629d71e3c

I’m wondering if the NVR doesn’t like this extra parameter. Have you tried getting an image snapshot directly from the camera (assuming that’s possible)?

Edit: I saw your message in the HE community that the cameras are only accessible via the NVR now that they’re connected to it.

1 Like

Hi @jchurch,

Can’t say I’ve come across any issues at the moment natively in Home Assistant but I don’t use SharpTools.io, so unfortunately can’t comment.

Hi @aq5001,

I’m currently trying myself to get motion detection working. It might be worth having a look at this thread - Reolink POE IP Camera Setup

All good I have learnt a bit since this post. I found a work around by using Android intents as shortcuts so when I clicked it involved VLC to open and show the stream, unfortunately though I started to notice the streams playing and then hanging which seems to be the same issue with the image refreshing I was doing. I’ve put it down to the Reolink NVR struggling at times with CPU and RAM as I see it goes red from time to time in the web client windows console.

In the end I have kept it simple and I now have tiles I just click and it takes a still image. I find this is the fastest method to quickly see what’s going on.

I have this for a URL(s)

stream:
camera:
  - platform: generic
    name: cam 1
    still_image_url: "http://192.168.4.18/cgi-bin/api.cgi?cmd=Snap&channel=1&rs=wuuPhkmUCeI9WG7C&user=admin&password=xxx"
    stream_source: "rtsp://admin:[email protected]:554//h264Preview_01_main"

And I get this …
image

If I post the rtsp url into VLC, I get the stream. If I post the HTTP into chrome I get …

image

I am suspecting the HA can not get past the snapshot having issues, just a guess.
Am I mistyping something?

Here is the versions of the NVR …
image

[Edit]
Got the stream to work in HA. When I was pasting the stream, it was the guest browser that HA VM runs in. I had a firewall rule blocking it. I don’t think firewall is the snapshot issue because the firewall rule is allows all traffic from that IP. Also, when I was testing the snapshot I tried disabling all rules to that vlan. I did not try disabling rules for the HA streaming, since VLC streaming was working.

When support at Reolink asked me about the password characters that got me thinking. I do have an exclamation point. I tried escaping it and still did not work. It will be a pain to change the password because I am running the NVR headless. If I do need to change it, can I do it from the client-side? If yes, what are the steps?

http://192.168.4.18/cgi-bin/api.cgi?cmd=Snap&channel=1&rs=wuuPhkmUCeI9WG7C&user=admin&password=John1230!

also tried the escaped version …

http://192.168.4.18/cgi-bin/api.cgi?cmd=Snap&channel=1&rs=wuuPhkmUCeI9WG7C&user=admin&password=John1230%21

I will post if I learn anything else.

Hi, do you have find a way for get jpeg snapshot of cameras connected to nvr rln16-410?

I get snapshots from each of my cameras via the Reolink NVR by going to:

http://YOURREOLINKNVRIP/cgi-bin/api.cgi?cmd=Snap&channel=1&rs=wuuPhkmUCeI9WG7C&user=admin&password=YOURREOLINKNVRPASSWORD

Note: Don’t forget to change the channel number for each one you resolve.

Unless I am looking at it wrong, what I am doing should work. Just don’t see why it does not.

I receive:

Access Error: Not Found

CGI program file does not exist

What model Is your nvr? And what software version you have?