Reolink POE IP Camera Setup

Did you get yours solved? I’ve Reolink RLC-511WA and after installing the integration I get below errors.


Error setting up entry Reolink for reolink_dev
Traceback (most recent call last):
  File "/config/custom_components/reolink_dev/__init__.py", line 77, in async_setup_entry
    push = hass.data[DOMAIN][base.push_manager]
KeyError: 'push_manager-5cc336243ca8'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 293, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/config/custom_components/reolink_dev/__init__.py", line 86, in async_setup_entry
    await push.subscribe(base.event_id)
  File "/config/custom_components/reolink_dev/base.py", line 302, in subscribe
    get_url(self._hass, prefer_external=False),
  File "/usr/src/homeassistant/homeassistant/helpers/network.py", line 83, in get_url
    request_host = _get_request_host()
  File "/usr/src/homeassistant/homeassistant/helpers/network.py", line 123, in _get_request_host
    raise NoURLAvailableError
homeassistant.helpers.network.NoURLAvailableError

Couple of weeks now struggling to get my Reolink RLC-511WA broadcasting live video on HA without good success. Now I’m stuck.

I’m using Rpi3+. I’m also having a Dahua cam that works fine. I’m able to get still pictures so I know the connection works to Reolink, but no live feed.

I’ve tried to install reolink_dev with HACs, but it generates errors and doesn’t work.

I’ve tried onvif integration and also camera integration without success. Just shows black video. I’ve tried to both main and sub stream. I’ve also tried changing the h264 profiles from Reolink settings.

The WebRTC would otherwise work, but I doesn’t work with iPhones from outside network without allowing ports in router which I don’t feel comfortable on doing.

Ideas what could be wrong? Could it be that Rpi3+ doesn’t have the power to broadcast? Would it be solved by upgrading to Rpi4?

I did several tests for my 5 RLC-810A Reolink cameras to make them work. I remember I managed to watch them with the default integration. However, latency was above 10 seconds, and that’s something that make them useless for the purpose. Finally, I stayed with the WebRTC option. Latency is almost realtime (below 1 second).

I had some problems at the begining, docker/network config related, but I could fix it by changing from brigde to host mode, although I later upgraded to an intel NUC setup.

I actually use the main entrance love feed for reference when the Amazon guys call me to deliver when nobody is at home. I open de outer garage gate and I can watch everything just at the time is happening and quite smoothly without opening the official Reolink app, as I have an opening/closing button just below the live feed. I have an iPhone too. It’s true that you will have to open a range of UDP ports, but it is worth it from my point of view.

At the end of the day, we usually have other better-known TCP open ports for other purposes like HA smartphone app, NAS, FTP server… And do not forget that you are using cameras which are probably calling to China from your home. I don’t think that opening a random range of 10 UDP ports per camera will put your local network at higher level of risk, IMHO.

Hello To all

Can anyone please help me in order to solve this issue please?

Thank you in advance for your help !!

Hello,

I have 2 Reolink cameras with sdcard and i’m wondering how to access to the saved videos on theses sdcards. has anyone done that already?

I have seen these service : reolink_dev.query_vods with the unofficial reolink addon, but how does it work? And is it possible to use it and replay saved video like in the apps?

Thanks in advance :wink:

Hello, I am unable to login:

I know my credentials are correct because I’ve used the same to add these cameras to Tinycam pro. I’ve also tested the feeds with the RTSP in VLC and they work fine. I have the RLK8-820D4-A NVR system.

Any help would be greatly appreciated.

Hi @sesardelaisla
I’m able to stream my Reolink locally in my network (192.xxxx) in custom:webrtc-camera card using inside that card url: rtsp://mylogin:[email protected]/h264Preview_01_main , but impossible to access it remotely from my iphone using HA App or through Iphone Chrome App.
Note : except WebRTC card, my entire HA pages are perfectly accessible remotely from my iphone through 4G

I followed the doc and did UDP port redirection in my router (IP source = Any, protocol = UDP, StartPort = 50000, endport = 50009, destination port = 50000, IPDestination = myHALocalIPAddress)

Any idea, why it’s not working ?

Try and uninstall, restart HA then reinstall and restart.

I have an rlc820A and the integration seems to disconnect a lot and returns

Error opening stream rtmp://192.168.1.117:1935/bcs/channel0_main.bcs?channel=0&stream=0&user=Username-here&password=password-here

I uninstall, restart HA, reinstall and restart HA once again

Seems like the integration doesn’t work friendly with the h265 stream once you do get the integration setup so go into the integration settings and the developer has given the option to change to the h264 sub-stream unless you use edge or safari then the h265 would work I hear and some people report it working on iphones as well because they default to h265.

See if this cant help get you going

Hi @isaste,

  1. Do note that you must set up the same UDP port range both in the router and in the HA WebRTC integration (click on configure and then set the UDP port range - allocate 10 ports per stream in order to be in the safe side).
  2. Taking into account what you typed about your router config, I think you are redirecting ports 50000-50009 to port 50000. You must keep the same range for destination port. If you put a single port in destination, all source ports will be redirected to the single port. Some routers do not allow to type a port range in destination field. If that is your issue, try leaving the destination port field blank/empty. The router should keep the source range for destination as well. Something like this:

IP source = Any, protocol = UDP, StartPort = 50000, endport = 50009, destination port = , IPDestination = myHALocalIPAddress

Yes! After following all your advice I can see my cameras now. Hopefully, they won’t quit on me. I’ll keep an eye on it and tweak if the connection stops working.

Thanks for the help.

Glad to hear its working for you! Absolutely. you’re welcome

been using this for a while now with all 3 4k cameras, using it along side 2 other addons and its working flawless for me, I have this setup for all the motion etch to help with triggers, I use onvif for the substream constant live feed and the webRTC for each cam (all 3 have there own single card page so when I tap feed it opens full 4k to that), I chose the single card page for webRTC so screen is filled with image. thanks for your work, as soon as we get full native support ill move to just using this superb work that convinced me to buy reolink (they should give you some freebies).

I got myself a RLN8-410 + 4 x B800 but having troubles getting these to HA. The reolink_dev HACS route is being blocked by the “Failed to connect with the camera” error (entered the NVR ip). Has someone been able to get the B800 via NVR to HA and if so which way did you do it?

How did you michaelhdmd add the cameras? more in detail what IP did you use below? The NVR or did you somehow get the camera specific IP’s

image

Hello, I noticed that my cameras are showing as Unavailable today. Not sure if this was because I did a recent update on the integration. Here is the current configuration:

Would you advise changing any of these settings? I am already on h264. Should I be using RTMP or RTSP protocol? What about Main vs Sub stream?

I’m using RLK8-820D4-A NVR system.

Ive got the settings to rtmp as people have reported better stability with the RTMP stream.

The stream should be set to sub and leave the h264 codec.

If you use edge browser or Safari they are able to stream the mainstream at h265.

also if you want thumbnails put in a folder for that, i use /config/www/Reolink make sure to not backup those files or space will fill up too quick.

have you tried for your h265 full stream making single card pages with webRTC as that seems to allow me to view full quality feed, and when I tap each cameras small substream card it jumps to the full webRTC card page for that camera.

Last time I set it up I just put the IP of the NVR along with my credentials and then a second window pops up with details about available cameras. Unfortunately, I can’t seem to get it to work anymore since the recent update. I put in an issue about it: https://github.com/fwestenberg/reolink_dev/issues/294

actually I still have no luck in my case. I am running latest version of the camera firmwares (RLC-810A : v3.0.0.494) ,HA core 2021.9.7 and latest version of the reolink_dev integration. My primary need is to have binay sensor (for person detection) to work. I do see the binay sensors created in lovelace (one for motion, one for person, one for vehicle - per camera) but the are not triggered.

I have the same problem. I tried deleting the cameras and re-adding, but I can’t seem to add any cameras either. I tried reverting to the backup before HA update, but it didn’t help. I’m wondering if it’s a change in the NVR firmware or something?
Have you had any luck?

1 Like