Reolink POE IP Camera Setup

Tags: #<Tag:0x00007f73902ecb78>

I spent the evening setting up my new ReoLink POE IP cameras. As a noobie, I wanted to share what worked for me as of June 2019.

After the cameras were mounted and connected, I had to intialize the cameras in the ReoLink app. I setup login credentials at this time.

BACK END

configuration.yaml

#Enable Cameras
 camera:
    - platform: generic
      name: rear
      still_image_url: !secret Camera_URL
      stream_source: !secret CameraRear_Source 
  
    - platform: generic
      name: side
      still_image_url: !secret Camera_URL
      stream_source: !secret CameraSide_Source 
 
 #Enable stream
 stream:

secrets.yaml

#Cameras
Camera_URL: "http://192.168.0.x/cgi-bin/api.cgi?cmd=Snap&amp;channel=0&amp;rs=wuuPhkmUCeI9WG7C&amp;user=user&amp;password=password"

:point_up_2: Replace username and password with your ReoLink login criteria.

CameraRear_Source:  "rtsp://username:pa[email protected]__:554/h264Preview_01_main"
CameraSide_Source: "rtsp://username:[email protected]__:554/h264Preview_01_main"

:point_up_2: Replace the username & password again. Change the IP for each respective camera.

Thanks to @hunterjm :100: for sharing the camera configurations in his post.

FRONT END

HA > Overview > Configure UI > + > Picture Glance

camera_image: camera.rear
camera_view: live
entities: []
title: Rear
type: picture-glance

OR open the Raw Config Editor

- camera_image: camera.side
        camera_view: live
        entities: []
        title: Side Camera
        type: picture-glance

- camera_image: camera.rear
        camera_view: live
        entities: []
        title: Rear Camera
        type: picture-glance

:arrow_down_small: My Hardware :arrow_down_small:

23 Likes

@candilocks : thanks for writing this recap! it made installing my reolink camera a breeze

Yay! I’m so glad you found it helpful! That’s awesome.

Thanks for posting this. Any ideas on what the difference is between rtmp and the rtsp streams from these cameras?

It seems as though the

rtsp://admin:[email protected]:554//h264Preview_01_main

compared to

rtmp://192.168.2.119/vod/Rec_20160707_040638_411_M.mp4?&channel=0&stream=0&user=admin&password=123456

Hi, just spent my budget on 3 reolink 420’s and this guide will be really helpful.

Do I need to purchase any additional hardware other than the cameras and ethernet cable to get them to work?
I am going to wire them to a switch in my loft but unsure if I need adaptors etc. This is my first time experimenting with cameras

This is my switch
https://www.google.com/url?sa=t&source=web&rct=j&url=https://www.amazon.co.uk/NETGEAR-GS108Ev3-Gigabit-Lifetime-Protection/dp/B00N2JPKEC&ved=2ahUKEwit0rDj27XjAhU0QEEAHXgRCAoQFjAFegQIAxAB&usg=AOvVaw1dAZh9KCeucvCH3vcb9KvD

Thanks

You will need poe adapters as you switch doesn’t support poe, if you can pick up a poe switch in a prime deal it might be worth doing.

Thanks. I just bought this and Amazon agreed to allow a refund/return of my original - what a company!

should be a bit easier than using adapters :+1:

Thanks for sharing!

I just got today a Reolink RLC-410, and I’m trying to get the alerts from the motion detection into Home Assistant… any idea about the URL for it?

Cheers!

1 Like

Thanks for this.

I am confused about the Camera_URL. It seems you use the same URL for all cameras. Is this correct or should I have a different URL for each camera like the RTSP?

I figured it out! Separate URL for each camera. Works great :grinning:

1 Like

Hey,

Thanks very much for the guide - very easy to follow! I have onyl set up 1 camera atm and i am on hassio using a Pi3b+. I plan on setting up 3 more to havr them all PoE to a switch

I am however having issues with the streams actually ‘working’. I cant watch “clear” on my phone as it says there is poor network quality and the streams at default settings wouldn’t play in hassio or on VLC. I have now reduced the settings to the following:

Res: 2304*1296
FPS: 15
Max Bit: 3072
H.264: Baseline

This allows me to play the stream on VLC perfectly without a grey/green screen and no delay. But, home assistant still has a delay of about 10 secs (preload stream enabled). how to fix this?

I would love if someone could shed some light?
Why am I not being able to stream the highest quality? is it really a network issue or a hardware(pi) issue?
My ISP down speed is 20mbps and 6mbps (rubbish i know) up but surely my local LAN speed is way faster and can handle the streams?
Do i only use bandwidth when a stream is being watched or is it continually using up bandwidth? if so why - when is the stream being sent/received (i have microSD in camera for now and no NVR)
if i use a lovelace picture glance card will this take up my bandwidth at all times or just if i click into and watch the stream?

Finally, any luck successfully integrating a 420 into motioneye? i read that you need to reduce resolution but i cant seem to drop mine any lower than 3M.

Sorry for such a post but would love to learn from someone about this stuff

1 Like

I Have the same problem with the same setup.
I can check perfectly on computer (reolink program), stream perfectly on my phone (also in HD).
But on Home assistant + Pi3b+ it just doesn’t load.
I managed to get the integration, but just can’t stream or see anything.
Any sugestion?

Pi3s have trouble with streams above 480p, so you’ll want to setup a 2nd profile in your camera, if possible, for a 640x480 resolution stream, then you’ll be able to stream the video just fine. I do this with my Amcrest camera currently.

@firstof9 @b.maia81

@firstof9 is this documented anywhere? because from what i have researched Pi3 seems to be a excellent kodi machine fully capabale of 1080p streaming?

I have been playing about with the ‘sub’ stream today and @firstof9 conclusions do seem correct though. Very quick to load and no issues with rendering/blue/green/grey screen.

Sorry that was for netflix playback, in Kodi, with the DRM software decoding. Either way the only way I’ve found to get the streaming working properly on a Pi is to use a lower resolution rate tho.

yeah, i have been trying to conclude if its the pi or my 4.5mbps upload rate that it preventing it from working probably - its hard to test 100% the culprit!

My reolink camera doesn’t seem to be able to shoot very low settings. At least I didn’t saw an option like 640x480. Can this dowscale be made in HA? Maybe using an add on like Montioneye?
Or is there any way to go around this? Otherwise to use the cameras, I will have to use my windows PC which is unfortunate, since even my smartphone is able to handle HD fine.

I have mine streaming perfectly fine on a RPi3B+ if I turn down the resolution of the „clear“ stream to 2MP. You can do this in the app or in the web interface of the camera.

@candilocks
what hardware are you running for hass? I am on a pi3 and can only get the sub/low settings stream working reliably. not managed to integrate it with motioneye either

The low quality settings - only difference is the ‘sub’ at the end instead of ‘main’.

try it out and let me know how you get on - more troubleshooting the better.

High Quality

Copy to clipboard

- platform: generic
  still_image_url: "http://192.168.1.x/cgi-bin/api.cgi?cmd=Snap&amp;channel=0&amp;rs=wuuPhkmUCeI9WG7C&amp;user=user&amp;password=password"
  stream_source: "rtsp://user:[email protected]:554/h264Preview_01_main"

Low Quality

Copy to clipboard

- platform: generic
  still_image_url: "http://192.168.1.x/cgi-bin/api.cgi?cmd=Snap&amp;channel=0&amp;rs=wuuPhkmUCeI9WG7C&amp;user=user&amp;password=password"
  stream_source: "rtsp://user:[email protected]:554/h264Preview_01_sub"
2 Likes