[Resolved] Harmony Hub issues after February 2019 update v.4.15.250

Hopefully most of you have seen the latest update information for your hub. My harmony updated by itself to latest 4.15.250 and was not reachable by Hassio. The below steps seemed promising but didn’t work for me. I have deleted the Android App data and cache, reinstalled the app and even restarted my hubs and home network. I am still unable to get Hassio to find my hubs. Please share if you are able to get the below to work for you. Thank you.

Harmony Instructions Link and Text:


Update to accessing Harmony Hub’s local API via XMPP

Hello folks,

I am here with an update regarding Harmony XMPP access.

Back in December 2018, Harmony released a firmware update that addressed several security vulnerabilities - including disabling access to the Hub’s local API via XMPP. After hearing the frustrations from some members of our community, we paused on our firmware update while we assessed the situation. An optional firmware, version 4.15.210, was then created and uploaded onto a MyHarmony tool that allowed for manual installation. This version allowed access to XMPP only for those that wanted it and understood the potential risks of the use of the option. Ultimately we decided to continue this support and make this access available as an opt-in option for firmware versions going forward.

We’re pleased to announce that beginning with firmware version 4.15.250 and Harmony app version 5.6 for iOS and Android, the option to enable XMPP can now be found in the mobile app settings. We plan to roll out this new firmware starting this Friday, February 15, 2019.

Note: See this article on how to check which firmware version you are on - https://support.myharmony.com/how-to-update-your-firmware

By default, Harmony firmware will keep XMPP disabled. For those of you already using the special firmware version 4.15.210 with XMPP access, when your hub upgrades to 4.15.250, you can easily re-enable it by:

• Perform a sync from your LCD screen based Harmony remote, by going to Menu > Settings > Sync Remote, or

• From your Harmony app, go to: Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP

You will not need to use the cumbersome firmware update process as you did in December. If you experience any issues, please let us know. Going forward, future firmware updates will respect your current setting, so this should be a one-time action on your part. Should you encounter any issues, please let us know here.

1 Like

Just received the update, but these steps didn’t work for me. I’m getting lots of errors and cannot connect to the hub… XMPP is enabled (didn’t have to reenable it)

I had performed the steps and went to sleep thinking it would work after my Home Assistant Restart. However, like you, I noticed it didn’t work. I have updated the post accordingly, hopefully someone else can chime in if they got it to work. I have also submitted a comment to the Harmony Community post to see if they can provide guidance. Thanks.

Wait for 88.0 , it fixed the websockets… Xmpp isn’t used anymore, so enabling in harmony app is not needed

1 Like

@ pergola.fabio Do you know when 88.0 is supposed to be released? Is there any workaround I can do meanwhile to get harmony hub to work with my setup? Thank you.

normally today
but as a workaround, just grab the old harmony.py file from an older HA release, then load it as a custom component, then you are using xmpp , the old good days :slight_smile:

Thank you for the information. Sorry I’m somewhat new, how do I load it as a custom component? Just move it to the custom component folder? Do I need to add anything to my configuration file to include the file? Thanks.

look in this thread :

So, either roll you install back to 0.84.3 in HASS OR roll your Harmony back to 4.15.206, so they either both use websockets or both use XMPP.

What I did was to download the 0.84.3 zip file https://github.com/home-assistant/home-assistant/archive/0.84.3.zip and copy the “harmony.py” file from 0.84.3 to my /home/homeassistant/.homeassistant/custom_components/remote/ directory (and restart HASS) so I’m still on 0.84.6 but running the harmony component from 0.84.3.


Thanks a lot. So once 88.0 rolls out, i can remove this file and the new websocket should automatically find my hubs? any config changes required besides having Discovery enabled?

well, ill stay with the xmpp, file, the websocket will work with 88.0 , but it still has issues, like unavaible state after a while …what i heard from developer than i future versions, eventuall HA will use XMPP again … websockets was only a temp solution, a quickfix

so untill XMPP isnt activated in HA, i stick with the custom component , working much better

Thanks a lot for your help, i am up and running again with the custom component and plan on using it until the websocket is stable.

Np have a nice day

@pergola.fabio - I’m running HA 0.87 in Docker. I’v downloaded 0.84.3 zip and located the file harmony.py, but I cannot find any path in docker that matches /home/homeassistant/.homeassistant/custom_components/remote/
So I have no idea where to put the harmony.py file.
Can you help?

have you a config folder? then place it here


the custom_comp… is a folder you need to create in your config dir

@pergola.fabio - that did help a lot, but not completely. HA now no longer complains about not finding the Harmony HUB, so I guess it finally found it. But none of the Harmony commands in my Lovelace i/f works (They all used to work just fine).
Any ideas?
Here my log entries:

2019-02-20 18:20:48 WARNING (MainThread) [homeassistant.loader] You are using a custom component for remote.harmony which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.

2019-02-20 18:21:19 ERROR (MainThread) [homeassistant.components.remote] Error while setting up platform harmony
Traceback (most recent call last):
File “/usr/src/app/homeassistant/helpers/entity_platform.py”, line 128, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=hass.loop)
File “/usr/local/lib/python3.6/asyncio/tasks.py”, line 358, in wait_for
return fut.result()
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/config/custom_components/remote/harmony.py”, line 96, in setup_platform
name, address, port, activity, harmony_conf_file, delay_secs)
File “/config/custom_components/remote/harmony.py”, line 135, in init
import pyharmony
ModuleNotFoundError: No module named ‘pyharmony’

Hmm, no idea it works for me…
Maybe it’s because the developer changed already pyarmony, and not compatible anymore with the older harmony.py component… So I think you need to wait for the websockets version fix, probably released tonight

88 is released :wink:

from rls notes:

This approach is working for me. Initially, only one of two hubs was identified, but after some time, they have both returned to Home Assistant.

Not yet on Docker. Only 0.87.1