Restore home assistant running in docker container

Hi,
I moved home assistant from a docker container running in Portainer to a Raspberry 3B+ but found that the performance is very poor (updates take hours, a simple backup takes 20 minutes), so I decided to migrate back to a docker container. Unfortunately there does not seem to be a restore function in the docker version (I tried 2022.4.7, then 4.6 and 4.5), so I can not take a backup of the raspberry Pi Install and restore that to the docker setup. To be more precise: the three dots on the upper left on the backup page are not there. Am I missing something here or is that on purpose?
I did the same as I did the other way around: Install, go through the initial dialog and then restore the data.

Many regards,
Thomas.

This is what the documentation states, I have never tried this before myself so am interested in your findings
Common Tasks - Operating System - Home Assistant (home-assistant.io)

1 Like

Thanks. The documentation says “follow the link”, however, I tried twice and did not see any link that allowed me to restore a backup. Strange.
What I did not mention before: I even tried making a backup on the new installation, uploading the backup from the other installation, putting it into the backup directory of the new installation and renaming it to the name of the backup I took before. Not even then I can restore the backup. I can even only download and delete any backup I take on a dockerized Home assistant.

LOL (or not really in fact)… tried myself too for 2022 4.3 and 4.6…no link at all
Let’s await one of the more advanced users/dev to comment

Copy the contents, including hidden files, of /config/ from one device to the other.

That is the workaround (or for me normal way of working), yes…but it does not address the backup/how-to-restore issue :slight_smile:

Docker does Not have backup/restore

If you copy/move config and start docker container it will run and be “restored”. To backup docker you can copy/zip contents of /config and verify you got all contents of hidden folder
…. This is docker method basically

Hi…backup has been introduced for docker/containers since 2022.4… is clearly available, works but should also (!) be usable for restore

2022.4: Groups! Groups! Groups! - Home Assistant (home-assistant.io)

Completely forgot

Interestingly, backup is missing from my configuration page. I swear it was there when I first went to 2202.4 :thinking:

EDIT

Had to add “backup” to my config

I got three dots on mobile IOS app. it only allows Download backup and Delete backup. It completely unusable in app since there is some weird aspect thing going on that prevents it from displaying properly. Download option disappears in landscape and only delete remains

In web the three dots only allow delete and backup

Back to the future :slight_smile:
But all jokes aside, the backup works but has to be scheduled separately/manually and the content of the file can be used manually. For me this is not usable unless I have the means to properly restore it or parts of it. I wanted to test this out to see if this is of any use as the text/the documentation sounds promising …but I just donot have the time to go in mode trial/error. I will raise a ticket for now

EDIT: ticket raised: New 2022.4 new feature for backup of a.o. container: no restore seems available · Issue #70840 · home-assistant/core · GitHub

btw, i just browsed through one of the backups and in fact it is indeed nothing more than the /config…I should have analysed this earlier.
In that case I will probably stick with duplicati allowing to include/exclude folders and do partial restore gui-wise. I was hoping on a bit more but…well

Issue was kicked back so I added a feature request now, please vote if you are OK
2022.4 Backup for a.o. container: allow restore as per documentation - Feature Requests - Home Assistant Community (home-assistant.io)

1 Like

Same here. Updating docker from 2022.7.5 to 2022.7.6 didnt work so i did a backup, downloaded it and created a new docker container from scratch. Now theres no way to restore the backup. No restore-button at first welcome, nore in the whole process or later in gui or backup-section. Seems as i have to reconfigure all.

damn…

No you don’t have to reconf… the tar-backup you have contains all /config elements so you can unpack them and copy it there

i tried it today with copy all the file from the /config directory (in my case a volume mount with docker).
But in the end i have to say that homeassistant didn’t accept the files and i have to setup everything on my own. Integrations aren’t setup anymore, user login as well…

Do you have a clue what’s the problem?

File permission issue

Copied files not accessible by new HA.

I have no clue what system you are running on but can’t you just check file permissions and amend? If you can copy/write then I assume you can also tailor these to what HA expects, e.g. check what file permissions are set on the config folder/dir and align them

If you are running a docker container, it will all be owned by root:root.

Maybe, but there are plenty of files and a gui-guided selection would be much better, than copy-paste-all. Especially, if someone (like me) would like to find out, which files create a special behaviour or bug. That’s what i can not find out by copy-paste-all, as i dont know, what each file is used for.

Additionally i am not very used to cli but more a “normal” user with a very little bit of experience in linux / terminal.

as for now i backup everything, in the hope for future ability to use one of them: the TARs created by HA-backup and the full images created by portainer/docker.
:pensive:

I would not see why HA would step into this when many alternatives are available.
Use another backup tool that allows file/directory based backup/restore, e.g. duplicati is great (my view)