Restored image back to new ProxMox 8.02 Hypervisor MQTT broker stopped working

As above - if ever i rebuild proxmox (v7) i back up the home assistant image and then restore back to the new installation which has always worked fine. Thought id move up to ProxMox 8 today and while the image has restored the Zigbee2MQTT broker is giving error 504: Bad Gateway - ive been on it for a few hours and not managed to get it working yet…wondered if anyone else has seen this.???

Cheers to anyone that takes a punt.

Where do you see this error?

Are you running haos inside proxmox?

Are you running z2m and mqtt as addons?

Hi there. First and foremost im not great at this…! ive got Home Assistant running now on Proxmox8. I see the error when i click on the Zigbee2MQTT down on the left hand side. So, somethings changed from going to ProxMox8. Not sure what you mean by “Are you running z2m and mqtt as addons?” while messing around yesterday i did buy some time ago a Sonoff usb plus dongle (ive just updated the firmware on it) and thought if i went through the setup from scratch with a newer dongle with the latest firmware i might be able to get it working again?

Looking at the logs i get this error when i try to start…

Error: Reset error: Error: {“sequence”:-1} after 10000ms
at /app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/uart.ts:299:23
at Queue.executeNext (/app/node_modules/zigbee-herdsman/src/utils/queue.ts:32:32)

Thanks for the reply as ive no idea how to get it working again…i kinda got it working about 9 months ago and have left it alone since so its like learning all over again!

I am unsure, but it looks like the usb device is not being passed through to the HA VM.

Take a look here and there are details on usb passthrough here

Hi - not sure any of that applies to me…as ive build the proxmox from scratch (so not an upgrade) - plus i can see the usb device in prox mox that is (or should i say) has been passed through…i can see it in HA and the Conbee thats already installed is working fine. Im guessing some sort of config issue…?

I don’t think you can have conbee an z2m on the same device.

Yep - theyve been running together since i set it up…it did work really well! :slight_smile:

Sorry I was talking nonsense.

Heh - dont worry about it…im a total novice on this…ive managed to get it running, pair devices and use the timers…thats about it…im pretty lost after that…i have asked how to do stuff but people that try to help jump off the deep end straight away and im lost! ( i know nothing about coding,yaml etc etc) - i can just about do stuff in the gui (even thats confusing!)

Just to update this (still not found a fix) - i went through the walk through again but still get the same error…

[11:13:15] INFO: Preparing to start…
[11:13:15] INFO: Socat not enabled
[11:13:15] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:info 2023-06-29 11:13:17: Logging to console and directory: ‘/config/zigbee2mqtt/log/2023-06-29.11-13-17’ filename: log.txt
Zigbee2MQTT:info 2023-06-29 11:13:17: Starting Zigbee2MQTT version 1.31.2 (commit #unknown)
Zigbee2MQTT:info 2023-06-29 11:13:17: Starting zigbee-herdsman (0.14.117)
Error: Reset error: Error: {“sequence”:-1} after 10000ms
at /app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/uart.ts:299:23
at Queue.executeNext (/app/node_modules/zigbee-herdsman/src/utils/queue.ts:32:32)

googled for it but cant find anything exact to the above issue…

That error looks like it is unable to talk to the USB device. Perhaps the USB path is different on the new system or permissions are not setup for the VM to access it?

Its definately there…its recognized in the passthrough and, in the terminal it can be seen on /dev/ttyUSB0 (in the Home assistant terminal)

Just an idea: check the permissions so that your HA can write to the device.

ok- not sure where i find that (the permissions)?

ls -l

Is the linux command to see permissions.

Ok - thanks…that just shows a list…im not really sure what to do with that?

I will explain it in a simplified way for you: it’s a command to show the files in a/the current directory in detail with it’s permissions.
The device (/dev/ttyUSB0) is seen as a file.
With a zigbee USB adapter, there is information written to the device, hence you need write permissions.

Can I ask you something?

  • have you ever used Linux before
  • what is the reason to use Proxmox

yes used linux before but not very much…over the years ive found that whatever youve learnt on one flavour is totally different on the next…

I use proxmox as i also use PiHole plus i also use a windows 11 vm for remote access which is used all of the time…(im on it now) all of the above runs from a little optiplex 3050 which draws no more than 10 - 15w at idle, with room to run more if i need to…seems a bit pointless running 2 pi’s and a desktop all at the same time. Finally i like to run ProxMox because i like to learn, its a good and reasonably intuative HyperVisor that i can get on with and also i can run up VM’s and just mess around with them.

Thanks for explaining - thats all it needed…assuming it works for me of course which invariably it rarely does.

As i suspected my command of “chmod 777 ttyUSB0” didnt work and came back with a usage list - so not the same as id last used…

Just to join in here…
Another good reason for using Proxmox is that, last time I looked, there weren’t any very simple official instructions for running HAos on bare-metal x86. Unless that’s changed?
And I like the fact that I can snapshot the VM every few nights and dump the snapshot onto my Synology.

So you have a Conbee working (which means that USB passthrough is basically fine) – I do the same with my Conbee under Proxmox 7 - I’m using ZHA. But then Zigbee2MQTT doesn’t recognise your second adapter, is that right? (I’ll try not to get distracted by wondering why you need two Zigbee adapters, especially when one of them is a Conbee!)

On mine, if I go into the VM’s console within Proxmox, I’m put into the HA console ‘ha’ utility… which isn’t the standard linux console. (You probably know this!)
But if I ssh into the actual HA VM itself, not the host machine, I can see my (one) USB adapter as /dev/ttyUSB0. Presumably your pass-through, if working, should show you something like a /dev/ttyUSB1 as well?