RFLink over WiFi best options

I just got a Nodo Shop RFLink board as well as their WiFi adapter to make it work wirelessly (the place I have my HA server is not a good place for the RFLink, so USB isn’t an option). I am trying to figure out the best firmware to install on the wifi adapter, and best way to configure it in HA.

It looks like the RFLink folks suggest ESPEasy, and offer instructions for that, but only for Domoticz integration. The HA page about the RFLink component suggests esp-link. I think I also saw somewhere that people have gotten Tasmota to work for this.

So, which firmware do you folks use? How do you configure it? Any way to get it to work with HA autodiscovery (not for the RFLink bridge itself, but for the 433MHz sensors)?

Advice much appreciated.

I’m looking into this as well, haven’t used it yet but I found this which might be a good sollution;

Yeah, I ran across that, and it’s one approach. But as I understand it, this pushes the whole thing to MQTT. I was hoping to use the HA RFlink component, which needs a serial-over-IP link.

No real reason for this - the MQTT approach may work perfectly well… My biggest issue is sensor discovery. I really don’t want to have to individually configure each sensor, as I plan to have a bunch. I’ll have to see what works the best.

@Juliean_Galak could you please share if you got this to work - and how?

I have just bought the same setup and am battling with ESPEasy so am hoping you figured out how to make it work!

Thanks.

OK, I managed to get it sorted using ESPEasy - the problem was that the Arduino Mega I was using was not delivering 3.3V to the NodeMCU. Swapped it out and now have a link and can try to programme my Somfy blinds!

I did get it to work, but because of the specific sensors I had bought the whole thing was so frustrating that I gave up and got a Sonoff RF Bridge. Not nearly as capable, but was much easier to get to work. May go back and poke at the RFLink eventually.

Thank you for your reply, @Juliean_Galak Once I replaced my Arduino Mega for one that provides 3V3 I can get it to link to HASS but I still can’t get HASS to drive the blinds attached / issue the right code.

I continue to work with it!

@Juliean_Galak did you happen to document the NodeMCU settings you used? I’m becoming convinced that this is where my problem lies - but can’t figure out where!

I managed to get it sorted - not entirely sure how but it is working. Thanks for your help!

I hope you can point me in the right direction, I’m unable to configure Home Assistant with my RFLink and EspEasy. Everything seems to be working, but the sensors and switches do not appear in Home Assistant.
This is how EspEasy is set up and what’s showing in RFLink uploader:

Configuration.yaml:

#RFLink
rflink:
  host: 192.168.88.164
  port: 8989
  wait_for_ack: true

#RFlink sensors
  - platform: rflink
    automatic_add: false
    devices:
      02a4_temp:
        name: Outside Temperature
        sensor_type: temperature
      02a4_hum:
        name: Outside Humidity
        sensor_type: humidity
      02a4_bat:
        name: Outside Sensor Battery
        sensor_type: battery

I have also tried with bl999_02a4_temp, …
I have also tried auto_discovery with automatic_add: true.

EspEasy seems to be getting the data from RFLink as the log shows:
31802881: WD : Uptime 530 ConnectFailures 0 FreeMem 20568 WiFiStatus 3
31814960: EVENT: !RFLink#
31814971: EVENT: !RFLink#adioFrequencyLink - RFLink Gateway V1.1 - R48;
31820525: EVENT: !RFLink#
31820533: EVENT: !RFLink#RadioFrequencyLink - RFLink Gateway V1.1 -
31820541: EVENT: !RFLink#
31824053: EVENT: !RFLink#
31824061: EVENT: !RFLink#S;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;
31824069: EVENT: !RFLink#ingColors=OFF;setAnsluta=OFF;setGPIO=OFF;
31824079: EVENT: !RFLink#=OFF;setMysensors=OFF;
31864652: EVENT: !RFLink#
31864660: EVENT: !RFLink#ID=41;SWITCH=1;CMD=ON;
32321956: EVENT: !RFLink#
32321964: EVENT: !RFLink#ID=02a4;TEMP=0084;HUM=74;BAT=OK;

Home assistant log shows Rflink to be connected:
2019-10-24 08:38:17 INFO (MainThread) [homeassistant.components.rflink] Initiating Rflink connection
2019-10-24 08:38:22 INFO (MainThread) [homeassistant.components.rflink] Connected to Rflink

But still, no data is displayed in Home assistant, the sensors show “Unknown”.

Any ideas, where it went astray?
Thanks.

It looks OK. According to this thread the setting are right :

For the moment I’m using this :

You can always try another port.

Thanks, that’s exactly the link I used to figure out the setup (the only difference is my ESP-01 is separate, not embedded on the MEGA. That’s why I don’t understand why it’s not working. It seems that the data does not get through from EspEasy to HASS. There is nothing in the HASS log, except that it got connected to RfLink.
espRFLinkMQTT is working, but I was hoping I could get stuff autoconfigured with the direct setup, and maybe it consumes less resources than MQTT.

If you use espeasy, if HA connects you should see an entry here :disappointed_relieved:

A message like ser2net connected. If not, you probably have to try another port.

Thanks. I tried different ports, none seemed to work. I checked with Packet sniffer on my router, it seems that no packet was sent out on those ports by EspEasy.
Solved it finally using Esp-link, which connected without a problem.
Thanks for the help.

Hi, I use my rflink with MQTT gateway on ESP since 1 year without any problems:

Very good projet, just work!
I have Two rflink one 433,92 Mhz and an other for Somfy RTS 433,42 Mhz