RFXcom support for Fan controls

RFXcom fixed the support for the Novy hood remote. However, we cannot add this to Home Assistant as it is a fan, not a switch. Please add the buttons for such a remote either as a switch or some other entity so we can control the hood from within Home Assistant.


I second this request! I’d love to get my Hunter fans into Home Assistant, but I’m out of luck at the moment. Cheers!

I also subscribe, also because I need to control a novy kitchen hood!

yes please, add a fan control

Yes here also needed fan support for my Novy hood

Support would be nice :slight_smile:

Would any of you be interested in a custom integration for this? I’m investigating if I can’t convert my appdaemon app into a custom component.

Not sure if it would play nice with the official RFXcom integration though, and for sure it won’t include receiving commands from the original remote.


1 Like

I was looking for a way to integrate this Novy hood into my HA installation too, didn’t flash the PRO2 firmware up until now. Unfortunately this isn’t possible. So, yes please @thomas-be , if it is only possible with a custom integration.

Sorry, haven’t had much time to tinker with HA in recent months. Hope this gets better soon so I can help you all out with this.

In the mean time, what you need to do on the most basic level is send some serial commands to the RFXcom device. What worked for me is (in hex notation):
Up button: b'\x08\x17\x0B\x01\x00\x00\x02\x02\x00'
Down button: b'\x08\x17\x0B\x01\x00\x00\x02\x03\x00'

You could maybe send these through node-red.

That basically is all there is to it; switching on/off also is possible by sending up/down commands. That works better than using the on/off toggle button as you have no way of knowing (in HA) if the hood is on or off.


1 Like

Hi Thomas,

I Have it working - sort of - like in the post where Harrie de Groot did it nicely!

I have the Novy-Hood, I can control it with RFXcom through Node-Red with your help in the other forum.

But I am not able to get the buttons work in HA correctly, Mostly I have the problem for example the light turns on/off/on/off/on/off in my node-red flow :slight_smile: So I am doing something stupid I guess…

The use with a Fibaro Powermeter works great!

With the new version of HA, the rfxtrx integration now also has a service to send custom codes: RFXCOM RFXtrx - Home Assistant

Have not tested it yet; but I assume you could use this to automate the Novy hood instead of the Appdaemon app I made.

For those who are still interested: I created an easy way to control the Novy hood wich you can set up from the frontend. What you need:

The blueprint controls the fan with the up/down commands, so the state of the hood is “assumed” as there is no feedback. Following functions are supported:

  • You can set the fan with the numeric input:
    0 = off
    1-3 = normal speeds
    4 = boost
  • An automatic timer to set boost back to max speed. You must set this timer (slightly) shorter than the internal timer of the hood to keep things in sync.
  • An automatic timer for the auto-off of the hood. Again, set this shorter than the hood’s own timer to keep everything in sync.
  • When switching off the hood, 2 supplemental “down” commands are given. So in case things get out of sync, switching it off (multiple times) will get it synchronized again.


  • You can no longer use the hood’s own remote as this will get things out of sync.
  • When you switch of the hood, the speed is “forgotten”.
  • As this is not a “fan” entity, there is no support for Google home or Alexa. This may be resolved by adding a template fan entity, but I have not (yet) tested that myself.

EDIT: I created a template fan to go with this blueprint! This is more advanced as it does require editing the configuration file, but it does turn your hood into a full-blown fan entity in HA.



But this Would then also be possible with current measurement I Guess ? :slight_smile:

Sure, should be possible. But I don’t have this and for me it is not needed. I just replaced the original Novy remote with a Tradfri remote which controls the hood and the lighting. Works very well.

Outside of my experiments, I have never seen the hood “get out of sync” with what is indicated by HA, so I don’t see the need to get the “real” feedback from the current measurement.

When trying to import the blueprint i’m getting an ‘unsupported url’ error message and it doens’t show the blueprint. Any thoughts how to fix this?

// I was able to add it manually by creating a new folder in my blueprints folder. Now just getting to know why my RFXcom doesn’t work anymore.

The correct address of the blueprint is:

Could you add the codes that turn the Hood on and off as an extra variables in the blueprint?
For me these codes work:
Off: 08170B000000000100
On: 08170B090000000100
Up: 08170B0C0000000200
Down: 08170B0D0000000300

Also… It seems possible (see GitHub - harriedegroot/nl.novy.intouch: Athom Homey: Novy Intouch Driver V2. ) to send codes that directly get the right speed (1, 2,3, 4). Could that be added too?

If i find the time, I might take a look. However, a few remarks:

  • I don’t use the off/on. As you can see, these are identical codes which does not allow me to bring the hood in a pre-determined state. To switch on, I just increase the speed. To switch off I decrease the speed to what I think is the lowest and then an extra step. The extra step is in case the hood got out of sync.
  • Directly setting the right speed could be added, but it does not add any functionality. I can set the speeds just fine using the current blueprint.

I may still add the commands for the speeds because that would avoid having to use the numeric helper, but other than that there is no immediate advantage I can see.

Thanks for the reply! And thanks for the work in this, Much appreciated!
In my situation, the code for ON (08170B090000000100) is not the same as OFF ( 08170B000000000100), hence the question.
Also…I have the hood react to the number of plates and power that is used in my Miele CookTop. If the power of one of the plates is set to max, the hood automatically switches to MAX. It goes back based on the power that is used in the cooktop.
If the cooktop is switched off, the hood switches off 5 minutes after.
(I am using a Homey, which receives Webhooks (and acts upon that) sent by a REST command in HA)

thanks, this one works indeed. I already created it manually so I was actively using your bp, tnx!