RFXtrx with T6 blinds cover configuration


#1

so my first of many searches about this problem led me to the below thread, which was the first part of some success, i did find i had to chmod 777 my usb device to get rid of the config error message that persisted to keep coming up,

anyway based on the above thread i thought, right sweet, i’ll take my info, sub it into the fields and we are good to go, (everything worked find from a windows box while i was programming the blinds), they are DV24-CE motors with DC1602 remotes.

i had partial / not complete success

so i have set up my id’s from 15,14,13,12,11,10,9 and 0 is all blinds

if i set the following cover

#RFXTRX module enable

rfxtrx:
device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A12D8TKP-if00-port0
debug: true

cover:

  • platform: rfxtrx
    devices:
    0919060300001FF00000: # RFY
    name: All Blinds

which from the other referenced thread
09190603[id][unit_code][cmd]00
my unit code (00001FF)
cmd of open which is 00 (not thtat it matters as the cover seems to be able to sort this out and gives me up down and stop regardless of what i insert here)
and 00 at the end

data from RFXtrx
Blinds command

Packettype = BLINDS1
subtype = DC106
Sequence nbr = 67
id1-4 = 00001FF decimal:511
Unit = 0
Command = Open

so the problem i am facing is that obviously i want to add all the blinds, so after the success of the all blinds cover working, i went on and added blind unit 15, Nope, broke it, config error, even though the config checker says it was ok

cover:

  • platform: rfxtrx
    devices:
    0919060300001FF150000: # RFY
    name: Playroom Side

then i tried dropping a 0, then another, etc etc, rebooting each time to see if it would work, no deal, the best i can get is making it show up as a single cover, but the action buttons give no function.

and so far i have tried enough that it seems this command can not handle double digit’s for the unit number, and i guess tomorrow i could run around and re-program all the blinds for numbers 1-7 and from all the testing i’ve done so far it will probably " just work "

i did confirm just previous to posting this that the cover for blind 9, works fine

cover:

  • platform: rfxtrx
    devices:
    0919060300001FF90000: # RFY
    name: Theatre Rear

i am new to this, and the blinds were the primary reason for giving this whole situation a go, please let me know if i need to provide more information, i’ve been searching pretty hard for a solution, and the best i can figure myself is reprogramming blinds, but if it can be sorted another way that would be great


#2

so i ended up solving this by re-pairing all of my blinds with new codes, i think the documention should be updated to reflect that multi digit unit id’s just dont work for this type of blind situation, i still have NFI what 09190603 vs 071a0000 in the main RFXtrx docco even means?

anyway provided that you maintain a single digit unit ID while you are pairing your devices it all works fine, and also it does not matter if you use 00- 01-02 as a command byte, HA seems to deal with it regardless of what you insert there

so my config ends up

cover:

  • platform: rfxtrx
    devices:
    0919060300001FF00000: # RFY
    name: All Blinds
    091906031122DDC10000: # RFY
    name: Play Room Side
    091906031122DDC20000: # RFY
    name: Play Room Front
    091906031122DDC30000: # RFY
    name: Play Room Center

etc etc,

i still need to sudo chmod 777 /dev/ttyUSB0 or sudo chmod 777 /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A12D8TKP-if00-port0 each time i disconnect the device to pair things on my windows pc

i have this running on a RPI raspbian stretch, latest, i did try hass.io and gave up when even the basic bom weather information wouldnt work, then due to being relatively familar with linux CLI i got tired tring to deal with and find the full usb path to configure rfxtrx in the first place, which worked first time after setting up in the pythyon virtial env on rasbian. i pasted the exact same config i was using previously with bom weather, and some snmp data from a hwg-ste temp sensor i have on the network, and it worked first time. (the temp sensor was the only thing i had working on hass.io)

happy it works, but it would be nice if someone could explain why it works like this, as i said i am new to this, now i need to figure out a way of making it look a bit more appealing on the home page, other than a mega list under the heading cover.