Ring camera Lovelace Card

Has anyone gotten the Ring Doorbell camera on a card in lovelace?

I’ve tried picture entity and a few other things but haven’t gotten it to work yet. I did some searching around and can’t find anything about it working or not.

Yep. I’m using a picture-glance card.

          type: picture-glance
          title: Front Door
            - binary_sensor.ring_front_door_motion
            - binary_sensor.ring_front_door_ding
          camera_image: camera.front_door

You sir are awesome!

Only thing I hadn’t done was add the entities: binary_sensor. Guess that was enough for it to not like it.

No worries, glad to help. :slight_smile:

Also appreciated!

Do you know how I can get it to display live image on my dasboard instead its showing last recording?

As it stands, Ring doesn’t provide live recordings, so this is impossible. I’d like to be able to use the new Camera Previews, but I don’t know how to do that and if it’s possible.

how did you get ring to present itself as camera.front_door? I don’t see any camera.xxx for ring at all?

I used the ring camera component. https://www.home-assistant.io/components/camera.ring/

Doh, got it working now, thanks!

I tried to set up my ring doorbell as in your example but I get an error on the ffmpeg:
Error starting FFMPEG
FFMPEG fails all args must be str or bytes.

In my configuration.yaml
I set up ffmpeg without any parameters like in the documentation.
I just have:


The interesting thing is that the very first time I started it, it worked, I was able to see the last recorded video from the doorbell.
After that I started to have those error messages
Anybody has an idea what could be wrong?

I’m in the same boat, however I have not gotten mine to ever show an image


This is all I have ever gotten. Still poking away at it though.

Yep. I get that every so often. Seems to happen when a new video is uploaded to the ring servers and not yet ready to download, or still being downloaded. This is just my assumption so I could be totally wrong.


Can you paste the part of your configuration.yaml file that has to to with the ring doorbell? Then maybe I can offer some help?
Not in any way a expert at this, but I started 2 weeks ago with my raspberry, and actually the ring doorbell and chime was something of the first I got to work. Gotten lots of help in the forums here, so if I can give back by helping others I would love to try! :slight_smile:

I’m also after the camera previews. Would be nice if we can set the interval, for example get a new preview every 30 seconds etc

From how I have understood this. The Ring component pulls its data from the Ring.com webpage so I dont think any update_interval in configuration.yaml side will do anything sadly. The previews are coded on Ring.com side.

Any help would be appreciated! Here is what i have at the moment.


  username: !secret ring_user
  password: !secret ring_pass


  - platform: ring
    ffmpeg_arguments: -pred 1 -q:v 2


- platform: ring
    - battery
    - last_activity
    - last_ding
    - last_motion
    - volume

Just to be sure. the username and password you have linked to in username: !secret ring_user
password: !secret ring_pass, have you checked to see if you can log in to ring.com webpage?

I have a little different setup than you do but still here is how I have set it up, and it works here on my side. In configuration.yaml

under sensors:

  - platform: ring
    scan_interval: 60

username: !secret ruser
password: !secret rpass

      - platform: ring
        scan_interval: 60

      - platform: ring

and this is how it looks
I just set up the top card as a simple glance card, then the picture on the bottom is a regular picture-glance.

Hope this helps
Kind regards

Yeah, this is how I started off thinking it seemed that easy to set up. When it didn’t work I then went to the ffmpeg route after doing some research.

Credentials haven’t changed and I can log in just fine to the web.

Interesting…so I left out the binary_sensor portion (purposely) because I didn’t think I needed the information it provided but just for kicks I added it and now I’m seeing video. I don’t understand how that would cause it but for anyone else out there with a similar issue, make sure to have all components added (I guess?).

1 Like

Yeah, I seem to remember the same, I also had problems getting this to work until I set the binary sensor.
Glad you got it up and running, here is a screenshot of how mine looks.

Sorry about the full white preview picture on my camera… but thats the northern arctic for ya, snow… snow… and more snow :stuck_out_tongue: