Ring integration setup fails

Just updated mine to 103.2 and seeing the same issue, inegration broken.

Does anyone know where the source of this sits within HA?

Glad Im using https://github.com/tsightler/ring-alarm-mqtt as it still works properly.

Also HomeBridge-Ring is working properly https://www.npmjs.com/package/homebridge-ring
Although homebridge-ring allows you to use a 2FA Token :slight_smile:

Both of these are based on the Unofficial Ring API

which is constantly updated…

I believe a lot of people are seeing their integrations still work. However they will likely run into the problem if/when they need to refresh their tokens.
This is based on my gut and not on any real knowledge of how the integrations work. For those that have working integrations, I still say “Avoid rebooting or reconfiguration at all costs”.

I agree. Don’t restart Home Assistant until a fix is available if you can avoid it.

The good news is that progress has been made on a fix.


Can confirm. I rebooted and it broke. I tried a bunch of stuff before finding this here.

Yeah I can confirm that before the reboot, the camera worked, but the motion detection stopped. And I know cause I had earlier setup a automation to get Alexa to announce Welcome Home for each Family member i set the trigger as the front door but tied it to two conditions, presence change and motion from the ring camera. And it worked before I left, 4 hours later when I came home with the family waiting to see their reaction and nothing, checked the log and ring motion failed, camera feed was fine as was everything else reboot and now all gone. Has nothing to do with to do with HA or any update. Now I have to change it to motion from the reolink cam instead.
Don’t you just love IOT. :frowning:

Originally I had 2FA turned on, it wouldn’t work with the standard ring HA integration. Turned it off and it started working up until yesterday. I had to reboot the server and now it has stopped and I am getting the error as above. @benjimatt I am not familiar with the HomeBridge setup, but can that be integrated into HA as a workaround for this current issue?


I have just joined the club, i.e., I am facing exactly the same problem. :frowning: First I thought the problem is related to some recent changes in my configuration.yaml, but it isn’t. Later I stumbled over this thread. For the record, “Two Factor Authentication” is disabled in my account settings, but the problem still persists. I am running 0.103.0.

Kind regards!

+1 to the not working for me either.

I contacted Ring Support earlier to be told that “Home Assistant isn’t something that we partner with” and as a result I needed to “Reach out to the people who develop home assistant” I told them that I need HA more than their Doorbells, and plenty of their “neighbors” are experiencing the same problem.

I have automation’s that integrate the motion sensors and notify me of the battery level. I appreciate the efforts of the extremely clever folks who write the Home Assistant integrations and if they can find a resolution.


1 Like

Well i got it back!

Screenshot_20191220-103135_Fully Kiosk Browser|243x500

1 Like

@Harry13 What did you do to get it back?

Boo, I’m also joining the club. Just upgraded Hass.io to 103.2. Hopefully a simple fix is on it’s way otherwise I’ll have to setup homebridge again.

What did you do to get it working again?

download the changes made 14e4bf841a
extract and save the ring_doorbell in your config or where ever you like the hassio share
use potainer
or cli if your better than me which is most likely
open exe console on homeassistant container
use the copy file with recursive switch
cp -r SOURCEFolder DESTfolder

DESTfolder will be

link below to changes

I have it working now, followed the info here:

Added as a custom component with the modified manifest.json file and all is well.

Now its all back running, sensors are fine and last stored clip also works.

I did the same though mine still has the ‘client error, forbidden…’

thanks mate.

This worked a treat. Downloaded a zip file that someone put together (link below), dropped the contents into my custom components folder, and restarted HA. All up and running again.



Not sure if this is the best way though I’ve managed to get it working by unzipping


& copying the contents of ring_doorbell to /srv/homeassistant/lib/python3.6/site-packages/ring_doorbell then removing the ring directory in custom_components & restarting HA

1 Like

I don’t know if anyone else has a similar problem, but whilst its all working I cannot get the “Check Config” to work. I have the Binary Sensor, Sensors and camera components configured from Ring, the cameras component on its own Check Config works fine. However once I add the sensor(s) then it never seems to be able to finish the check. I left it around 20 minutes got bored and restarted anyway.

Everything works fine, I just wondered if anyone else is getting the similar situation?

Do what @jaraeez and I did
Its simple
Forget the custom component

Seems to be working fine for me. Take about twice as long, but it finishes. I also have the following line pop up in my logs.

2019-12-20 14:00:45 INFO (SyncWorker_3) [homeassistant.util.package] Attempting install of https://github.com/xernaj/python-ring-doorbell/archive/fix/oauth-fail-due-to-blocked-user-agent.zip#ring_doorbell==0.2.4