Ring live view

You don’t need a ring protection plan to use this addon (which is based on the Homebridge plugin).

This addon is not that useful at the moment I think given it’s limitations (i.e. having to start and stop the addon each time you want to view the camera).

Thank you. Thank you,
ok, so that’s why the addon deactivates itself? maybe an automation is possible?

You can use the hassio.addon_start service

Ok, thanks for your answer, I tried to create a sensor and a swicth like in the addon example but something doesn’t work, could you please show me your code?
Thank you in advance.

I have had to redirect port 3000 on my router to the IP of my ha, have you tried that?

No, I’m in 8123.
how do you redirect the port, i use tenda nova. for the addon i point to lip of my ha:3000 it works but randomly. for the sensor and switch it doesn’t work.

It depends on your router, each one is different, but basically it is to do NAT from port 3000 on your router to the ip of ha. I don’t use the sensor or the switch, I just start the addon when they ring the bell to see the camera and 5 minutes later I stop the addon

Does it show a feed I’m homekit like Homebridge?

All right, I’ll take a look at this. Thank you.

1 Like

I cannot add the repo to my HACS running on 0.112.4: Jottacloud

Anyone else with the same problem?

EDIT: Understood now that this isnt a HACS addon.

1 Like

This may be a stupid question
Where does the ring_refresh_token: xxxx go in configuration.yaml?

Quick clarification since you seem to have the Ring streaming working for you. Did you use the URL
stream_source: http://hassio.local:port/public/stream.m3u8

to access the stream? OR something like
stream_source: http://YOUR_IP_ADDRESS:PICK_A_PORT/public/stream.m3u8 ?


1 Like

@samceccola Guess that makes two of us :grinning: :+1:

It goes in the Configuration tab of the Add In. Still don’t see anything working though.

1 Like

Yes, it goes under Config tab under Add-on and the same tab also says that port selected (default 3000) also needs to be open on the router. I have reservations about opening ports on the router so did not try it further.

Thanks for the clarifications.

You need to expose the stream as a generic camera entity in HA.

      name: Ring Livestream
      stream_source: http://192.168.XX.XX:3000/public/stream.m3u8

Sorry if this is somewhat off topic… I believe it was after 115 was released HomeKit now says these devices are not responding. Could have also happened after iOS 14 was released. Preview works fine though. But for whatever reason when a scene is triggered with Siri, it always says “some devices are not responding” even though the cameras are not part of the scene. It’s a bit annoying.

Any help?

Can anyone confirm if this addon is working with latest HA version (116.4). I see some posts at the github page about it not working, but unsure if its the addon or user error.

I did create a refresh token via homebrige. I have not opened a port on my router just yet as only working within the Lan.

Sorry if this is a dumb question. I’m running Home Assistant 0.116.4 under Docker. How do I add this?

1 Like

I finally got this working for one camera but I’m not sure what needs to be done to support multiple cameras. I have a ring doorbell at the front door and back door. Right now it seems to only connect to the back door camera.