Ring live view

Hi, do you know how to set up this repo on HACS? I didn’t make it.
Thanks to you.
ring-hassio

I am interested in this too, is it necessary to be a home bridge owner?

Wow, Didn’t know this existed!

Just tried it and it works. You just need to add the repo (i.e. https://github.com/jeroenterheerdt/ring-hassio) in your Add On Store (Configuration -> Addon Store -> Click on the 3 dots ( topright hand corner) and add the repository.
Then you install the addon and setup the addon config and camera config.
Does’t appear to be a still image for the camera entity as mentioned in the Addon documentation.
But the livestream works.

I didn’t have to forward a port on the router.

I can’t get the token, it gives me an error. do you have homebridge?

Yes, I used a token I already had setup in homebridge.

Do you pay for an activated ring protect plan?

I have already managed to create the token, I have added the camera in ha but it does not load any image or anything
I’m not sure if it is necessary to pay for a ring protect plan, can someone confirm it?

Wow, thanks. I thought that was in hacs for the installation. Do you know how to make the token?.

Hey, how’d you make the token?

could you show us your configuration please, at my place also the picture doesn’t show up.
Thanks

I setup the ring homebridge plugin awhile back and used their documentation to obtain a token (https://github.com/dgreif/ring/wiki/Refresh-Tokens).

You don’t need a ring protection plan to use this addon (which is based on the Homebridge plugin).

This addon is not that useful at the moment I think given it’s limitations (i.e. having to start and stop the addon each time you want to view the camera).

Thank you. Thank you,
ok, so that’s why the addon deactivates itself? maybe an automation is possible?

You can use the hassio.addon_start service

Ok, thanks for your answer, I tried to create a sensor and a swicth like in the addon example but something doesn’t work, could you please show me your code?
Thank you in advance.

I have had to redirect port 3000 on my router to the IP of my ha, have you tried that?

No, I’m in 8123.
how do you redirect the port, i use tenda nova. for the addon i point to lip of my ha:3000 it works but randomly. for the sensor and switch it doesn’t work.

It depends on your router, each one is different, but basically it is to do NAT from port 3000 on your router to the ip of ha. I don’t use the sensor or the switch, I just start the addon when they ring the bell to see the camera and 5 minutes later I stop the addon

Does it show a feed I’m homekit like Homebridge?

All right, I’ll take a look at this. Thank you.

I cannot add the repo to my HACS running on 0.112.4: https://www.jottacloud.com/s/0067b90cb493d294c4fa9bb97998211c0cd

Anyone else with the same problem?

EDIT: Understood now that this isnt a HACS addon.