Ring live view

This may be a stupid question
Where does the ring_refresh_token: xxxx go in configuration.yaml?

Quick clarification since you seem to have the Ring streaming working for you. Did you use the URL
stream_source: http://hassio.local:port/public/stream.m3u8

to access the stream? OR something like
stream_source: http://YOUR_IP_ADDRESS:PICK_A_PORT/public/stream.m3u8 ?


1 Like

@samceccola Guess that makes two of us :grinning: :+1:

It goes in the Configuration tab of the Add In. Still don’t see anything working though.

1 Like

Yes, it goes under Config tab under Add-on and the same tab also says that port selected (default 3000) also needs to be open on the router. I have reservations about opening ports on the router so did not try it further.

Thanks for the clarifications.

You need to expose the stream as a generic camera entity in HA.

      name: Ring Livestream
      stream_source: http://192.168.XX.XX:3000/public/stream.m3u8

Sorry if this is somewhat off topic… I believe it was after 115 was released HomeKit now says these devices are not responding. Could have also happened after iOS 14 was released. Preview works fine though. But for whatever reason when a scene is triggered with Siri, it always says “some devices are not responding” even though the cameras are not part of the scene. It’s a bit annoying.

Any help?

Can anyone confirm if this addon is working with latest HA version (116.4). I see some posts at the github page about it not working, but unsure if its the addon or user error.

I did create a refresh token via homebrige. I have not opened a port on my router just yet as only working within the Lan.

Sorry if this is a dumb question. I’m running Home Assistant 0.116.4 under Docker. How do I add this?

1 Like

I finally got this working for one camera but I’m not sure what needs to be done to support multiple cameras. I have a ring doorbell at the front door and back door. Right now it seems to only connect to the back door camera.

You’d need to make 2 camera entries.

So for example:


Hello, I have noticed that when I turn on the addon, the ring doorbell device does not communicate when someone presses the doorbell, I mean that at the HA level and in the ring app there is no notification of any kind until a few minutes have passed.
Does anyone else have this problem?Greetings and sorry for my english, the google translator is helping me.

I note that this addon states

DOT NOT run this add-on with 24-hour streaming - use this addon by starting it on-demand

Is this only due to the battery consumption.

I run my ring doorbell with a power adapter so battery consumption is is not an issue.

Dose starting this service start the ring service an is likely to cause me an issue with my account,

Right, if you have the plug-in on your ring device will not work properly

Update for my off-topic issue. Either 118 or 118.3 fixed it.

Hello. I’m a few weeks in to HA. However, I believe I have everything set up correctly as I’m able to view the livestream of my camera in VLC at http://ip.add.re.ss:port/public/stream.m3u8 with no issues. I was also able to add the card to HA, but the problem i’m running in to is that the video is live for about 5 seconds and then buffers indefinitely.

I’m running HA OS 5.8 and version 2020.12.6

Can someone please share the sensor config section of this addon.

I have the addon setup and it streams to VLC or HA when running. What I can’t get to work is the sensor part of the example used to know if the addon is running.

Documents show this

  - platform: rest
    resource: "http://hassio.local:port/api/hassio/addons/xxxxxxxx_ringlivestream/info"
      Authorization: "Bearer [Long_Lived_Access_Token]"
      Content-Type: application/json
    name: ring_addon_state
    value_template: "{{value_json['data']['state']}}" 

but I can get it to show up even looking for the sensor in the development tools its not there.
I have looked at the rest sensor documentation and there seems to be some differences in the use of " " in the resource, Authorisation, and value_template lines.
also the use of :port in the resource line

I have tried a few combinations but can get it to show up

any help appreciated

here is my config for reference with a few x’s for security

  - platform: rest
    resource: "https://192.168.x.xxx:xxxx/api/hassio/addons/xxxxxxxx_ringlivestream/info"
      Authorization: "Bearer xxxxx"
      Content-Type: application/json
    name: ring_addon_state
    value_template: "{{value_json['data']['state']}}" 

Hey Kaz, I am not getting the live-stream to work; I am doing something wrong with the ports, I presume. Can you clarify which ports you use where and which to forward on your router?

I am getting an error message when i try to add the repo to HACS

Repostitory structure for 1.3.7 is not compliant

Any ideas

I got everything installed, and my cameras are now available in homekit just fine.

Several questions

  1. I can not get them working in Hassio, the ip address in the config.yaml for the generic camera is that the ip of the camera, homekit or hassio?
  2. How do i get it working with multiple cameras, the configuration panel of the addon, only accepts one camera name