Roborock s5 Max wifi

Hi all, I am trying to integrate the robot, but I cannot find a version of xiaomi mi home that detects my vacuum and token.

Seems that there are problems after the update to 1026 version. I have the same problem :frowning:

I was trying to get the token last couple days on Android, today I took the time to get the token and I got it after 4 hours trial and error, tried different apk’s none of those worked except this one (but read my explanation below):

If you have the Roborock app, delete data first and remove the app and never install it back :yum:

Do not remove the roborock between the tries from the app you use, first install the latest version from play store, in my case I used The Netherlands as region but 5.4.49 does not have Netherlands so I choose Europe. After your Roborock S5 Max shows it’s map in the app, remove the app (do not delete data) and install 5.4.49 and open the app, after login the vacuum will be there, try to tap on it couple times, it will give error and wont open the map or anything, close the app and get the log file from “Plug_Devicemanager” the last token shown there should be the correct one. Now you can remove the app (don’t touch the data) and reinstall the latest one from play store.

DO NOT try to connect to the robot through HA integrations, instead wait couple minutes and add this in your configuration.yaml:

  - platform: xiaomi_miio
    host: 192.168.1.xx
    token: 01234567891g123456789f0123456789

Replace the host with the IP adres of your Robodock S5 MAX and use the token you got earlier. reboot HA and the entity will show in your list (at least it did for me)

There was also problem with the integrations when I tried to add from there, every time I tried, it give me errors like “unknown error” or “fail to connect” But putting it manually in the configuration.yaml did the trick for me.

Our Roborock S5 Max has firmware: 3.5.8_1026 and I am on HA 0.117.1

Added in to my tablet dash with lovelace:


I used same method as you described as it seems a lot of the other methods in doc doesn’t work for Xiaomi Roborock S5 Max newer firmware. I did get the token and the IP, but still the entity in HA remained unavailable, not sure wether the token was changed or something else.

Does someone else in house hold have the app installed too? Like Roborock app itself or Xiaomi app, if so remove those too, and try to get the token again, and put it in the configuration.yaml.

Check also if the IP adres is correct in the log file with your router, and make sure it gets a dedicated IP adres through your router.

Yes IP is correct and no-one else is controlling the vacuuming through the mobile app.

Does the python-miio cli works for you and also returns the vacuums status?

I am able to see all details, and compared to the Xiaomi Home app everything is correct.

Hi guys, since firmware update 3.5.8_1026 (HA is vers. 0.117.6) on my S5 Max I got massive wifi connections issues. the vacuum loses connection after a few hours and won’t reconnect to wifi, just turning vacuum off and on bring him back for a short period.

any suggestions?

I’m having the same issues. Home Assistant seems to find the vacuum after reboot once I connect to it and start it from the Mi Home app. I have five S6, and it’s affecting all of them. They all show up as unavailable until they’re started.

I reset the wifi, no improvement, vacuum was kicked out at 6 in the morning every day from wifi. I think this is a kind of bug in the new firmware 3.5.8_1026. A couple of hours ago I decided to do a factory reset, which brought back the old firmware.

Will keep you posted!

Back on 3.5.8_0876 and everything is fine :pray:

Did you have to get a new token, or does the old one work?

New one.
But easy going to get it.

Hi there,

i tried to integrate my Roborock S7 into Home Assistant.

I configured this in the config.yaml


  • platform: xiaomi_miio
    name: Roborock
    token: 12736916478623546523476235

After that the Xiaomi Miio Integration shows up a new Device, but I didn’t get a entity_id.

So i removed it from my config.yaml and tried again, but then i got the following issue:

“platform error vacuum.xiaomi_miio - cannot import name ‘gatewayexception‘ from ‘miio.gateway‘”

Then I tried to install the Xiaomi Miio Integration and get this issue:

“config flow could not be loaded”

Don’t know what to do… someone out there some ideas ?